<!doctype html>
<html lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=1">
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<link rel="pingback" href="https://www.theyoungfolks.com/xmlrpc.php">
	<link rel="icon" href="https://www.theyoungfolks.com/wp-content/uploads/2016/07/cropped-tyf-logo-2016-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://www.theyoungfolks.com/wp-content/uploads/2016/07/cropped-tyf-logo-2016-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.theyoungfolks.com/wp-content/uploads/2016/07/cropped-tyf-logo-2016-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://www.theyoungfolks.com/wp-content/uploads/2016/07/cropped-tyf-logo-2016-270x270.jpg" />
		
	<meta http-equiv="x-dns-prefetch-control" content="on">
	<link rel="dns-prefetch" href="//fonts.googleapis.com" />
	<link rel="dns-prefetch" href="//fonts.gstatic.com" />
	<link rel="dns-prefetch" href="//0.gravatar.com/" />
	<link rel="dns-prefetch" href="//2.gravatar.com/" />
	<link rel="dns-prefetch" href="//1.gravatar.com/" />
	<title>The Hip Hop Roundup: The Best From May So Far | The Young Folks</title>

<!-- All In One SEO Pack 3.4.3[1209,1297] -->
<meta name="description"  content="The hip hop roundup returns with new tracks/projects from RLouie, Ric Wilson and Terrace Martin, Lil Tjay, 909 Memphis, Duwap Kaine, Blocboy JB, and Peggy." />

<meta name="keywords"  content="rlouie new ep,lil tjay new song,909 memphis new song,duwap kaine new song,blocboy jb new song,ric wilson and terrace martin new ep,jpeg mafia new songs" />

<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.theyoungfolks.com/#organization","url":"https://www.theyoungfolks.com/","name":"The Young Folks","sameAs":["https://www.facebook.com/TYFofficial/","https://twitter.com/tyfofficial","https://www.instagram.com/TYFofficial/"]},{"@type":"WebSite","@id":"https://www.theyoungfolks.com/#website","url":"https://www.theyoungfolks.com/","name":"The Young Folks","publisher":{"@id":"https://www.theyoungfolks.com/#organization"}},{"@type":"WebPage","@id":"https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/#webpage","url":"https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/","inLanguage":"en-US","name":"The Hip Hop Roundup: The Best From May's First Week","isPartOf":{"@id":"https://www.theyoungfolks.com/#website"},"breadcrumb":{"@id":"https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/#breadcrumblist"},"description":"The hip hop roundup returns with new tracks/projects from RLouie, Ric Wilson and Terrace Martin, Lil Tjay, 909 Memphis, Duwap Kaine, Blocboy JB, and Peggy.","image":{"@type":"ImageObject","@id":"https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/#primaryimage","url":"https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1.png","width":497,"height":499},"primaryImageOfPage":{"@id":"https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/#primaryimage"},"datePublished":"2020-05-14T14:00:00-04:00","dateModified":"2020-05-14T01:02:20-04:00"},{"@type":"Article","@id":"https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/#article","isPartOf":{"@id":"https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/#webpage"},"author":{"@id":"https://www.theyoungfolks.com/author/rfeyre/#author"},"headline":"The Hip Hop Roundup: The Best From May&#8217;s First Week","datePublished":"2020-05-14T14:00:00-04:00","dateModified":"2020-05-14T01:02:20-04:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/#webpage"},"publisher":{"@id":"https://www.theyoungfolks.com/#organization"},"articleSection":"Music, Music Features, 49th Parallel, 909 Memphis, Blocboy JB, Cash Bentley, Denzel Curry, Duwap Kaine, Fivio Foreign, Hip Hop Roundup, JPEGMAFIA, Lil Tjay, Peggy, Pop Smoke, Ric Wilson, RLouie, Terrace Martin","image":{"@type":"ImageObject","@id":"https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/#primaryimage","url":"https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1.png","width":497,"height":499}},{"@type":"Person","@id":"https://www.theyoungfolks.com/author/rfeyre/#author","name":"Ryan Feyre","sameAs":[]},{"@type":"BreadcrumbList","@id":"https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/#breadcrumblist","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.theyoungfolks.com/","url":"https://www.theyoungfolks.com/","name":"The Young Folks: Reviews of Films, Music, TV, Books, and Video Games - Written by young people for young people"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/","url":"https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/","name":"The Hip Hop Roundup: The Best From May's First Week"}}]}]}</script>
<link rel="canonical" href="https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/" />
<meta property="og:type" content="article" />
<meta property="og:title" content="The Hip Hop Roundup: The Best From May So Far" />
<meta property="og:description" content="The hip hop roundup returns with new tracks/projects from RLouie, Ric Wilson and Terrace Martin, Lil Tjay, 909 Memphis, Duwap Kaine, Blocboy JB, and Peggy." />
<meta property="og:url" content="https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/" />
<meta property="og:site_name" content="The Young Folks" />
<meta property="og:image" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1.png" />
<meta property="fb:admins" content="156189131064135" />
<meta property="fb:app_id" content="449377471938761" />
<meta property="article:published_time" content="2020-05-14T14:00:00Z" />
<meta property="article:modified_time" content="2020-05-14T01:02:20Z" />
<meta property="article:publisher" content="//www.facebook.com/TheYoungFolks" />
<meta property="og:image:secure_url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1.png" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@TheYoungFolks" />
<meta name="twitter:domain" content="TheYoungFolks.com" />
<meta name="twitter:title" content="The Hip Hop Roundup: The Best From May So Far" />
<meta name="twitter:description" content="The hip hop roundup returns with new tracks/projects from RLouie, Ric Wilson and Terrace Martin, Lil Tjay, 909 Memphis, Duwap Kaine, Blocboy JB, and Peggy." />
<meta name="twitter:image" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1.png" />
			<script type="text/javascript" >
				window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
				ga('create', 'UA-12374332-4', 'auto');
				// Plugins
				
				ga('send', 'pageview');
			</script>
			<script async src="https://www.google-analytics.com/analytics.js"></script>
			<!-- All In One SEO Pack -->
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Young Folks &raquo; Feed" href="https://www.theyoungfolks.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Young Folks &raquo; Comments Feed" href="https://www.theyoungfolks.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Young Folks &raquo; The Hip Hop Roundup: The Best From May&#8217;s First Week Comments Feed" href="https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/feed/" />
						<meta property="og:title" content="The Hip Hop Roundup: The Best From May&#8217;s First Week" />
			<meta property="og:type" content="article" />
			<meta property="og:description" content="RLouie &#8211; Louie Black Massachusetts continues an unprecedented hot streak with these celebratory collaborative efforts. Less than a month after ALFII released his video game anthology, Brockton n" />
			<meta property="og:image" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1.png" />
			<meta property="og:url" content="https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/" />
			<!-- This site uses the Google Analytics by ExactMetrics plugin v6.0.2 - Using Analytics tracking - https://www.exactmetrics.com/ -->
<script type="text/javascript" data-cfasync="false">
	var em_version         = '6.0.2';
	var em_track_user      = true;
	var em_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-12374332-4';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( em_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

window.ga = __gaTracker;		__gaTracker('create', 'UA-12374332-4', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
		__gaTracker( function() { window.ga = __gaTracker; } );
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + em_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
			window.ga = __gaTracker;		})();
		}
</script>
<!-- / Google Analytics by ExactMetrics -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.theyoungfolks.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.4.1/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://www.theyoungfolks.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.3.10' type='text/css' media='all' />
<link rel='stylesheet' id='ctf_styles-css'  href='https://www.theyoungfolks.com/wp-content/plugins/custom-twitter-feeds/css/ctf-styles.css?ver=1.3' type='text/css' media='all' />
<link rel='stylesheet' id='math-captcha-frontend-css'  href='https://www.theyoungfolks.com/wp-content/plugins/wp-math-captcha/css/frontend.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='thb-fa-css'  href='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/assets/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thb-app-css'  href='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/assets/css/app.css?ver=2.1.2' type='text/css' media='all' />
<style id='thb-app-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='style-css'  href='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='thb-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Droid+Serif%3A300%2C400%2C500%2C600%2C700%2C900%7CPoppins%3A300%2C400%2C500%2C600%2C700%2C900&#038;subset=latin%2Clatin-ext&#038;ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.5/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.5/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/www.theyoungfolks.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend.min.js?ver=6.0.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctf = {"ajax_url":"https:\/\/www.theyoungfolks.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.1/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.1/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://www.theyoungfolks.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.theyoungfolks.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.theyoungfolks.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Making FFVII Remake&#8217;s Ending Make Sense' href='https://www.theyoungfolks.com/video-games/143085/making-ffvii-remakes-ending-make-sense/' />
<link rel='next' title='Book Review: Forged in Fire and Stars by Andrea Robertson' href='https://www.theyoungfolks.com/review/143235/forged-in-fire-and-stars-andrea-robertson/' />
<meta name="generator" content="WordPress 5.4.1" />
<link rel='shortlink' href='https://wp.me/p5gXzl-BgU' />
<link rel="alternate" type="application/json+oembed" href="https://www.theyoungfolks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F143276%2Fthe-hip-hop-roundup-the-best-from-mays-first-week%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.theyoungfolks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F143276%2Fthe-hip-hop-roundup-the-best-from-mays-first-week%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.theyoungfolks.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><link rel="icon" href="https://www.theyoungfolks.com/wp-content/uploads/2016/07/cropped-tyf-logo-2016-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://www.theyoungfolks.com/wp-content/uploads/2016/07/cropped-tyf-logo-2016-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.theyoungfolks.com/wp-content/uploads/2016/07/cropped-tyf-logo-2016-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://www.theyoungfolks.com/wp-content/uploads/2016/07/cropped-tyf-logo-2016-270x270.jpg" />
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>		<meta name="norton-safeweb-site-verification" content="rwr0f6kx274t8xgjjttouapy0u9kpb0pomx7w4ozxn4715jrqzi8dkb6vugohvgwsixwypfm3vwz9ly9lxpj3q9qj4bw56r88xchfe1u8h7bjn63zodcnkdzo47rjg7w" />
</head>
<body class="post-template-default single single-post postid-143276 single-format-standard lazy-load-on thb_ads_header_mobile_off thb-lightbox-off thb-capitalize-off wpb-js-composer js-comp-ver-5.1.1 vc_responsive" data-themeurl="https://www.theyoungfolks.com/wp-content/themes/goodlife-wp">
<div id="wrapper" class="open">
	
	<!-- Start Mobile Menu -->
			<nav id="mobile-menu">
			<div class="custom_scroll" id="menu-scroll">
				<div>
															  <ul id="menu-mobile-menu" class="mobile-menu"><li id="menu-item-135843" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-135843"><a title="About" href="https://www.theyoungfolks.com/about-2/"><span><i class="fa fa-plus"></i></span>About</a>
<ul class="sub-menu">
	<li id="menu-item-135845" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-135845"><a title="About The Young Folks" href="https://www.theyoungfolks.com/about-2/">About The Young Folks</a></li>
	<li id="menu-item-98506" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-98506"><a href="https://www.theyoungfolks.com/write/">Join the TYF Team!</a></li>
	<li id="menu-item-98507" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-98507"><a href="https://www.theyoungfolks.com/review-policy/general-comment-policy/">General Comment Policy</a></li>
</ul>
</li>
<li id="menu-item-98510" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98510 menu-item-category-6"><a href="https://www.theyoungfolks.com/books/"><span><i class="fa fa-plus"></i></span>Books</a>
<ul class="sub-menu">
	<li id="menu-item-98513" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98513 menu-item-category-1781"><a href="https://www.theyoungfolks.com/books/book-reviews/">Book Reviews</a></li>
	<li id="menu-item-98512" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98512 menu-item-category-1784"><a href="https://www.theyoungfolks.com/books/book-news/">Book News</a></li>
	<li id="menu-item-98511" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98511 menu-item-category-1785"><a href="https://www.theyoungfolks.com/books/book-features/">Book Features</a></li>
	<li id="menu-item-98514" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98514 menu-item-category-14026"><a href="https://www.theyoungfolks.com/books/comics/">Comics &#038; Graphic Novels</a></li>
</ul>
</li>
<li id="menu-item-98515" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98515 menu-item-category-3"><a href="https://www.theyoungfolks.com/film/"><span><i class="fa fa-plus"></i></span>Film</a>
<ul class="sub-menu">
	<li id="menu-item-98519" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98519 menu-item-category-1780"><a href="https://www.theyoungfolks.com/film/movie-reviews/">Movie Reviews</a></li>
	<li id="menu-item-98518" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98518 menu-item-category-1782"><a href="https://www.theyoungfolks.com/film/movie-news/">Movie News</a></li>
	<li id="menu-item-98517" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98517 menu-item-category-1783"><a href="https://www.theyoungfolks.com/film/movie-features/">Movie Features</a></li>
	<li id="menu-item-98521" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98521 menu-item-category-1450"><a href="https://www.theyoungfolks.com/film/the-film-canon/">The Film Canon</a></li>
</ul>
</li>
<li id="menu-item-98528" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-98528 menu-item-category-4"><a href="https://www.theyoungfolks.com/music/"><span><i class="fa fa-plus"></i></span>Music</a>
<ul class="sub-menu">
	<li id="menu-item-98533" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98533 menu-item-category-1786"><a href="https://www.theyoungfolks.com/music/music-reviews/"><span><i class="fa fa-plus"></i></span>Music Reviews</a>
	<ul class="sub-menu">
		<li id="menu-item-98529" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98529 menu-item-category-5"><a href="https://www.theyoungfolks.com/music/concerts/">Concert Reviews</a></li>
	</ul>
</li>
	<li id="menu-item-98532" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98532 menu-item-category-1787"><a href="https://www.theyoungfolks.com/music/music-news/">Music News</a></li>
	<li id="menu-item-98531" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-98531 menu-item-category-1788"><a href="https://www.theyoungfolks.com/music/music-features/">Music Features</a></li>
	<li id="menu-item-98530" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98530 menu-item-category-11890"><a href="https://www.theyoungfolks.com/music/from-the-record-crate/">From the Record Crate</a></li>
</ul>
</li>
<li id="menu-item-98534" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98534 menu-item-category-7"><a href="https://www.theyoungfolks.com/television/"><span><i class="fa fa-plus"></i></span>Television</a>
<ul class="sub-menu">
	<li id="menu-item-98537" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98537 menu-item-category-1793"><a href="https://www.theyoungfolks.com/television/tv-reviews/">TV Reviews</a></li>
	<li id="menu-item-98536" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98536 menu-item-category-1794"><a href="https://www.theyoungfolks.com/television/tv-news-television/">TV News</a></li>
	<li id="menu-item-98535" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98535 menu-item-category-1795"><a href="https://www.theyoungfolks.com/television/tv-features/">TV Features</a></li>
</ul>
</li>
<li id="menu-item-98541" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98541 menu-item-category-13"><a href="https://www.theyoungfolks.com/video-games/"><span><i class="fa fa-plus"></i></span>Video Games</a>
<ul class="sub-menu">
	<li id="menu-item-98544" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98544 menu-item-category-1797"><a href="https://www.theyoungfolks.com/video-games/video-game-reviews/">Video Game Reviews</a></li>
	<li id="menu-item-98542" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98542 menu-item-category-1798"><a href="https://www.theyoungfolks.com/video-games/gaming-news/">Gaming News</a></li>
	<li id="menu-item-98543" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98543 menu-item-category-1799"><a href="https://www.theyoungfolks.com/video-games/video-game-features/">Video Game Features</a></li>
</ul>
</li>
<li id="menu-item-98538" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98538 menu-item-category-259"><a title="Lists" href="https://www.theyoungfolks.com/top-10-2/">Lists</a></li>
<li id="menu-item-98540" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98540 menu-item-category-15"><a href="https://www.theyoungfolks.com/tyf-media/podcast/"><span><i class="fa fa-plus"></i></span>Podcasts</a>
<ul class="sub-menu">
	<li id="menu-item-98508" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98508 menu-item-category-6411"><a href="https://www.theyoungfolks.com/tyf-media/tyf-vlog/">Videos</a></li>
</ul>
</li>
<li id="menu-item-98522" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98522 menu-item-category-1789"><a href="https://www.theyoungfolks.com/giveaways/"><span><i class="fa fa-plus"></i></span>Giveaways</a>
<ul class="sub-menu">
	<li id="menu-item-98523" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98523 menu-item-category-1791"><a href="https://www.theyoungfolks.com/giveaways/book-giveaways/">Book Giveaways</a></li>
	<li id="menu-item-98524" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98524 menu-item-category-1790"><a href="https://www.theyoungfolks.com/giveaways/movie-giveaways/"><span><i class="fa fa-plus"></i></span>Movie Giveaways</a>
	<ul class="sub-menu">
		<li id="menu-item-98526" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98526 menu-item-category-1266"><a href="https://www.theyoungfolks.com/giveaways/screening/">Screenings</a></li>
	</ul>
</li>
	<li id="menu-item-98525" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98525 menu-item-category-1792"><a href="https://www.theyoungfolks.com/giveaways/music-giveaways/">Music Giveaways</a></li>
	<li id="menu-item-98527" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98527 menu-item-category-12263"><a href="https://www.theyoungfolks.com/giveaways/tv-giveaways/">TV Giveaways</a></li>
</ul>
</li>
</ul>															<div class="social-links">
								<a href="https://www.facebook.com/TheYoungFolks" class="facebook icon-1x" target="_blank"><i class="fa fa-facebook"></i></a>
				<a href="https://twitter.com/theyoungfolks" class="twitter icon-1x" target="_blank"><i class="fa fa-twitter"></i></a>
				<a href="https://www.instagram.com/theyoungfolks/" class="instagram icon-1x" target="_blank"><i class="fa fa-instagram"></i></a>
							<a href="https://soundcloud.com/tyfofficial" class="soundcloud icon-1x" target="_blank"><i class="fa fa-soundcloud"></i></a>
				<a href="https://www.youtube.com/c/theyoungfolks" class="youtube icon-1x" target="_blank"><i class="fa fa-youtube"></i></a>
			<a href="https://play.spotify.com/user/tyfofficial" class="spotify icon-1x" target="_blank"><i class="fa fa-spotify"></i></a>
					<a href="https://feeds.feedburner.com/TheYoungFolks" class="rss icon-1x" target="_blank"><i class="fa fa-rss"></i></a>
							</div>
					<div class="menu-footer">
											</div>
				</div>
			</div>
		</nav>
		<!-- End Mobile Menu -->
	
	<!-- Start Content Container -->
	<section id="content-container">
		<!-- Start Content Click Capture -->
		<div class="click-capture"></div>
		<!-- End Content Click Capture -->
		<!-- Start Fixed Header -->
<div class="subheader fixed show-for-large light">
			<div class="row full-width-row">
			<div class="medium-8 columns logo">
				<div>
										<a href="https://www.theyoungfolks.com/" class="logolink">
						<img src="/wp-content/uploads/2017/02/2017-logo-21.png" class="logoimg" alt="The Young Folks"/>
					</a>
					<span class="page-title" id="page-title">The Hip Hop Roundup: The Best From May&#8217;s First Week</span>
				</div>
			</div>
			<div class="medium-4 columns">
				 		<aside class="share-article-vertical hide-on-print ">
		<h6>0<span>Shares</span></h6>

				<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F143276%2Fthe-hip-hop-roundup-the-best-from-mays-first-week%2F" class="facebook social"><i class="fa fa-facebook"></i><span>0</span></a>
						<a href="https://twitter.com/intent/tweet?text=The+Hip+Hop+Roundup%3A+The+Best+From+May%E2%80%99s+First+Week&url=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F143276%2Fthe-hip-hop-roundup-the-best-from-mays-first-week%2F&via=theyoungfolks" class="twitter social "><i class="fa fa-twitter"></i><span>0</span></a>
								<a href="http://pinterest.com/pin/create/link/?url=https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/&media=https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1.png&description=The+Hip+Hop+Roundup%3A+The+Best+From+May%E2%80%99s+First+Week" class="pinterest social" nopin="nopin" data-pin-no-hover="true"><i class="fa fa-pinterest"></i><span>0</span></a>
						<a href="https://www.linkedin.com/cws/share?url=https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/" class="linkedin social"><i class="fa fa-linkedin"></i><span>0</span></a>
						<a href="whatsapp://send?text=The+Hip+Hop+Roundup%3A+The+Best+From+May%E2%80%99s+First+Week" class="whatsapp social" data-href="https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/" data-action="share/whatsapp/share"><i class="fa fa-whatsapp"></i><span><i class="fa fa-whatsapp"></i></span></a>
			</aside>
				</div>
							<span class="progress"></span>
					</div>
		
	</div>
<!-- End Fixed Header -->
<!-- Start Sub Header -->
<div class="subheader show-for-large light ">
	<div class="row full-width-row">
		<div class="small-12 medium-6 large-7 columns">
			<nav class="subheader-menu">
				<ul id="menu-home" class="sf-menu"><li id="menu-item-12558" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-12558"><a href="https://www.theyoungfolks.com/">Home</a></li>
<li id="menu-item-135846" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135846"><a href="https://www.theyoungfolks.com/about-2/">About The Young Folks</a></li>
<li id="menu-item-12561" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12561"><a href="https://www.theyoungfolks.com/review-policy/">Review &#038; Promotion Policy</a></li>
<li id="menu-item-63212" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63212"><a href="https://www.theyoungfolks.com/review-policy/general-comment-policy/">TYF Comment Policy</a></li>
<li id="menu-item-12562" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12562"><a href="https://www.theyoungfolks.com/write/">Join the TYF Team!</a></li>
</ul>			</nav>
		</div>
		<div class="small-12 medium-6 large-5 columns text-right">
			<ul class="sf-menu right-menu">
					<li class="menu-item-has-children">
		<a href="#">Follow Us</a>
		<ul class="sub-menu">
						<li><a href="https://www.facebook.com/TheYoungFolks" class="facebook icon-1x" target="_blank"><i class="fa fa-facebook"></i> Facebook</a></li>
												<li><a href="https://twitter.com/theyoungfolks" class="twitter icon-1x" target="_blank"><i class="fa fa-twitter"></i> Twitter</a></li>
												<li><a href="https://www.instagram.com/theyoungfolks/" class="instagram icon-1x" target="_blank"><i class="fa fa-instagram"></i> Instagram</a></li>
																					<li><a href="https://soundcloud.com/tyfofficial" class="soundcloud icon-1x" target="_blank"><i class="fa fa-soundcloud"></i> Soundcloud</a></li>
												<li><a href="https://www.youtube.com/c/theyoungfolks" class="youtube icon-1x" target="_blank"><i class="fa fa-youtube"></i> Youtube</a></li>
									<li><a href="https://play.spotify.com/user/tyfofficial" class="spotify icon-1x" target="_blank"><i class="fa fa-spotify"></i> Spotify</a></li>
															<li><a href="https://feeds.feedburner.com/TheYoungFolks" class="rss icon-1x" target="_blank"><i class="fa fa-rss"></i> RSS</a></li>
									<li><a href="https://www.twitch.tv/tyfofficial" class="twitch icon-1x" target="_blank"><i class="fa fa-twitch"></i> Twitch.tv</a></li>
					</ul>
	</li>
									<li>	<div class="quick_search">
		<a href="#" class="quick_toggle"></a>
		<svg version="1.1" class="quick_search_icon" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="20px" height="20px" viewBox="0 -1 20 18" xml:space="preserve">
			<path d="M18.96,16.896l-4.973-4.926c1.02-1.255,1.633-2.846,1.633-4.578c0-4.035-3.312-7.317-7.385-7.317S0.849,3.358,0.849,7.393
				c0,4.033,3.313,7.316,7.386,7.316c1.66,0,3.188-0.552,4.422-1.471l4.998,4.95c0.181,0.179,0.416,0.268,0.652,0.268
				c0.235,0,0.472-0.089,0.652-0.268C19.32,17.832,19.32,17.253,18.96,16.896z M2.693,7.393c0-3.027,2.485-5.489,5.542-5.489
				c3.054,0,5.541,2.462,5.541,5.489c0,3.026-2.486,5.489-5.541,5.489C5.179,12.882,2.693,10.419,2.693,7.393z"/>
		</svg>
		<!-- Start SearchForm -->
<form method="get" class="searchform" role="search" action="https://www.theyoungfolks.com/">
    <fieldset>
    	<input name="s" type="text" placeholder="Search" class="s">
    	<input type="submit" value="Search">
    </fieldset>
</form>
<!-- End SearchForm -->	</div>
	
</li>			</ul>
		</div>
	</div>
</div>
<!-- End Sub Header -->
<!-- Start Header -->
<header class="header style3  light" role="banner">
	<div class="row">
		<div class="small-2 columns text-left mobile-icon-holder">
			<a href="#" data-target="open-menu" class="mobile-toggle"><i class="fa fa-bars"></i></a>
		</div>
		<div class="small-8 large-12 columns logo">
			<div id="menu_width">
								<a href="https://www.theyoungfolks.com/" class="logolink">
					<img src="/wp-content/uploads/2017/02/2017-logo-21.png" class="logoimg" alt="The Young Folks"/>
				</a>
				<nav class="menu-holder">
										  <ul id="menu-main-nav-categories" class="sf-menu style3"><li id="menu-item-12523" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12523 menu-item-category-3"><a title="Movies" href="https://www.theyoungfolks.com/film/">Movies</a>


<ul class="sub-menu ">
	<li id="menu-item-12536" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12536 menu-item-category-1780"><a href="https://www.theyoungfolks.com/film/movie-reviews/">Movie Reviews</a></li>
	<li id="menu-item-12535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12535 menu-item-category-1782"><a href="https://www.theyoungfolks.com/film/movie-news/">Movie News</a></li>
	<li id="menu-item-12534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12534 menu-item-category-1783"><a title="Movie Features" href="https://www.theyoungfolks.com/film/movie-features/">Movie Features</a></li>
	<li id="menu-item-12537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12537 menu-item-category-1450"><a href="https://www.theyoungfolks.com/film/the-film-canon/">The Film Canon</a>
	<ul class="sub-menu ">
		<li id="menu-item-12807" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12807"><a title="TFC Index" href="https://www.theyoungfolks.com/the-film-canon/">TFC Index</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-12522" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12522 menu-item-category-6"><a href="https://www.theyoungfolks.com/books/">Books</a>


<ul class="sub-menu ">
	<li id="menu-item-12532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12532 menu-item-category-1781"><a href="https://www.theyoungfolks.com/books/book-reviews/">Book Reviews</a>
	<ul class="sub-menu ">
		<li id="menu-item-12899" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12899 menu-item-category-1925"><a href="https://www.theyoungfolks.com/books/book-reviews/audiobook-reviews/">Audiobook Reviews</a></li>
	</ul>
</li>
	<li id="menu-item-12530" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12530 menu-item-category-1785"><a href="https://www.theyoungfolks.com/books/book-features/">Book Features</a></li>
	<li id="menu-item-12531" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12531 menu-item-category-1784"><a href="https://www.theyoungfolks.com/books/book-news/">Book News</a></li>
	<li id="menu-item-54742" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54742 menu-item-category-14026"><a href="https://www.theyoungfolks.com/books/comics/">Comics &#038; Graphic Novels</a></li>
</ul>
</li>
<li id="menu-item-12525" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-12525 menu-item-category-4"><a href="https://www.theyoungfolks.com/music/">Music</a>


<ul class="sub-menu ">
	<li id="menu-item-12545" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12545 menu-item-category-1786"><a href="https://www.theyoungfolks.com/music/music-reviews/">Music Reviews</a></li>
	<li id="menu-item-12542" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12542 menu-item-category-5"><a href="https://www.theyoungfolks.com/music/concerts/">Concert Reviews</a></li>
	<li id="menu-item-12544" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12544 menu-item-category-1787"><a href="https://www.theyoungfolks.com/music/music-news/">Music News</a></li>
	<li id="menu-item-12543" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12543 menu-item-category-1788"><a href="https://www.theyoungfolks.com/music/music-features/">Music Features</a></li>
	<li id="menu-item-43919" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-43919 menu-item-category-11890"><a href="https://www.theyoungfolks.com/music/from-the-record-crate/">From the Record Crate</a>
	<ul class="sub-menu ">
		<li id="menu-item-43920" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43920"><a title="FtRC Index" href="https://www.theyoungfolks.com/from-the-record-crate/">FtRC Index</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-12526" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12526 menu-item-category-7"><a href="https://www.theyoungfolks.com/television/">Television</a>


<ul class="sub-menu ">
	<li id="menu-item-12548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12548 menu-item-category-1793"><a href="https://www.theyoungfolks.com/television/tv-reviews/">TV Reviews</a></li>
	<li id="menu-item-12547" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12547 menu-item-category-1794"><a href="https://www.theyoungfolks.com/television/tv-news-television/">TV News</a></li>
	<li id="menu-item-12546" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12546 menu-item-category-1795"><a href="https://www.theyoungfolks.com/television/tv-features/">TV Features</a></li>
</ul>
</li>
<li id="menu-item-12529" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12529 menu-item-category-13"><a href="https://www.theyoungfolks.com/video-games/">Video Games</a>


<ul class="sub-menu ">
	<li id="menu-item-12554" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12554 menu-item-category-1797"><a href="https://www.theyoungfolks.com/video-games/video-game-reviews/">Video Game Reviews</a></li>
	<li id="menu-item-12552" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12552 menu-item-category-1798"><a href="https://www.theyoungfolks.com/video-games/gaming-news/">Gaming News</a></li>
	<li id="menu-item-12553" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12553 menu-item-category-1799"><a href="https://www.theyoungfolks.com/video-games/video-game-features/">Video Game Features</a></li>
</ul>
</li>
<li id="menu-item-12527" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12527 menu-item-category-259"><a title="Lists" href="https://www.theyoungfolks.com/top-10-2/">Lists</a></li>
<li id="menu-item-83832" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-83832"><a href="https://www.theyoungfolks.com/tyf-podcasts-video-series/">Podcasts &#038; More</a>


<ul class="sub-menu ">
	<li id="menu-item-12551" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12551 menu-item-category-15"><a href="https://www.theyoungfolks.com/tyf-media/podcast/">Podcasts</a></li>
	<li id="menu-item-24973" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24973 menu-item-category-6411"><a href="https://www.theyoungfolks.com/tyf-media/tyf-vlog/">Videos</a></li>
	<li id="menu-item-12549" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12549 menu-item-category-1796"><a href="https://www.theyoungfolks.com/tyf-column/editorials/">Editorials</a>
	<ul class="sub-menu ">
		<li id="menu-item-12550" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12550 menu-item-category-975"><a href="https://www.theyoungfolks.com/tyf-column/latinx-spotlight/">Latinx Spotlight</a></li>
	</ul>
</li>
</ul>
</li>
</ul>																			</nav>
			</div>
		</div>
		<div class="small-2 columns text-right mobile-share-holder">
			<div>
				<div class="quick_search">
		<a href="#" class="quick_toggle"></a>
		<svg version="1.1" class="quick_search_icon" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="20px" height="20px" viewBox="0 -1 20 18" xml:space="preserve">
			<path d="M18.96,16.896l-4.973-4.926c1.02-1.255,1.633-2.846,1.633-4.578c0-4.035-3.312-7.317-7.385-7.317S0.849,3.358,0.849,7.393
				c0,4.033,3.313,7.316,7.386,7.316c1.66,0,3.188-0.552,4.422-1.471l4.998,4.95c0.181,0.179,0.416,0.268,0.652,0.268
				c0.235,0,0.472-0.089,0.652-0.268C19.32,17.832,19.32,17.253,18.96,16.896z M2.693,7.393c0-3.027,2.485-5.489,5.542-5.489
				c3.054,0,5.541,2.462,5.541,5.489c0,3.026-2.486,5.489-5.541,5.489C5.179,12.882,2.693,10.419,2.693,7.393z"/>
		</svg>
		<!-- Start SearchForm -->
<form method="get" class="searchform" role="search" action="https://www.theyoungfolks.com/">
    <fieldset>
    	<input name="s" type="text" placeholder="Search" class="s">
    	<input type="submit" value="Search">
    </fieldset>
</form>
<!-- End SearchForm -->	</div>
	
			</div>
		</div>
	</div>
</header>
<!-- End Header -->		
		<div role="main" class=""><div id="infinite-article" data-infinite="on" class="on">
			<div class="row post-detail-row top-padding">
	<div class="small-12 medium-8 columns">

	  <article itemscope itemtype="http://schema.org/Article" class="post blog-post post-143276 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-features tag-49th-parallel tag-909-memphis tag-blocboy-jb tag-cash-bentley tag-denzel-curry tag-duwap-kaine tag-fivio-foreign tag-hip-hop-roundup tag-jpegmafia tag-lil-tjay tag-peggy tag-pop-smoke tag-ric-wilson tag-rlouie tag-terrace-martin" id="post-143276" role="article" data-id="143276" data-url="https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/">
	  	<header class="post-title entry-header">
	  		<a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a>	  		<h1 class="entry-title" itemprop="name headline">The Hip Hop Roundup: The Best From May&#8217;s First Week</h1>	  			<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time" datetime="2020-05-14T10:00:00-04:00" itemprop="datePublished" content="2020-05-14T10:00:00-04:00">May 14, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-05-13T21:02:20-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1.png">
		  <meta itemprop="width" content="497">
		  <meta itemprop="height" content="499">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/">
							</aside>
		  	</header>
	  		  	<figure class="post-gallery">
	  		<img width="497" height="499" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1.png" class="attachment-goodlife-post-style1 size-goodlife-post-style1 wp-post-image" alt="" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1.png 497w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1-150x150.png 150w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1-24x24.png 24w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1-48x48.png 48w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1-96x96.png 96w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1-300x300.png 300w" sizes="(max-width: 497px) 100vw, 497px" />	  			  	</figure>
	  		  	<div class="share-container">
		  	 		<aside class="share-article-vertical hide-on-print fixed-me show-for-medium">
		<h6>0<span>Shares</span></h6>

				<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F143276%2Fthe-hip-hop-roundup-the-best-from-mays-first-week%2F" class="facebook social"><i class="fa fa-facebook"></i><span>0</span></a>
						<a href="https://twitter.com/intent/tweet?text=The+Hip+Hop+Roundup%3A+The+Best+From+May%E2%80%99s+First+Week&url=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F143276%2Fthe-hip-hop-roundup-the-best-from-mays-first-week%2F&via=theyoungfolks" class="twitter social "><i class="fa fa-twitter"></i><span>0</span></a>
								<a href="http://pinterest.com/pin/create/link/?url=https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/&media=https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1.png&description=The+Hip+Hop+Roundup%3A+The+Best+From+May%E2%80%99s+First+Week" class="pinterest social" nopin="nopin" data-pin-no-hover="true"><i class="fa fa-pinterest"></i><span>0</span></a>
						<a href="https://www.linkedin.com/cws/share?url=https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/" class="linkedin social"><i class="fa fa-linkedin"></i><span>0</span></a>
						<a href="whatsapp://send?text=The+Hip+Hop+Roundup%3A+The+Best+From+May%E2%80%99s+First+Week" class="whatsapp social" data-href="https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/" data-action="share/whatsapp/share"><i class="fa fa-whatsapp"></i><span><i class="fa fa-whatsapp"></i></span></a>
			</aside>
				  <div class="post-content-container">
					<div class="post-content entry-content cf">
									    	
<h3>RLouie &#8211; <em>Louie Black</em></h3>



<figure class="wp-block-embed-soundcloud aligncenter wp-block-embed is-type-rich is-provider-soundcloud wp-embed-aspect-4-3 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<iframe title="Louie Black by RLouie" width="1170" height="450" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player/?visual=true&#038;url=https%3A%2F%2Fapi.soundcloud.com%2Fplaylists%2F1025770033&#038;show_artwork=true&#038;maxwidth=1170&#038;maxheight=1000&#038;dnt=1"></iframe>
</div></figure>



<p>Massachusetts continues an unprecedented hot streak with these celebratory collaborative efforts. Less than a month after ALFII released his video game<a href="https://soundcloud.com/alfiimusic/sets/avalanche-1" class="aioseop-link"> anthology</a>, Brockton native RLouie blesses local diehards with a six-track quick hitter that features soul-crushing 808s, summery Afro-beat renditions, and textural horn passages for added dimension. </p>



<p>RLouie is typically known for engineering some of Eastern Massachusetts&#8217; recent projects, but according to his Twitter account, <em>Louie Black </em>is a marvelous opportunity to showcase his production value. And boy does it pay off. </p>



<p>Much like in the case of ALFII, RLouie denotes the entirety of the instrumental space for local mainstays, particularly Luke Bar$, Lord Felix, Dupes, Saint Lyor, Jiles, Meech and Big Leano. All perform spectacularly on their desired platform, but it&#8217;s Bar$&#8217; helium-filled vocals that stand out across three different tracks. His typical melodic bungee jumping is present, but songs like &#8220;Change&#8221; and &#8220;Feel&#8221; prove that he carries perceptive singing chops as well. All of this confirms my theory that Brockton is the Atlanta of Massachusetts when it comes to hip hop. There&#8217;s so much talent it&#8217;s almost unfair. </p>



<h3>Lil Tjay (feat. Pop Smoke and Fivio Foreign&#8221;) &#8211; &#8220;Zoo York&#8221;</h3>



<figure class="wp-block-embed-youtube aligncenter wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<div class="flex-video widescreen youtube"><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' width='1170' height='659' src='https://www.youtube.com/embed/ToRiflECtU8?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent&#038;showinfo=0&#038;rel=0&#038;modestbranding=1' allowfullscreen='true' style='border:0;'></iframe></span></div>
</div></figure>



<p>After a life-changing 2019, Lil Tjay was destined for an even bigger start to the decade. He released his single &#8220;2020&#8221; on New Years, and bluntly laid out a blueprint for becoming the greatest artist in his genre. It&#8217;s a familiar narrative for sure, but it&#8217;s difficult to dissociate yourself from someone who sounds so young and yet so confident when that upper register is obtained. After all the prison time and heartache he felt from the loss of his friend Smelly (despite what Don Q may say), Tjay had finally &#8220;made it.&#8221;</p>



<p>Then in a matter of a month, things took a turn for the worse. Close friend (and New York drill messiah) and frequent collaborator Pop Smoke unexpectedly died in mid-February, and a crippling pandemic brought warlike imagery to New York. The 19-year-old had already witnessed a lot at an early age, and now this is just overkill. You can transparently hear and see the trauma in his most recent videos and songs. On &#8220;Ice Cold,&#8221; Tjay is spotted masked up with a gloomy backdrop emanating across the barracks of his home. No amount of money can help with this heartbreak, especially for someone who hasn&#8217;t even reached the drinking age yet.</p>



<p>To combat this lingering depression, Tjay released a seven-track EP aptly titled <em>State Of Emergency. </em>It mainly concentrates on the trendy harshness of Brooklyn drill courtesy of AXL Beats and 808 Melo. Nothing on the tape is different from what you could find on the Raps &amp; Hustles YouTube channel, though there are a few highlights. &#8220;Zoo York&#8221; is triumphantly one of them thanks to Tjay&#8217;s crackly harmonies and Pop Smoke&#8217;s growling cadence. This track simultaneously captures the current mood (just look at the title) and tastefully remembers a regional legend. Once again, long live the Woo. </p>



<h3>Ric Wilson &amp; Terrace Martin &#8211; <em>They Call Me Disco</em></h3>



<figure class="wp-block-embed-soundcloud wp-block-embed is-type-rich is-provider-soundcloud wp-embed-aspect-4-3 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<iframe title="They Call Me Disco by Ric Wilson" width="1170" height="450" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player/?visual=true&#038;url=https%3A%2F%2Fapi.soundcloud.com%2Fplaylists%2F1022749012&#038;show_artwork=true&#038;maxwidth=1170&#038;maxheight=1000&#038;dnt=1"></iframe>
</div></figure>



<p>Summer will not be the same in 2020, which is why music like this is so valuable. Ric Wilson and Terrace Martin&#8217;s new EP is like a needle in the haystack. A hidden gem in the midst of an unequivocal disaster. The suitable light at the end of this eerie tunnel. </p>



<p>Wilson and Martin imitate all of the best duos for a funk-induced expedition into Chicago&#8217;s illustrious backstreets. Glittering keys and piercing bass-lines circulate throughout the production as Wilson raps with the panache of early Donald Glover and sings with the celestial godliness of Devonte Hynes. This is the same type of laid-back mood music Thundercat experimented with earlier this year, except Wilson better identifies a pocket for Martin&#8217;s illustrious instrumentals. He raps about our current world with a universal perspective that doesn&#8217;t get lost in the beauty of the aforementioned landscape (&#8220;Got a mask on my face at the chick-fil-a/I just wanna be on right side of history/Whats the purpose?/Global warming is swarming around beyond the matrix/Why we out here killing for colorism and hatred?&#8221;). Wilson is part of the Chicago Young Authors for a reason.</p><div class="Wn7elqrU" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>



<p>Their sentiments are powerful yet purposefully euphoric. You can dance while feeling the weight of the world on your shoulders. Everyone should give this a listen. </p>



<h3>49th Parallel &#8211; &#8220;New Chevy&#8221;</h3>



<figure class="wp-block-embed-soundcloud aligncenter wp-block-embed is-type-rich is-provider-soundcloud wp-embed-aspect-4-3 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<iframe title="New Chevy by 49th Parallel" width="1170" height="400" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player/?visual=true&#038;url=https%3A%2F%2Fapi.soundcloud.com%2Ftracks%2F794119249&#038;show_artwork=true&#038;maxwidth=1170&#038;maxheight=1000&#038;dnt=1&#038;secret_token=s-6PUyJnw2pvv"></iframe>
</div></figure>



<p>49th Parallel are on the brink of becoming the next big rap group. The Seattle-based outfit released their debut album <em>Canvas </em>as a partnership with highly-regarded YouTube channel Yes Theory. The video associated with the album had over 3 million views, thereby positioning them for a luxurious future. </p>



<p>That same extravagance is showcased on their newest track &#8220;Chevy,&#8221; a catchy anthem that finds the collective slithering through jumpy drum patterns and alien-like synth flutters. The chorus particularly festers in your mind like any great song,as each member of the group highlights why they don&#8217;t need any help from big table conglomerates. All they need is a cult fanbase and one viral hit. This could be the one. Stay on the lookout for them. </p>



<h3>909 Memphis (feat. Cash Bentley) &#8211; &#8220;Falling Out of Love&#8221;</h3>



<figure class="wp-block-embed-soundcloud aligncenter wp-block-embed is-type-rich is-provider-soundcloud wp-embed-aspect-4-3 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<iframe title="909Memphis &amp; CashBently - Falling Out of Love (Prod. by Guala Beatz) by @909Memphis (memphy)" width="1170" height="400" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player/?visual=true&#038;url=https%3A%2F%2Fapi.soundcloud.com%2Ftracks%2F814415902&#038;show_artwork=true&#038;maxwidth=1170&#038;maxheight=1000&#038;dnt=1"></iframe>
</div></figure>



<p>Despite being from the DMV, 909Memphis has a strong grasp of midsummer antics, particularly falling in and out of love. On a collaborative cut with Cash Bentley, the melodic crooner is participating in the latter before summer even starts. The acoustic number evokes a dreamy aesthetic as each rapper&#8217;s ethereal inflections are swallowed hole by love&#8217;s emptiness. This is autotune done right. </p><div class="HZHWwrRD" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>



<h3>Duwap Kaine &#8211; &#8220;Smile&#8221;</h3>



<figure class="wp-block-embed-soundcloud aligncenter wp-block-embed is-type-rich is-provider-soundcloud wp-embed-aspect-4-3 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<iframe title="Smile by Kaine" width="1170" height="400" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player/?visual=true&#038;url=https%3A%2F%2Fapi.soundcloud.com%2Ftracks%2F811585168&#038;show_artwork=true&#038;maxwidth=1170&#038;maxheight=1000&#038;dnt=1"></iframe>
</div></figure>



<p>Duwap Kaine&#8217;s 2020 album <em>Bad Kid From the 4</em> is one of the most innovative rap projects to be released over the last three years. His voice glides across whatever self-produced shuttle he finds. He&#8217;s also one of the most unpredictable artists within the Soundcloud sphere, which is why his double-time style works so well across 18 tracks. </p>



<p>To capitalize on this momentum, Kaine provides listeners with a sputtering loosie that sounds like it&#8217;s in reverse the whole time. The production is inherently demonic, and yet it draws you in with its merry-go-round aesthetic. Kaine is as fidgety as ever, reminding listeners how high they should be when pressing play on his music. </p>



<p>One of his close friends advised him not to release this song on the night of Drake&#8217;s mixtape. Kaine did anyway, saying that it would go harder than Drizzy&#8217;s project. He was absolutely right.</p>



<h3>Blocboy JB &#8211; &#8220;Swervin'&#8221;</h3>



<figure class="wp-block-embed-soundcloud aligncenter wp-block-embed is-type-rich is-provider-soundcloud wp-embed-aspect-4-3 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<iframe title="Swervin by BlocBoy JB" width="1170" height="400" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player/?visual=true&#038;url=https%3A%2F%2Fapi.soundcloud.com%2Ftracks%2F778700920&#038;show_artwork=true&#038;maxwidth=1170&#038;maxheight=1000&#038;dnt=1"></iframe>
</div></figure>



<p>I find Blocboy&#8217;s music to be mind-numbingly uniform the majority of the time. This is a major exception, especially if you have the bass cranked up to the max while driving in your car. The song may knock your speakers out. Please don&#8217;t blame me for it. I&#8217;m still just a broke post-college student. </p><div class="VBh8fvFw" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>



<h3>Bonus: Listen to more Peggy. </h3>



<figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<div class="flex-video widescreen youtube"><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' width='1170' height='659' src='https://www.youtube.com/embed/t0yye8ThC1A?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent&#038;showinfo=0&#038;rel=0&#038;modestbranding=1' allowfullscreen='true' style='border:0;'></iframe></span></div>
</div></figure>



<figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<div class="flex-video widescreen youtube"><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' width='1170' height='659' src='https://www.youtube.com/embed/zjglQrx3Ex4?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent&#038;showinfo=0&#038;rel=0&#038;modestbranding=1' allowfullscreen='true' style='border:0;'></iframe></span></div>
</div></figure>
</p><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Bottom Post Link Ads -->
<ins class="adsbygoogle"
     style="display: block;height: 100px;overflow: hidden;"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="4109762806"
     data-ad-format="link"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-143276" class="share-facebook sd-button share-icon" href="https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-143276" class="share-twitter sd-button share-icon" href="https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div>			    				    	
					</div>
				</div>
			</div>
						<footer class="article-tags entry-footer">
			<div>
		<span class="tags-title">Tags</span> 
		<a href="https://www.theyoungfolks.com/tag/49th-parallel/" title="https://www.theyoungfolks.com/tag/xbla/" class="tag-link">49th Parallel</a> <a href="https://www.theyoungfolks.com/tag/909-memphis/" title="https://www.theyoungfolks.com/tag/tina-sinatra/" class="tag-link">909 Memphis</a> <a href="https://www.theyoungfolks.com/tag/blocboy-jb/" title="" class="tag-link">Blocboy JB</a> <a href="https://www.theyoungfolks.com/tag/cash-bentley/" title="" class="tag-link">Cash Bentley</a> <a href="https://www.theyoungfolks.com/tag/denzel-curry/" title="" class="tag-link">Denzel Curry</a> <a href="https://www.theyoungfolks.com/tag/duwap-kaine/" title="" class="tag-link">Duwap Kaine</a> <a href="https://www.theyoungfolks.com/tag/fivio-foreign/" title="" class="tag-link">Fivio Foreign</a> <a href="https://www.theyoungfolks.com/tag/hip-hop-roundup/" title="" class="tag-link">Hip Hop Roundup</a> <a href="https://www.theyoungfolks.com/tag/jpegmafia/" title="" class="tag-link">JPEGMAFIA</a> <a href="https://www.theyoungfolks.com/tag/lil-tjay/" title="" class="tag-link">Lil Tjay</a> <a href="https://www.theyoungfolks.com/tag/peggy/" title="" class="tag-link">Peggy</a> <a href="https://www.theyoungfolks.com/tag/pop-smoke/" title="" class="tag-link">Pop Smoke</a> <a href="https://www.theyoungfolks.com/tag/ric-wilson/" title="" class="tag-link">Ric Wilson</a> <a href="https://www.theyoungfolks.com/tag/rlouie/" title="" class="tag-link">RLouie</a> <a href="https://www.theyoungfolks.com/tag/terrace-martin/" title="" class="tag-link">Terrace Martin</a>	</div>
</footer>
 
<section class="post-author">
		<img width="106" height="106" src="https://cdn1.theyoungfolks.com/wp-content/uploads/2017/02/19155218/b4c5ab20586ef31507efb1f98297f696.jpg" class="avatar avatar-164 photo" alt="" srcset="https://cdn1.theyoungfolks.com/wp-content/uploads/2017/02/19155218/b4c5ab20586ef31507efb1f98297f696.jpg 106w, https://cdn1.theyoungfolks.com/wp-content/uploads/2017/02/19155218/b4c5ab20586ef31507efb1f98297f696-24x24.jpg 24w, https://cdn1.theyoungfolks.com/wp-content/uploads/2017/02/19155218/b4c5ab20586ef31507efb1f98297f696-48x48.jpg 48w, https://cdn1.theyoungfolks.com/wp-content/uploads/2017/02/19155218/b4c5ab20586ef31507efb1f98297f696-96x96.jpg 96w" sizes="(max-width: 106px) 100vw, 106px" />	<div class="author-content">
		<h5><a href="https://www.theyoungfolks.com/author/rfeyre/">Ryan Feyre</a></h5>
				<p>Ryan Feyre is a writer for The Young Folks.</p>
									</div>
	</section>
 		<aside class="share-article hide-on-print ">
		<div class="row">
			<div class="small-12 medium-5 columns">
				<h6>Share This</h6>
			</div>
			<div class="small-12 medium-7 columns small-only-text-center text-right">
				<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F143276%2Fthe-hip-hop-roundup-the-best-from-mays-first-week%2F" class="facebook social"><i class="fa fa-facebook"></i><span>0</span></a>
						<a href="https://twitter.com/intent/tweet?text=The+Hip+Hop+Roundup%3A+The+Best+From+May%E2%80%99s+First+Week&url=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F143276%2Fthe-hip-hop-roundup-the-best-from-mays-first-week%2F&via=theyoungfolks" class="twitter social "><i class="fa fa-twitter"></i><span>0</span></a>
								<a href="http://pinterest.com/pin/create/link/?url=https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/&media=https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1.png&description=The+Hip+Hop+Roundup%3A+The+Best+From+May%E2%80%99s+First+Week" class="pinterest social" nopin="nopin" data-pin-no-hover="true"><i class="fa fa-pinterest"></i><span>0</span></a>
						<a href="https://www.linkedin.com/cws/share?url=https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/" class="linkedin social"><i class="fa fa-linkedin"></i><span>0</span></a>
						<a href="whatsapp://send?text=The+Hip+Hop+Roundup%3A+The+Best+From+May%E2%80%99s+First+Week" class="whatsapp social" data-href="https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/" data-action="share/whatsapp/share"><i class="fa fa-whatsapp"></i></a>
					</div>
	</aside>
	 
			<div class="row post-navi hide-on-print no-padding">
				<div class="small-12 medium-6 columns">
					<span>Previous Article</span><a href="https://www.theyoungfolks.com/video-games/143085/making-ffvii-remakes-ending-make-sense/" title="Making FFVII Remake's Ending Make Sense">Making FFVII Remake's Ending Make Sense</a>				</div>
				<div class="small-12 medium-6 columns">
					<span>Next Article</span><a href="https://www.theyoungfolks.com/review/143235/forged-in-fire-and-stars-andrea-robertson/" title="Book Review: Forged in Fire and Stars by Andrea Robertson">Book Review: Forged in Fire and Stars by Andrea Robertson</a>				</div>
			</div>
			  </article>

					
<div id="disqus_thread"></div>
			</div>
	<aside class="sidebar small-12 medium-4 columns" role="complementary">
	<div class="sidebar_inner fixed-me">
		<div id="thb_singlead_widget-10" class="widget cf widget_singlead"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div id="thb_latestimages_widget-1" class="widget cf widget_latestimages"><strong>Latest Posts</strong><ul><li itemscope itemtype="http://schema.org/Article" class="post listing post-143331 type-post status-publish format-standard has-post-thumbnail hentry category-editorials category-featured category-film category-movie-features tag-featured tag-george-miller tag-mad-max-fury-road" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/film/143331/mad-max-fury-road-five-years-later/" rel="bookmark" title="Mad Max: Fury Road Five Years Later: What We Can Learn About Surviving Together">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/14180626/Screen-Shot-2020-05-14-at-5.04.52-PM-80x75.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/14180626/Screen-Shot-2020-05-14-at-5.04.52-PM-80x75.png 80w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/14180626/Screen-Shot-2020-05-14-at-5.04.52-PM-24x24.png 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/film/" class="single_category_title category-link-3" title="Film">Film</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/film/143331/mad-max-fury-road-five-years-later/" title="Mad Max: Fury Road Five Years Later: What We Can Learn About Surviving Together">Mad Max: Fury Road Five Years Later: What We Can Learn About Surviving Together</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/kstoetzel/" title="Posts by Katey Stoetzel" rel="author">Katey Stoetzel</a></strong>
		<time class="date published time" datetime="2020-05-15T07:00:00-04:00" itemprop="datePublished" content="2020-05-15T07:00:00-04:00">May 15, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-05-14T19:43:51-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/14180626/Screen-Shot-2020-05-14-at-5.04.52-PM.png">
		  <meta itemprop="width" content="1476">
		  <meta itemprop="height" content="604">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/film/143331/mad-max-fury-road-five-years-later/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-143235 type-post status-publish format-standard has-post-thumbnail hentry category-book-reviews category-books category-review tag-andrea-robertson tag-forged-in-fire-and-stars tag-ya tag-ya-fantasy tag-ya-fiction" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/review/143235/forged-in-fire-and-stars-andrea-robertson/" rel="bookmark" title="Book Review: Forged in Fire and Stars by Andrea Robertson">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/14191350/forged-in-fire-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/14191350/forged-in-fire-80x75.jpg 80w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/14191350/forged-in-fire-24x24.jpg 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/books/book-reviews/" class="single_category_title category-link-1781" title="Book Reviews">Book Reviews</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/143235/forged-in-fire-and-stars-andrea-robertson/" title="Book Review: Forged in Fire and Stars by Andrea Robertson">Book Review: Forged in Fire and Stars by Andrea Robertson</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/bphilip/" title="Posts by Bella Philip" rel="author">Bella Philip</a></strong>
		<time class="date published time" datetime="2020-05-14T12:38:19-04:00" itemprop="datePublished" content="2020-05-14T12:38:19-04:00">May 14, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-05-14T19:15:42-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/14191350/forged-in-fire.jpg">
		  <meta itemprop="width" content="1696">
		  <meta itemprop="height" content="2560">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/143235/forged-in-fire-and-stars-andrea-robertson/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-143276 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-features tag-49th-parallel tag-909-memphis tag-blocboy-jb tag-cash-bentley tag-denzel-curry tag-duwap-kaine tag-fivio-foreign tag-hip-hop-roundup tag-jpegmafia tag-lil-tjay tag-peggy tag-pop-smoke tag-ric-wilson tag-rlouie tag-terrace-martin" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/" rel="bookmark" title="The Hip Hop Roundup: The Best From May&#8217;s First Week">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1-80x75.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1-80x75.png 80w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1-24x24.png 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/" title="The Hip Hop Roundup: The Best From May&#8217;s First Week">The Hip Hop Roundup: The Best From May&#8217;s First Week</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time" datetime="2020-05-14T10:00:00-04:00" itemprop="datePublished" content="2020-05-14T10:00:00-04:00">May 14, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-05-13T21:02:20-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/11200450/Screen-Shot-2020-05-11-at-8.03.56-PM-1.png">
		  <meta itemprop="width" content="497">
		  <meta itemprop="height" content="499">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-143085 type-post status-publish format-standard has-post-thumbnail hentry category-video-game-features category-video-games tag-final-fantasy tag-final-fantasy-vii tag-final-fantasy-vii-remake tag-kingdom-hearts-3 tag-ps4" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/video-games/143085/making-ffvii-remakes-ending-make-sense/" rel="bookmark" title="Making FFVII Remake&#8217;s Ending Make Sense">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/06161125/FINAL-FANTASY-VII-REMAKE_20200418164801-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/06161125/FINAL-FANTASY-VII-REMAKE_20200418164801-80x75.jpg 80w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/06161125/FINAL-FANTASY-VII-REMAKE_20200418164801-24x24.jpg 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/video-games/video-game-features/" class="single_category_title category-link-1799" title="Video Game Features">Video Game Features</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/video-games/143085/making-ffvii-remakes-ending-make-sense/" title="Making FFVII Remake&#8217;s Ending Make Sense">Making FFVII Remake&#8217;s Ending Make Sense</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/thymas/" title="Posts by Travis Hymas" rel="author">Travis Hymas</a></strong>
		<time class="date published time" datetime="2020-05-12T12:13:40-04:00" itemprop="datePublished" content="2020-05-12T12:13:40-04:00">May 12, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-05-12T12:13:41-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/06161125/FINAL-FANTASY-VII-REMAKE_20200418164801.jpg">
		  <meta itemprop="width" content="1920">
		  <meta itemprop="height" content="1080">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/video-games/143085/making-ffvii-remakes-ending-make-sense/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-143144 type-post status-publish format-standard has-post-thumbnail hentry category-book-reviews category-books category-review tag-kiera-cass tag-the-betrothed tag-ya-fantasy tag-ya-romance" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/review/143144/the-betrothed-kiera-cass/" rel="bookmark" title="Book Review: The Betrothed by Kiera Cass">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/12042819/8142uPFybHL-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/12042819/8142uPFybHL-80x75.jpg 80w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/12042819/8142uPFybHL-24x24.jpg 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/books/book-reviews/" class="single_category_title category-link-1781" title="Book Reviews">Book Reviews</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/143144/the-betrothed-kiera-cass/" title="Book Review: The Betrothed by Kiera Cass">Book Review: The Betrothed by Kiera Cass</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/mstanley/" title="Posts by Meagan Stanley" rel="author">Meagan Stanley</a></strong>
		<time class="date published time" datetime="2020-05-12T11:45:54-04:00" itemprop="datePublished" content="2020-05-12T11:45:54-04:00">May 12, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-05-12T11:45:55-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/12042819/8142uPFybHL.jpg">
		  <meta itemprop="width" content="1600">
		  <meta itemprop="height" content="2417">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/143144/the-betrothed-kiera-cass/">
							</aside>
				</div>
</li></ul></div><div id="thb_singlead_widget-4" class="widget cf widget_singlead"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div id="thb_topreviews_widget-2" class="widget cf widget_topreviews"><strong>Top Reviews</strong><article itemscope itemtype="http://schema.org/Article" class="post post-overlay photo-listing post-117977 type-post status-publish format-standard has-post-thumbnail hentry category-book-reviews category-books category-featured category-review tag-amie-kaufman tag-featured tag-gemina tag-illuminae tag-jay-kristoff tag-obsidio" role="article" style="background-image: url(https://cdn1.theyoungfolks.com/wp-content/uploads/2018/03/13002734/9781925266726-280x150.jpg);">
	<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/117977/review-obsidio-by-amie-kaufman-and-jay-kristoff/" rel="bookmark" title="Review: OBSIDIO by Amie Kaufman and Jay Kristoff">
					<figure class="circle_rating small">
			<span>10/10</span>
			<svg width="50" height="50" viewBox="0 0 50 50" version="1.1" xmlns="http://www.w3.org/2000/svg">
			  <circle class="circle_base" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="0"></circle>
			 	<circle class="circle_perc" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="144.44" data-dashoffset="0"></circle>
			</svg>
		</figure>
				</a>
		<header class="post-title entry-header">
			<h5 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/117977/review-obsidio-by-amie-kaufman-and-jay-kristoff/" title="Review: OBSIDIO by Amie Kaufman and Jay Kristoff">Review: OBSIDIO by Amie Kaufman and Jay Kristoff</a></h5>				<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/yhspatriot1014/" title="Posts by Lauren Wengrovitz" rel="author">Lauren Wengrovitz</a></strong>
		<time class="date published time" datetime="2018-03-13T08:00:25-04:00" itemprop="datePublished" content="2018-03-13T08:00:25-04:00">March 13, 2018</time>
		<meta itemprop="dateModified" class="date updated" content="2018-03-13T16:02:26-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2018/03/13002734/9781925266726.jpg">
		  <meta itemprop="width" content="1827">
		  <meta itemprop="height" content="2765">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/117977/review-obsidio-by-amie-kaufman-and-jay-kristoff/">
							</aside>
			</header>
	</figure>
</article><ul class="style2">               			<li>
               				<a href="https://www.theyoungfolks.com/review/138678/queen-of-nothing-holly-black/" title="Book Review: The Queen of Nothing by Holly Black">Book Review: The Queen of Nothing by Holly Black <span>10</span></a>
               			</li>
               		               			<li>
               				<a href="https://www.theyoungfolks.com/review/141264/red-hood-elana-k-arnold/" title="Book Review: Red Hood by Elana K. Arnold">Book Review: Red Hood by Elana K. Arnold <span>10</span></a>
               			</li>
               		               			<li>
               				<a href="https://www.theyoungfolks.com/music/142920/album-review-fiona-apples-fetch-the-bolt-cutters-is-the-perfect-storm/" title="Album review: Fiona Apple’s “Fetch The Bolt Cutters” is the perfect storm">Album review: Fiona Apple’s “Fetch The Bolt Cutters” is the perfect storm <span>10</span></a>
               			</li>
               		               			<li>
               				<a href="https://www.theyoungfolks.com/review/123648/review-the-darkest-legacy-by-alexandra-bracken/" title="Review: The Darkest Legacy by Alexandra Bracken">Review: The Darkest Legacy by Alexandra Bracken <span>10</span></a>
               			</li>
               		</ul></div><div id="thb_singlead_widget-7" class="widget cf widget_singlead"><iframe src="https://player.twitch.tv/?channel=gamingfrogtv" muted="true" autoplay="true" frameborder="0" allowfullscreen="false" scrolling="no" height="250" width="300"></iframe><a href="//www.twitch.tv/gamingfrogtv?tt_content=text_link&tt_medium=live_embed" target="_blank" style="padding:2px 0px 4px; display:block; width:300px; font-weight:normal; font-size:10px; text-decoration:underline;">Watch live video from GamingFrogTV on www.twitch.tv</a></div><div id="thb_viewedimages_widget-2" class="widget cf widget_viewedimages"><strong>Most Viewed<span class="thb_listing" data-type="views" data-count="10"><a href="#" data-time="7" class="active">WEEK</a><a href="#" data-time="30">MONTH</a><a href="#" data-time="365">ALL</a></span></strong><ul><li itemscope itemtype="http://schema.org/Article" class="post listing post-79401 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-music category-music-features tag-christopher-jackson tag-daveed-diggs tag-featured tag-hamilton tag-jonathan-groff tag-leslie-odom-jr tag-lin-manuel-miranda tag-phillipa-soo tag-rankings tag-renee-elise-goldsberry" role="article">
		<figure class="post-gallery">
					<span class="counts">1</span>
				<a href="https://www.theyoungfolks.com/music/79401/every-song-from-the-hamilton-cast-album-ranked/" rel="bookmark" title="Every Song from the &#8216;Hamilton&#8217; Cast Album, Ranked">
			<img width="80" height="42" data-original="https://www.theyoungfolks.com/wp-content/uploads/2016/05/alexander-hamilton.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-original-set="https://www.theyoungfolks.com/wp-content/uploads/2016/05/alexander-hamilton.jpg 540w, https://www.theyoungfolks.com/wp-content/uploads/2016/05/alexander-hamilton-300x157.jpg 300w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/79401/every-song-from-the-hamilton-cast-album-ranked/" title="Every Song from the &#8216;Hamilton&#8217; Cast Album, Ranked">Every Song from the &#8216;Hamilton&#8217; Cast Album, Ranked</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/mrice/" title="Posts by Melody Danielle Rice" rel="author">Melody Danielle Rice</a></strong>
		<time class="date published time hide" datetime="2016-06-14T09:00:47-04:00" itemprop="datePublished" content="2016-06-14T09:00:47-04:00">June 14, 2016</time>
		<meta itemprop="dateModified" class="date updated" content="2017-03-01T12:42:51-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2016/05/alexander-hamilton.jpg">
		  <meta itemprop="width" content="540">
		  <meta itemprop="height" content="283">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/79401/every-song-from-the-hamilton-cast-album-ranked/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-143186 type-post status-publish format-standard has-post-thumbnail hentry category-review category-television category-tv-reviews tag-dynasty tag-elizabeth-gillies tag-grant-show tag-maddison-brown tag-michael-michele tag-rafael-de-la-fuente tag-robert-christopher-riley tag-sam-underwood tag-the-cw" role="article">
		<figure class="post-gallery">
					<span class="counts">2</span>
				<a href="https://www.theyoungfolks.com/review/143186/dynasty-season-3-finale-review-my-hangovers-arrived-is-a-night-in-vegas-youll-want-to-remember/" rel="bookmark" title="Dynasty Season 3 Finale Review: “My Hangover&#8217;s Arrived” is a night in Vegas you&#8217;ll want to remember">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/09145159/DYN320b_0123b-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Sam, Kirby, and Fallon in Las Vegas on Dynasty" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/09145159/DYN320b_0123b-80x75.jpg 80w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/09145159/DYN320b_0123b-24x24.jpg 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/television/tv-reviews/" class="single_category_title category-link-1793" title="TV Reviews">TV Reviews</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/143186/dynasty-season-3-finale-review-my-hangovers-arrived-is-a-night-in-vegas-youll-want-to-remember/" title="Dynasty Season 3 Finale Review: “My Hangover&#8217;s Arrived” is a night in Vegas you&#8217;ll want to remember">Dynasty Season 3 Finale Review: “My Hangover&#8217;s Arrived” is a night in Vegas you&#8217;ll want to remember</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/jcarreiro/" title="Posts by Justin Carreiro" rel="author">Justin Carreiro</a></strong>
		<time class="date published time hide" datetime="2020-05-10T12:00:04-04:00" itemprop="datePublished" content="2020-05-10T12:00:04-04:00">May 10, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-05-10T12:09:16-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/09145159/DYN320b_0123b.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="857">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/143186/dynasty-season-3-finale-review-my-hangovers-arrived-is-a-night-in-vegas-youll-want-to-remember/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-87680 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-music category-music-features category-top-10-2 tag-david-bowie tag-featured tag-nirvana tag-pink-floyd tag-queen tag-rod-stewart tag-the-beatles tag-the-clash tag-the-cure tag-the-rolling-stones tag-u2" role="article">
		<figure class="post-gallery">
					<span class="counts">3</span>
				<a href="https://www.theyoungfolks.com/music/87680/10-classic-rock-songs-you-can-play-on-the-ukulele/" rel="bookmark" title="10 Classic Rock Songs You Can Play on the Ukulele">
			<img width="80" height="52" data-original="https://www.theyoungfolks.com/wp-content/uploads/2016/09/image-3-620x400.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-original-set="https://www.theyoungfolks.com/wp-content/uploads/2016/09/image-3-620x400.jpg 620w, https://www.theyoungfolks.com/wp-content/uploads/2016/09/image-3-300x194.jpg 300w, https://www.theyoungfolks.com/wp-content/uploads/2016/09/image-3-85x54.jpg 85w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/featured/" class="single_category_title category-link-12" title="Featured">Featured</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/87680/10-classic-rock-songs-you-can-play-on-the-ukulele/" title="10 Classic Rock Songs You Can Play on the Ukulele">10 Classic Rock Songs You Can Play on the Ukulele</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/bmenjivar/" title="Posts by Brittany Menjivar" rel="author">Brittany Menjivar</a></strong>
		<time class="date published time hide" datetime="2016-09-27T08:30:36-04:00" itemprop="datePublished" content="2016-09-27T08:30:36-04:00">September 27, 2016</time>
		<meta itemprop="dateModified" class="date updated" content="2016-09-27T01:17:33-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2016/09/image-3.jpg">
		  <meta itemprop="width" content="859">
		  <meta itemprop="height" content="804">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/87680/10-classic-rock-songs-you-can-play-on-the-ukulele/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-116203 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-special category-television category-top-10-2 category-tv-features tag-best-of tag-double-dare tag-featured tag-figure-it-out tag-finders-keepers tag-game-shows tag-get-the-picture tag-guts tag-legends-of-the-hidden-temple tag-marc-summers tag-nick-arcade tag-nickelodeon tag-slime-time-live tag-top-lists tag-tv tag-what-would-you-do tag-wild-crazy-kids" role="article">
		<figure class="post-gallery">
					<span class="counts">4</span>
				<a href="https://www.theyoungfolks.com/television/116203/the-10-best-nickelodeon-game-shows/" rel="bookmark" title="The 10 Best Nickelodeon Game Shows">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2018/02/02153923/DoubleDare_02b-80x75.jpeg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/top-10-2/" class="single_category_title category-link-259" title="Top Lists">Top Lists</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/television/116203/the-10-best-nickelodeon-game-shows/" title="The 10 Best Nickelodeon Game Shows">The 10 Best Nickelodeon Game Shows</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/tchristian/" title="Posts by Tyler Christian" rel="author">Tyler Christian</a></strong>
		<time class="date published time hide" datetime="2018-02-05T10:00:27-05:00" itemprop="datePublished" content="2018-02-05T10:00:27-05:00">February 5, 2018</time>
		<meta itemprop="dateModified" class="date updated" content="2018-02-05T12:26:40-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2018/02/02153923/DoubleDare_02b.jpeg">
		  <meta itemprop="width" content="1140">
		  <meta itemprop="height" content="873">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/television/116203/the-10-best-nickelodeon-game-shows/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-32887 type-post status-publish format-standard has-post-thumbnail hentry category-editorials category-featured category-special category-television category-tv-features tag-alan-van-sprang tag-cw tag-featured tag-king-henry tag-reign tag-special tag-television tag-the-cw tag-theory tag-tv tag-tv-shows" role="article">
		<figure class="post-gallery">
					<span class="counts">5</span>
				<a href="https://www.theyoungfolks.com/television/32887/reign-theory-king-henrys-madness/" rel="bookmark" title="&#8216;Reign&#8217; Theory: King Henry&#8217;s Madness">
			<img width="80" height="42" data-original="https://www.theyoungfolks.com/wp-content/uploads/2014/05/reign-620x325.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/featured/" class="single_category_title category-link-12" title="Featured">Featured</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/television/32887/reign-theory-king-henrys-madness/" title="&#8216;Reign&#8217; Theory: King Henry&#8217;s Madness">&#8216;Reign&#8217; Theory: King Henry&#8217;s Madness</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/ivannabarrera/" title="Posts by Ivanna Barrera" rel="author">Ivanna Barrera</a></strong>
		<time class="date published time hide" datetime="2014-05-14T00:15:12-04:00" itemprop="datePublished" content="2014-05-14T00:15:12-04:00">May 14, 2014</time>
		<meta itemprop="dateModified" class="date updated" content="2014-05-14T09:27:17-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2014/05/reign.jpg">
		  <meta itemprop="width" content="699">
		  <meta itemprop="height" content="325">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/television/32887/reign-theory-king-henrys-madness/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-134278 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-music category-music-features tag-american-pie tag-bic-runga tag-blink-182 tag-dishwalla tag-semisonic tag-shades-apart tag-super-transatlantic tag-the-atomic-fireballs tag-third-eye-blind tag-tonic" role="article">
		<figure class="post-gallery">
					<span class="counts">6</span>
				<a href="https://www.theyoungfolks.com/music/134278/every-song-from-the-american-pie-soundtrack-ranked/" rel="bookmark" title="Every Song from the ‘American Pie’ Soundtrack, Ranked">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2019/07/03160734/American-Pie-Soundtrack-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/134278/every-song-from-the-american-pie-soundtrack-ranked/" title="Every Song from the ‘American Pie’ Soundtrack, Ranked">Every Song from the ‘American Pie’ Soundtrack, Ranked</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/bthompson/" title="Posts by Brian Thompson" rel="author">Brian Thompson</a></strong>
		<time class="date published time hide" datetime="2019-07-09T07:00:01-04:00" itemprop="datePublished" content="2019-07-09T07:00:01-04:00">July 9, 2019</time>
		<meta itemprop="dateModified" class="date updated" content="2019-07-04T18:49:17-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2019/07/03160734/American-Pie-Soundtrack.jpg">
		  <meta itemprop="width" content="340">
		  <meta itemprop="height" content="355">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/134278/every-song-from-the-american-pie-soundtrack-ranked/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-142266 type-post status-publish format-standard has-post-thumbnail hentry category-television category-tv-reviews tag-ben-sinclair tag-hbo tag-high-maintenance tag-katja-blichfeld" role="article">
		<figure class="post-gallery">
					<span class="counts">7</span>
				<a href="https://www.theyoungfolks.com/television/142266/high-maintenance-season-4-finale-review/" rel="bookmark" title="High Maintenance Season 4 Finale Review">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/04/04213837/high-maintenance-409-soup-review-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/04/04213837/high-maintenance-409-soup-review-80x75.jpg 80w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/04/04213837/high-maintenance-409-soup-review-24x24.jpg 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/television/tv-reviews/" class="single_category_title category-link-1793" title="TV Reviews">TV Reviews</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/television/142266/high-maintenance-season-4-finale-review/" title="High Maintenance Season 4 Finale Review">High Maintenance Season 4 Finale Review</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/bwinchester/" title="Posts by Beth Winchester" rel="author">Beth Winchester</a></strong>
		<time class="date published time hide" datetime="2020-04-05T13:07:17-04:00" itemprop="datePublished" content="2020-04-05T13:07:17-04:00">April 5, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-04-05T13:20:04-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/04/04213837/high-maintenance-409-soup-review.jpg">
		  <meta itemprop="width" content="1584">
		  <meta itemprop="height" content="1054">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/television/142266/high-maintenance-season-4-finale-review/">
							</aside>
				</div>
</li></ul></div><div id="thb_singlead_widget-5" class="widget cf widget_singlead"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>	</div>
</aside></div>
		<div class="row">
		<div class="small-12 columns">
			<!-- Start Related Posts -->
<aside class="related-posts cf hide-on-print">
	<h4 class="related-title">Related News</h4>
	<div class="row">
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-143031 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-features tag-big-moochie-grape tag-chief-keef tag-chris-keys tag-empty-sentiment tag-gao-the-arsonist tag-hip-hop-roundup tag-kenny-mason tag-quelle-chris tag-smino tag-westside-gunn" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/143031/the-hip-hop-roundup-the-best-from-april/" rel="bookmark" title="The Hip Hop Roundup: The Best From April">
			<img width="225" height="225" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/04162520/westside-gunn-pray-for-paris.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/04162520/westside-gunn-pray-for-paris.jpg 225w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/04162520/westside-gunn-pray-for-paris-150x150.jpg 150w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/04162520/westside-gunn-pray-for-paris-24x24.jpg 24w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/04162520/westside-gunn-pray-for-paris-48x48.jpg 48w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/04162520/westside-gunn-pray-for-paris-96x96.jpg 96w" sizes="(max-width: 225px) 100vw, 225px" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/143031/the-hip-hop-roundup-the-best-from-april/" title="The Hip Hop Roundup: The Best From April">The Hip Hop Roundup: The Best From April</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time hide" datetime="2020-05-05T10:50:20-04:00" itemprop="datePublished" content="2020-05-05T10:50:20-04:00">May 5, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-05-05T10:50:22-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/04162520/westside-gunn-pray-for-paris.jpg">
		  <meta itemprop="width" content="225">
		  <meta itemprop="height" content="225">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/143031/the-hip-hop-roundup-the-best-from-april/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-142806 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-reviews tag-benjy-ali tag-earl-sweatshirt tag-hip-hop-roundup tag-juice-wrld tag-kasha-paige tag-maxo tag-rucci tag-smino tag-tony-seltzer tag-wifigawd" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/142806/the-hip-hop-roundup-smino-rucci-kaash-paige-and-more/" rel="bookmark" title="The Hip Hop Roundup: Smino, Rucci, Kaash Paige and More">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/04/27190656/smino-she-already-decided-1-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/music/" class="single_category_title category-link-4" title="Music">Music</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/142806/the-hip-hop-roundup-smino-rucci-kaash-paige-and-more/" title="The Hip Hop Roundup: Smino, Rucci, Kaash Paige and More">The Hip Hop Roundup: Smino, Rucci, Kaash Paige and More</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time hide" datetime="2020-04-30T09:00:00-04:00" itemprop="datePublished" content="2020-04-30T09:00:00-04:00">April 30, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-04-30T13:14:59-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/04/27190656/smino-she-already-decided-1.jpg">
		  <meta itemprop="width" content="1400">
		  <meta itemprop="height" content="1400">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/142806/the-hip-hop-roundup-smino-rucci-kaash-paige-and-more/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-142651 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-features tag-ean-wire tag-alfii tag-allblack tag-bi-weekly-hip-hop-roundup tag-billy-dean-thomas tag-chicken-p tag-hip-hop-roundup tag-jiggs tag-kid-cudi tag-lor-choc tag-milkshaw-benedict tag-most-high-kingdom tag-najee-janey tag-stephon-joseph" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/142651/the-hip-hop-roundup-lor-choc-kid-cudi-allblack-and-more/" rel="bookmark" title="The Hip Hop Roundup: Lor Choc, Kid Cudi, ALLBLACK and More">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/04/20175712/lor-choc-still-worth-it-1-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/142651/the-hip-hop-roundup-lor-choc-kid-cudi-allblack-and-more/" title="The Hip Hop Roundup: Lor Choc, Kid Cudi, ALLBLACK and More">The Hip Hop Roundup: Lor Choc, Kid Cudi, ALLBLACK and More</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time hide" datetime="2020-04-21T11:15:22-04:00" itemprop="datePublished" content="2020-04-21T11:15:22-04:00">April 21, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-04-30T12:47:11-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/04/20175712/lor-choc-still-worth-it-1.jpg">
		  <meta itemprop="width" content="1000">
		  <meta itemprop="height" content="1000">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/142651/the-hip-hop-roundup-lor-choc-kid-cudi-allblack-and-more/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-142550 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-features tag-bi-weekly-hip-hop-roundup tag-bomethius tag-hip-hop-roundup tag-jean-deaux tag-lil-poppa tag-mozzy tag-polo-g tag-rico-nasty tag-saba tag-sunny2point0 tag-tmcthedon tag-trippie-redd" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/142550/hip-hop-roundup-bomethius-polo-g-jean-deax-and-more/" rel="bookmark" title="Hip Hop Roundup: Bomethius, Polo G, Jean Deax, and More">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/04/13183702/jean-deaux-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/142550/hip-hop-roundup-bomethius-polo-g-jean-deax-and-more/" title="Hip Hop Roundup: Bomethius, Polo G, Jean Deax, and More">Hip Hop Roundup: Bomethius, Polo G, Jean Deax, and More</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time hide" datetime="2020-04-17T08:00:00-04:00" itemprop="datePublished" content="2020-04-17T08:00:00-04:00">April 17, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-04-30T12:35:56-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/04/13183702/jean-deaux.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="1200">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/142550/hip-hop-roundup-bomethius-polo-g-jean-deax-and-more/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-142359 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-features tag-bi-weekly-hip-hop-roundup tag-drake-the-ruler tag-hip-hop-roundup tag-keiyaa tag-lil-uzi-vert tag-quin-nfn tag-rio-da-yung-og tag-sada-baby tag-zayland" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/142359/the-hip-hop-roundup-the-best-projects-from-march/" rel="bookmark" title="The Hip Hop Roundup: The Best Projects from March">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/04/06160602/eternal-atake-lil-uzi-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/142359/the-hip-hop-roundup-the-best-projects-from-march/" title="The Hip Hop Roundup: The Best Projects from March">The Hip Hop Roundup: The Best Projects from March</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time hide" datetime="2020-04-08T19:39:49-04:00" itemprop="datePublished" content="2020-04-08T19:39:49-04:00">April 8, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-04-08T19:39:50-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/04/06160602/eternal-atake-lil-uzi.jpg">
		  <meta itemprop="width" content="600">
		  <meta itemprop="height" content="600">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/142359/the-hip-hop-roundup-the-best-projects-from-march/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-142165 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-features tag-azchike tag-cinoevil tag-connie tag-conway-the-machine tag-hip-hop-roundup tag-keiyaa tag-lance-jackson tag-luke-bar tag-schoolboy-q tag-the-alchemist tag-wakai" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/142165/the-hip-hop-roundup-week-of-march-30-keiyaa-connis-az-chike-and-more/" rel="bookmark" title="The Hip Hop Roundup &#8211; Week of March 30: KeiyaA, Connis, AZ Chike and more">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/03/30220519/keiyaa-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/142165/the-hip-hop-roundup-week-of-march-30-keiyaa-connis-az-chike-and-more/" title="The Hip Hop Roundup &#8211; Week of March 30: KeiyaA, Connis, AZ Chike and more">The Hip Hop Roundup &#8211; Week of March 30: KeiyaA, Connis, AZ Chike and more</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time hide" datetime="2020-04-02T16:05:44-04:00" itemprop="datePublished" content="2020-04-02T16:05:44-04:00">April 2, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-04-02T16:05:45-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/03/30220519/keiyaa.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="1200">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/142165/the-hip-hop-roundup-week-of-march-30-keiyaa-connis-az-chike-and-more/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-141902 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-features category-review tag-baby-smoove tag-bi-weekly-hip-hop-roundup tag-chicken-p tag-chris-keys tag-hip-hop-roundup tag-jpegmafia tag-mac-hefner tag-quelle-chris tag-sada-baby tag-shordie-shordie" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/141902/hip-hop-roundup-march-22-sada-baby-mac-hefner-quelle-chris-and-more/" rel="bookmark" title="Hip Hop Roundup March 22: Sada Baby, Mac Hefner, Quelle Chris and more">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/03/23220623/skuba-sada-2-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-reviews/" class="single_category_title category-link-1786" title="Music Reviews">Music Reviews</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/141902/hip-hop-roundup-march-22-sada-baby-mac-hefner-quelle-chris-and-more/" title="Hip Hop Roundup March 22: Sada Baby, Mac Hefner, Quelle Chris and more">Hip Hop Roundup March 22: Sada Baby, Mac Hefner, Quelle Chris and more</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time hide" datetime="2020-03-25T11:03:02-04:00" itemprop="datePublished" content="2020-03-25T11:03:02-04:00">March 25, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-03-25T11:03:03-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/03/23220623/skuba-sada-2.jpg">
		  <meta itemprop="width" content="1000">
		  <meta itemprop="height" content="1000">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/141902/hip-hop-roundup-march-22-sada-baby-mac-hefner-quelle-chris-and-more/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-141714 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-features tag-bi-weekly-hip-hop-roundup tag-chicken-p tag-chief-keef tag-don-tolliver tag-gmac-cash tag-hip-hop-roundup tag-ill-addicts tag-mozzy" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/141714/the-hip-hop-roundup-chief-keef-ill-addicts-don-tolliver-and-more/" rel="bookmark" title="The Hip Hop Roundup: Chief Keef, Ill Addicts, Don Tolliver and more">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/03/16200209/ill-addicts-malfunction-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/141714/the-hip-hop-roundup-chief-keef-ill-addicts-don-tolliver-and-more/" title="The Hip Hop Roundup: Chief Keef, Ill Addicts, Don Tolliver and more">The Hip Hop Roundup: Chief Keef, Ill Addicts, Don Tolliver and more</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time hide" datetime="2020-03-17T16:15:00-04:00" itemprop="datePublished" content="2020-03-17T16:15:00-04:00">March 17, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-03-17T16:09:55-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/03/16200209/ill-addicts-malfunction.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="1200">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/141714/the-hip-hop-roundup-chief-keef-ill-addicts-don-tolliver-and-more/">
							</aside>
	</article>    </div>
    </div>
</aside>
<!-- End Related Posts -->		</div>
	</div>
		</div>
		</div><!-- End role["main"] -->
			
						<!-- Start Footer -->
			<footer id="footer" role="contentinfo" class="dark ">
			  	<div class="row">
			  						    <div class="small-12 medium-4 large-4 columns">
				    	<div id="custom-twitter-feeds-widget-2" class="widget cf widget_custom-twitter-feeds-widget"><strong>@TheYoungFolks on Twitter</strong><!-- Custom Twitter Feeds by Smash Balloon --><div id="ctf" class="ctf ctf-type-usertimeline  ctf-styles" style="width: 100%;" data-ctfshortcode="{}" data-ctfneeded="0"><div class="ctf-tweets"><div class="ctf-item ctf-author-theyoungfolks ctf-new ctf-retweet" id="1261177621519491072" style=""><div class="ctf-context"><a href="https://twitter.com/intent/user?screen_name=TheYoungFolks" target="_blank" class="ctf-retweet-icon"><i class="fa fa-retweet" aria-hidden="true"></i><span class="ctf-screenreader">Retweet on Twitter</span></a><a href="https://twitter.com/TheYoungFolks" target="_blank" class="ctf-retweet-text" style="">The Young Folks Retweeted</a></div><div class="ctf-author-box"><div class="ctf-author-box-link" style=""><a href="https://twitter.com/49parallelmusic" class="ctf-author-avatar" target="_blank" style=""><img src="https://pbs.twimg.com/profile_images/1076946326812676096/dOFI11su_normal.jpg" alt="49parallelmusic" width="48" height="48"></a><a href="https://twitter.com/49parallelmusic" target="_blank" class="ctf-author-name" style="">49th Parallel</a><a href="https://twitter.com/49parallelmusic" class="ctf-author-screenname" target="_blank" style="">@49parallelmusic</a><span class="ctf-screename-sep">&middot;</span><div class="ctf-tweet-meta"><a href="https://twitter.com/49parallelmusic/status/1261104967252762624" class="ctf-tweet-date" target="_blank" style="">13h</a></div></div> <!-- end .ctf-author-box-link --></div><div class="ctf-tweet-content"><p class="ctf-tweet-text" style="">The Hip Hop Roundup: The Best From May’s First Week https://t.co/idlMk7A8QG Thank you @theyoungfolks for featuring New Chevy 🙏🙏🙏</div><div class="ctf-tweet-actions"><a href="https://twitter.com/intent/tweet?in_reply_to=1261104967252762624&related=49parallelmusic" class="ctf-reply" target="_blank" style=""><i class="fa fa-reply"></i><span class="ctf-screenreader">Reply on Twitter 1261104967252762624</span></a><a href="https://twitter.com/intent/retweet?tweet_id=1261104967252762624&related=49parallelmusic" class="ctf-retweet" target="_blank" style=""><i class="fa fa-retweet"></i><span class="ctf-screenreader">Retweet on Twitter 1261104967252762624</span><span class="ctf-action-count ctf-retweet-count">1</span></a><a href="https://twitter.com/intent/like?tweet_id=1261104967252762624&related=49parallelmusic" class="ctf-like" target="_blank" style=""><i class="fa fa-heart"></i><span class="ctf-screenreader">Like on Twitter 1261104967252762624</span><span class="ctf-action-count ctf-favorite-count">1</span></a><a href="https://twitter.com/49parallelmusic/status/1261104967252762624" class="ctf-twitterlink" style="" target="_blank">Twitter <span class="ctf-screenreader">1261104967252762624</span></a></div></div><div class="ctf-item ctf-author-theyoungfolks ctf-new ctf-retweet" id="1261012992491163652" style=""><div class="ctf-context"><a href="https://twitter.com/intent/user?screen_name=TheYoungFolks" target="_blank" class="ctf-retweet-icon"><i class="fa fa-retweet" aria-hidden="true"></i><span class="ctf-screenreader">Retweet on Twitter</span></a><a href="https://twitter.com/TheYoungFolks" target="_blank" class="ctf-retweet-text" style="">The Young Folks Retweeted</a></div><div class="ctf-author-box"><div class="ctf-author-box-link" style=""><a href="https://twitter.com/TravisHymas" class="ctf-author-avatar" target="_blank" style=""><img src="https://pbs.twimg.com/profile_images/1208953148104048641/L9GAisoK_normal.jpg" alt="TravisHymas" width="48" height="48"></a><a href="https://twitter.com/TravisHymas" target="_blank" class="ctf-author-name" style="">Blathers Defense Force™</a><a href="https://twitter.com/TravisHymas" class="ctf-author-screenname" target="_blank" style="">@TravisHymas</a><span class="ctf-screename-sep">&middot;</span><div class="ctf-tweet-meta"><a href="https://twitter.com/TravisHymas/status/1260649623552618496" class="ctf-tweet-date" target="_blank" style="">13 May</a></div></div> <!-- end .ctf-author-box-link --></div><div class="ctf-tweet-content"><p class="ctf-tweet-text" style="">Time to burn down my credibility by defending Tetsuya Nomura and #FinalFantasy7Remake on @TheYoungFolks:  https://t.co/8yL4CYKEj5</div><div class="ctf-tweet-actions"><a href="https://twitter.com/intent/tweet?in_reply_to=1260649623552618496&related=TravisHymas" class="ctf-reply" target="_blank" style=""><i class="fa fa-reply"></i><span class="ctf-screenreader">Reply on Twitter 1260649623552618496</span></a><a href="https://twitter.com/intent/retweet?tweet_id=1260649623552618496&related=TravisHymas" class="ctf-retweet" target="_blank" style=""><i class="fa fa-retweet"></i><span class="ctf-screenreader">Retweet on Twitter 1260649623552618496</span><span class="ctf-action-count ctf-retweet-count">2</span></a><a href="https://twitter.com/intent/like?tweet_id=1260649623552618496&related=TravisHymas" class="ctf-like" target="_blank" style=""><i class="fa fa-heart"></i><span class="ctf-screenreader">Like on Twitter 1260649623552618496</span><span class="ctf-action-count ctf-favorite-count">1</span></a><a href="https://twitter.com/TravisHymas/status/1260649623552618496" class="ctf-twitterlink" style="" target="_blank">Twitter <span class="ctf-screenreader">1260649623552618496</span></a></div></div><div class="ctf-item ctf-author-theyoungfolks ctf-new" id="1261012416613285890" style=""><div class="ctf-author-box"><div class="ctf-author-box-link" style=""><a href="https://twitter.com/TheYoungFolks" class="ctf-author-avatar" target="_blank" style=""><img src="https://pbs.twimg.com/profile_images/1163537668418002944/LMsRxAEN_normal.jpg" alt="TheYoungFolks" width="48" height="48"></a><a href="https://twitter.com/TheYoungFolks" target="_blank" class="ctf-author-name" style="">The Young Folks</a><a href="https://twitter.com/TheYoungFolks" class="ctf-author-screenname" target="_blank" style="">@TheYoungFolks</a><span class="ctf-screename-sep">&middot;</span><div class="ctf-tweet-meta"><a href="https://twitter.com/TheYoungFolks/status/1261012416613285890" class="ctf-tweet-date" target="_blank" style="">19h</a></div></div> <!-- end .ctf-author-box-link --></div><div class="ctf-tweet-content"><p class="ctf-tweet-text" style="">BREAKING: A live-action series based on Rick Riordan’s popular PERCY JACKSON books is officially in the works for Disney+! <br />
#PercyJackson #DisneyPlus </p><a href="https://twitter.com/TheYoungFolks/status/1261012416613285890" target="_blank" class="ctf-tweet-text-media-wrap"><i style="padding-right: 5px;" class="fa fa-picture-o ctf-tweet-text-media" aria-hidden="true"></i></a></div><div class="ctf-tweet-actions"><a href="https://twitter.com/intent/tweet?in_reply_to=1261012416613285890&related=TheYoungFolks" class="ctf-reply" target="_blank" style=""><i class="fa fa-reply"></i><span class="ctf-screenreader">Reply on Twitter 1261012416613285890</span></a><a href="https://twitter.com/intent/retweet?tweet_id=1261012416613285890&related=TheYoungFolks" class="ctf-retweet" target="_blank" style=""><i class="fa fa-retweet"></i><span class="ctf-screenreader">Retweet on Twitter 1261012416613285890</span><span class="ctf-action-count ctf-retweet-count">2</span></a><a href="https://twitter.com/intent/like?tweet_id=1261012416613285890&related=TheYoungFolks" class="ctf-like" target="_blank" style=""><i class="fa fa-heart"></i><span class="ctf-screenreader">Like on Twitter 1261012416613285890</span><span class="ctf-action-count ctf-favorite-count">5</span></a><a href="https://twitter.com/TheYoungFolks/status/1261012416613285890" class="ctf-twitterlink" style="" target="_blank">Twitter <span class="ctf-screenreader">1261012416613285890</span></a></div></div></div></div><script type="text/javascript" src="https://www.theyoungfolks.com/wp-content/plugins/custom-twitter-feeds/js/ctf-scripts.js?ver=1.3"></script></div>				    </div>
				    <div class="small-12 medium-4 large-4 columns">
				    	<div id="thb_categoryslider_widget-2" class="widget cf widget_categoryslider"><strong>Latest Reviews</strong><div class="slick text-center" data-columns="1" data-pagination="false" data-navigation="true" data-autoplay="false" data-speed="500"><article itemscope itemtype="http://schema.org/Article" class="post style1 style1-meta post-143235 type-post status-publish format-standard has-post-thumbnail hentry category-book-reviews category-books category-review tag-andrea-robertson tag-forged-in-fire-and-stars tag-ya tag-ya-fantasy tag-ya-fiction" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/143235/forged-in-fire-and-stars-andrea-robertson/" rel="bookmark" title="Book Review: Forged in Fire and Stars by Andrea Robertson">
			<img width="280" height="150" src="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/14191350/forged-in-fire-280x150.jpg" class="no-lazy-load wp-post-image" alt="" />					<figure class="circle_rating small">
			<span>6</span>
			<svg width="50" height="50" viewBox="0 0 50 50" version="1.1" xmlns="http://www.w3.org/2000/svg">
			  <circle class="circle_base" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="0"></circle>
			 	<circle class="circle_perc" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="144.44" data-dashoffset="57.776"></circle>
			</svg>
		</figure>
				</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/books/book-reviews/" class="single_category_title category-link-1781" title="Book Reviews">Book Reviews</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/143235/forged-in-fire-and-stars-andrea-robertson/" title="Book Review: Forged in Fire and Stars by Andrea Robertson">Book Review: Forged in Fire and Stars by Andrea Robertson</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/bphilip/" title="Posts by Bella Philip" rel="author">Bella Philip</a></strong>
		<time class="date published time" datetime="2020-05-14T12:38:19-04:00" itemprop="datePublished" content="2020-05-14T12:38:19-04:00">May 14, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-05-14T19:15:42-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/14191350/forged-in-fire.jpg">
		  <meta itemprop="width" content="1696">
		  <meta itemprop="height" content="2560">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/143235/forged-in-fire-and-stars-andrea-robertson/">
							</aside>
	</article><article itemscope itemtype="http://schema.org/Article" class="post style1 style1-meta post-143144 type-post status-publish format-standard has-post-thumbnail hentry category-book-reviews category-books category-review tag-kiera-cass tag-the-betrothed tag-ya-fantasy tag-ya-romance" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/143144/the-betrothed-kiera-cass/" rel="bookmark" title="Book Review: The Betrothed by Kiera Cass">
			<img width="280" height="150" src="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/12042819/8142uPFybHL-280x150.jpg" class="no-lazy-load wp-post-image" alt="" />					<figure class="circle_rating small">
			<span>5</span>
			<svg width="50" height="50" viewBox="0 0 50 50" version="1.1" xmlns="http://www.w3.org/2000/svg">
			  <circle class="circle_base" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="0"></circle>
			 	<circle class="circle_perc" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="144.44" data-dashoffset="72.22"></circle>
			</svg>
		</figure>
				</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/books/book-reviews/" class="single_category_title category-link-1781" title="Book Reviews">Book Reviews</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/143144/the-betrothed-kiera-cass/" title="Book Review: The Betrothed by Kiera Cass">Book Review: The Betrothed by Kiera Cass</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/mstanley/" title="Posts by Meagan Stanley" rel="author">Meagan Stanley</a></strong>
		<time class="date published time" datetime="2020-05-12T11:45:54-04:00" itemprop="datePublished" content="2020-05-12T11:45:54-04:00">May 12, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-05-12T11:45:55-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/12042819/8142uPFybHL.jpg">
		  <meta itemprop="width" content="1600">
		  <meta itemprop="height" content="2417">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/143144/the-betrothed-kiera-cass/">
							</aside>
	</article><article itemscope itemtype="http://schema.org/Article" class="post style1 style1-meta post-143017 type-post status-publish format-standard has-post-thumbnail hentry category-book-reviews category-books category-review tag-amanda-sellet tag-by-the-book-a-novel-of-prose-and-cons tag-ya-contemporary" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/143017/by-the-book-novel-prose-cons-amanda-sellet/" rel="bookmark" title="Book Review: By the Book by Amanda Sellet">
			<img width="280" height="150" src="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/04140031/81S8apLoryL-280x150.jpg" class="no-lazy-load wp-post-image" alt="" />					<figure class="circle_rating small">
			<span>9</span>
			<svg width="50" height="50" viewBox="0 0 50 50" version="1.1" xmlns="http://www.w3.org/2000/svg">
			  <circle class="circle_base" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="0"></circle>
			 	<circle class="circle_perc" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="144.44" data-dashoffset="14.444"></circle>
			</svg>
		</figure>
				</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/books/book-reviews/" class="single_category_title category-link-1781" title="Book Reviews">Book Reviews</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/143017/by-the-book-novel-prose-cons-amanda-sellet/" title="Book Review: By the Book by Amanda Sellet">Book Review: By the Book by Amanda Sellet</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/apetree/" title="Posts by Abby Petree" rel="author">Abby Petree</a></strong>
		<time class="date published time" datetime="2020-05-12T08:05:00-04:00" itemprop="datePublished" content="2020-05-12T08:05:00-04:00">May 12, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-05-04T20:06:48-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/05/04140031/81S8apLoryL.jpg">
		  <meta itemprop="width" content="1650">
		  <meta itemprop="height" content="2475">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/143017/by-the-book-novel-prose-cons-amanda-sellet/">
							</aside>
	</article></div></div>				    </div>
				    <div class="small-12 medium-4 large-4 columns">
				        <div id="text-17" class="widget cf widget_text"><strong>@TYFofficial on Spotify</strong>			<div class="textwidget"><p><center><iframe src="//open.spotify.com/embed/user/tyfofficial/playlist/6Vz4AfORooxu2z4fpg9kt3" frameborder="0"></iframe><br />
&nbsp;<br />
&nbsp;<br />
<iframe src="//open.spotify.com/embed/user/tyfofficial/playlist/1QbfPr5WqgAEAfRBRD8WR0" frameborder="0"></iframe> </center></p>
</div>
		</div>				    </div>
				    			    </div>
			</footer>
			<!-- End Footer -->
									<!-- Start Sub Footer -->
			<footer id="subfooter" role="contentinfo" class="dark ">
				<div class="row">
					<div class="small-12 columns">
						<div class="subfooter-menu-holder text-center">
															<a href="https://www.theyoungfolks.com/" class="logolink">
									<img src="/wp-content/uploads/2016/07/cropped-tyf-logo-2016.jpg" class="logoimg" alt="The Young Folks"/>
								</a>
														<div class="subfooter-menu"><ul id="menu-footer-menu" class="footer-menu"><li id="menu-item-24378" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-24378"><a href="https://www.theyoungfolks.com/">Home</a></li>
<li id="menu-item-135847" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135847"><a href="https://www.theyoungfolks.com/about-2/">About The Young Folks</a></li>
<li id="menu-item-24380" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24380"><a href="https://www.theyoungfolks.com/write/">Join the TYF Team!</a></li>
<li id="menu-item-63213" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63213"><a href="https://www.theyoungfolks.com/review-policy/general-comment-policy/">TYF Comment Policy</a></li>
</ul></div>	
							<p>Copyright 2017 The Young Folks. All Rights Reserved </p>
						</div>
					</div>
				</div>
			</footer>
			<!-- End Sub Footer -->
				</section> <!-- End #content-container -->

</div> <!-- End #wrapper -->
	<a href="#" id="scroll_totop"><i class="fa fa-angle-up"></i></a>
	<div style="display:none">
	<div class="grofile-hash-map-b4c5ab20586ef31507efb1f98297f696">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.theyoungfolks.com\/music\/143276\/the-hip-hop-roundup-the-best-from-mays-first-week\/":143276};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/music/143276/the-hip-hop-roundup-the-best-from-mays-first-week/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://www.theyoungfolks.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.3.10'></script>
<script type='text/javascript' src='https://platform.twitter.com/widgets.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"theyoungfolks"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"143276 https:\/\/www.theyoungfolks.com\/?p=143276","disqusShortname":"theyoungfolks","disqusTitle":"The Hip Hop Roundup: The Best From May\u2019s First Week","disqusUrl":"https:\/\/www.theyoungfolks.com\/music\/143276\/the-hip-hop-roundup-the-best-from-mays-first-week\/","postId":"143276"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=202020'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.5/modules/wpgroho.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.1/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/assets/js/vendor.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var themeajax = {"url":"https:\/\/www.theyoungfolks.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/assets/js/app.min.js?ver=2.1.2'></script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.3.3'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.1/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.5/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202020.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.5',blog:'77923915',post:'143276',tz:'-4',srv:'www.theyoungfolks.com'} ]);
	_stq.push([ 'clickTrackerInit', '77923915', '143276' ]);
</script>
</body>
</html>