<!doctype html>
<html lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=1">
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<link rel="pingback" href="https://www.theyoungfolks.com/xmlrpc.php">
	<link rel="icon" href="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/16114115/cropped-TYF-Favicon-2020-rounded-32x32.png" sizes="32x32" />
<link rel="icon" href="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/16114115/cropped-TYF-Favicon-2020-rounded-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/16114115/cropped-TYF-Favicon-2020-rounded-180x180.png" />
<meta name="msapplication-TileImage" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/16114115/cropped-TYF-Favicon-2020-rounded-270x270.png" />
		
	<meta http-equiv="x-dns-prefetch-control" content="on">
	<link rel="dns-prefetch" href="//fonts.googleapis.com" />
	<link rel="dns-prefetch" href="//fonts.gstatic.com" />
	<link rel="dns-prefetch" href="//0.gravatar.com/" />
	<link rel="dns-prefetch" href="//2.gravatar.com/" />
	<link rel="dns-prefetch" href="//1.gravatar.com/" />
	<title>Hip Hop Roundup: Chris Crack, RMC Mike and more | The Young Folks</title>

<!-- All In One SEO Pack 3.6.2[1293,1378] -->
<meta name="description"  content="The roundup is back with new songs from Chris Crack, BBy Goyard, RMC Mike, Nef the Pharaoh and Jiles." />

<meta name="keywords"  content="miles new ep,chris crack new album,nef the pharaoh new song,rmc mike new song,bby goyard new song" />

<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.theyoungfolks.com/#organization","url":"https://www.theyoungfolks.com/","name":"The Young Folks","sameAs":["https://www.facebook.com/TYFofficial/","https://twitter.com/tyfofficial","https://www.instagram.com/TYFofficial/"]},{"@type":"WebSite","@id":"https://www.theyoungfolks.com/#website","url":"https://www.theyoungfolks.com/","name":"The Young Folks","publisher":{"@id":"https://www.theyoungfolks.com/#organization"}},{"@type":"WebPage","@id":"https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/#webpage","url":"https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/","inLanguage":"en-US","name":"Hip Hop Roundup: Chris Crack, Jiles, RMC Mike and more","isPartOf":{"@id":"https://www.theyoungfolks.com/#website"},"breadcrumb":{"@id":"https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/#breadcrumblist"},"description":"The roundup is back with new songs from Chris Crack, BBy Goyard, RMC Mike, Nef the Pharaoh and Jiles.","image":{"@type":"ImageObject","@id":"https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/#primaryimage","url":"https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1.jpg","width":225,"height":225},"primaryImageOfPage":{"@id":"https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/#primaryimage"},"datePublished":"2020-08-07T11:15:00-04:00","dateModified":"2020-08-06T23:11:38-04:00"},{"@type":"Article","@id":"https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/#article","isPartOf":{"@id":"https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/#webpage"},"author":{"@id":"https://www.theyoungfolks.com/author/rfeyre/#author"},"headline":"Hip Hop Roundup: Chris Crack, Jiles, RMC Mike and more","datePublished":"2020-08-07T11:15:00-04:00","dateModified":"2020-08-06T23:11:38-04:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/#webpage"},"publisher":{"@id":"https://www.theyoungfolks.com/#organization"},"articleSection":"Music, Music Features, BBY Goyard, Big Super, Chris Crack, ComptonAss TG, Hip Hop Roundup, Jiles, Lil Yachty, Louie Ray, Nef the Pharaoh, RMC Mike, Teeezy, YN Jay","image":{"@type":"ImageObject","@id":"https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/#primaryimage","url":"https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1.jpg","width":225,"height":225}},{"@type":"Person","@id":"https://www.theyoungfolks.com/author/rfeyre/#author","name":"Ryan Feyre","sameAs":[]},{"@type":"BreadcrumbList","@id":"https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/#breadcrumblist","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.theyoungfolks.com/","url":"https://www.theyoungfolks.com/","name":"The Young Folks: Reviews of Films, Music, TV, Books, and Video Games - Written by young people for young people"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/","url":"https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/","name":"Hip Hop Roundup: Chris Crack, Jiles, RMC Mike and more"}}]}]}</script>
<link rel="canonical" href="https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Hip Hop Roundup: Chris Crack, RMC Mike and more" />
<meta property="og:description" content="The roundup is back with new songs from Chris Crack, BBy Goyard, RMC Mike, Nef the Pharaoh and Jiles." />
<meta property="og:url" content="https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/" />
<meta property="og:site_name" content="The Young Folks" />
<meta property="og:image" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1.jpg" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="1000" />
<meta property="fb:admins" content="156189131064135" />
<meta property="fb:app_id" content="449377471938761" />
<meta property="article:tag" content="#chris crack" />
<meta property="article:tag" content="#rmc mike #bby goyard" />
<meta property="article:tag" content="#nef the pharaoh" />
<meta property="article:tag" content="#jiles" />
<meta property="article:published_time" content="2020-08-07T11:15:00Z" />
<meta property="article:modified_time" content="2020-08-06T23:11:38Z" />
<meta property="article:publisher" content="//www.facebook.com/TheYoungFolks" />
<meta property="og:image:secure_url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@TheYoungFolks" />
<meta name="twitter:domain" content="TheYoungFolks.com" />
<meta name="twitter:title" content="Hip Hop Roundup: Chris Crack, RMC Mike and more" />
<meta name="twitter:description" content="The roundup is back with new songs from Chris Crack, BBy Goyard, RMC Mike, Nef the Pharaoh and Jiles." />
<meta name="twitter:image" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1.jpg" />
			<script type="text/javascript" >
				window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
				ga('create', 'UA-12374332-4', 'auto');
				// Plugins
				
				ga('send', 'pageview');
			</script>
			<script async src="https://www.google-analytics.com/analytics.js"></script>
			<!-- All In One SEO Pack -->
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="The Young Folks &raquo; Feed" href="https://www.theyoungfolks.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Young Folks &raquo; Comments Feed" href="https://www.theyoungfolks.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Young Folks &raquo; Hip Hop Roundup: Chris Crack, Jiles, RMC Mike and more Comments Feed" href="https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/feed/" />
						<meta property="og:title" content="Hip Hop Roundup: Chris Crack, Jiles, RMC Mike and more" />
			<meta property="og:type" content="article" />
			<meta property="og:description" content="Album of the Week: Chris Crack &#8211; Good Cops Don&#8217;t Exist Chicago MC Chris Crack never approaches an album with limited prose. His wisecracking sensibilities (&#8220;Post-Nut Clarity&#8221;) " />
			<meta property="og:image" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1.jpg" />
			<meta property="og:url" content="https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/" />
			<!-- This site uses the Google Analytics by ExactMetrics plugin v6.2.1 - Using Analytics tracking - https://www.exactmetrics.com/ -->
<script type="text/javascript" data-cfasync="false">
	var em_version         = '6.2.1';
	var em_track_user      = true;
	var em_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-12374332-4';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( em_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

window.ga = __gaTracker;		__gaTracker('create', 'UA-12374332-4', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
		__gaTracker( function() { window.ga = __gaTracker; } );
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + em_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
			window.ga = __gaTracker;		})();
		}
</script>
<!-- / Google Analytics by ExactMetrics -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.theyoungfolks.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.4.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://www.theyoungfolks.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.3.10' type='text/css' media='all' />
<link rel='stylesheet' id='ctf_styles-css'  href='https://www.theyoungfolks.com/wp-content/plugins/custom-twitter-feeds/css/ctf-styles.css?ver=1.3' type='text/css' media='all' />
<link rel='stylesheet' id='math-captcha-frontend-css'  href='https://www.theyoungfolks.com/wp-content/plugins/wp-math-captcha/css/frontend.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='thb-fa-css'  href='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/assets/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thb-app-css'  href='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/assets/css/app.css?ver=2.1.2' type='text/css' media='all' />
<style id='thb-app-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='style-css'  href='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='thb-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Droid+Serif%3A300%2C400%2C500%2C600%2C700%2C900%7CPoppins%3A300%2C400%2C500%2C600%2C700%2C900&#038;subset=latin%2Clatin-ext&#038;ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.8/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.8/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/www.theyoungfolks.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend.min.js?ver=6.2.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctf = {"ajax_url":"https:\/\/www.theyoungfolks.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://www.theyoungfolks.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.theyoungfolks.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.theyoungfolks.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='She Dies Tomorrow Review: Amy Seimetz Unleashes Pure, Existential Dread in this Infectious New Horror' href='https://www.theyoungfolks.com/review/145902/she-dies-tomorrow-review-amy-seimetz-unleashes-pure-existential-dread-in-this-infectious-new-horror/' />
<link rel='next' title='Album Review: The Chicks &#8211; &#8220;Gaslighter&#8221;' href='https://www.theyoungfolks.com/music/145982/album-review-the-chicks-gaslighter/' />
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://wp.me/p5gXzl-BWl' />
<link rel="alternate" type="application/json+oembed" href="https://www.theyoungfolks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F145845%2Fhip-hop-roundup-chris-crack-jiles-rmc-mike-and-more%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.theyoungfolks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F145845%2Fhip-hop-roundup-chris-crack-jiles-rmc-mike-and-more%2F&#038;format=xml" />
<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.theyoungfolks.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><link rel="icon" href="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/16114115/cropped-TYF-Favicon-2020-rounded-32x32.png" sizes="32x32" />
<link rel="icon" href="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/16114115/cropped-TYF-Favicon-2020-rounded-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/16114115/cropped-TYF-Favicon-2020-rounded-180x180.png" />
<meta name="msapplication-TileImage" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/16114115/cropped-TYF-Favicon-2020-rounded-270x270.png" />
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>		<meta name="norton-safeweb-site-verification" content="rwr0f6kx274t8xgjjttouapy0u9kpb0pomx7w4ozxn4715jrqzi8dkb6vugohvgwsixwypfm3vwz9ly9lxpj3q9qj4bw56r88xchfe1u8h7bjn63zodcnkdzo47rjg7w" />
</head>
<body class="post-template-default single single-post postid-145845 single-format-standard lazy-load-on thb_ads_header_mobile_off thb-lightbox-off thb-capitalize-off wpb-js-composer js-comp-ver-5.1.1 vc_responsive" data-themeurl="https://www.theyoungfolks.com/wp-content/themes/goodlife-wp">
<div id="wrapper" class="open">
	
	<!-- Start Mobile Menu -->
			<nav id="mobile-menu">
			<div class="custom_scroll" id="menu-scroll">
				<div>
															  <ul id="menu-mobile-menu" class="mobile-menu"><li id="menu-item-135843" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-135843"><a title="About" href="https://www.theyoungfolks.com/about-2/"><span><i class="fa fa-plus"></i></span>About</a>
<ul class="sub-menu">
	<li id="menu-item-135845" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-135845"><a title="About The Young Folks" href="https://www.theyoungfolks.com/about-2/">About The Young Folks</a></li>
	<li id="menu-item-98506" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-98506"><a href="https://www.theyoungfolks.com/write/">Join the TYF Team!</a></li>
	<li id="menu-item-98507" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-98507"><a href="https://www.theyoungfolks.com/review-policy/general-comment-policy/">General Comment Policy</a></li>
</ul>
</li>
<li id="menu-item-98510" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98510 menu-item-category-6"><a href="https://www.theyoungfolks.com/books/"><span><i class="fa fa-plus"></i></span>Books</a>
<ul class="sub-menu">
	<li id="menu-item-98513" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98513 menu-item-category-1781"><a href="https://www.theyoungfolks.com/books/book-reviews/">Book Reviews</a></li>
	<li id="menu-item-98512" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98512 menu-item-category-1784"><a href="https://www.theyoungfolks.com/books/book-news/">Book News</a></li>
	<li id="menu-item-98511" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98511 menu-item-category-1785"><a href="https://www.theyoungfolks.com/books/book-features/">Book Features</a></li>
	<li id="menu-item-98514" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98514 menu-item-category-14026"><a href="https://www.theyoungfolks.com/books/comics/">Comics &#038; Graphic Novels</a></li>
</ul>
</li>
<li id="menu-item-98515" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98515 menu-item-category-3"><a href="https://www.theyoungfolks.com/film/"><span><i class="fa fa-plus"></i></span>Film</a>
<ul class="sub-menu">
	<li id="menu-item-98519" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98519 menu-item-category-1780"><a href="https://www.theyoungfolks.com/film/movie-reviews/">Movie Reviews</a></li>
	<li id="menu-item-98518" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98518 menu-item-category-1782"><a href="https://www.theyoungfolks.com/film/movie-news/">Movie News</a></li>
	<li id="menu-item-98517" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98517 menu-item-category-1783"><a href="https://www.theyoungfolks.com/film/movie-features/">Movie Features</a></li>
	<li id="menu-item-98521" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98521 menu-item-category-1450"><a href="https://www.theyoungfolks.com/film/the-film-canon/">The Film Canon</a></li>
</ul>
</li>
<li id="menu-item-98528" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-98528 menu-item-category-4"><a href="https://www.theyoungfolks.com/music/"><span><i class="fa fa-plus"></i></span>Music</a>
<ul class="sub-menu">
	<li id="menu-item-98533" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98533 menu-item-category-1786"><a href="https://www.theyoungfolks.com/music/music-reviews/"><span><i class="fa fa-plus"></i></span>Music Reviews</a>
	<ul class="sub-menu">
		<li id="menu-item-98529" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98529 menu-item-category-5"><a href="https://www.theyoungfolks.com/music/concerts/">Concert Reviews</a></li>
	</ul>
</li>
	<li id="menu-item-98532" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98532 menu-item-category-1787"><a href="https://www.theyoungfolks.com/music/music-news/">Music News</a></li>
	<li id="menu-item-98531" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-98531 menu-item-category-1788"><a href="https://www.theyoungfolks.com/music/music-features/">Music Features</a></li>
	<li id="menu-item-98530" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98530 menu-item-category-11890"><a href="https://www.theyoungfolks.com/music/from-the-record-crate/">From the Record Crate</a></li>
</ul>
</li>
<li id="menu-item-98534" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98534 menu-item-category-7"><a href="https://www.theyoungfolks.com/television/"><span><i class="fa fa-plus"></i></span>Television</a>
<ul class="sub-menu">
	<li id="menu-item-98537" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98537 menu-item-category-1793"><a href="https://www.theyoungfolks.com/television/tv-reviews/">TV Reviews</a></li>
	<li id="menu-item-98536" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98536 menu-item-category-1794"><a href="https://www.theyoungfolks.com/television/tv-news-television/">TV News</a></li>
	<li id="menu-item-98535" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98535 menu-item-category-1795"><a href="https://www.theyoungfolks.com/television/tv-features/">TV Features</a></li>
</ul>
</li>
<li id="menu-item-98541" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98541 menu-item-category-13"><a href="https://www.theyoungfolks.com/video-games/"><span><i class="fa fa-plus"></i></span>Video Games</a>
<ul class="sub-menu">
	<li id="menu-item-98544" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98544 menu-item-category-1797"><a href="https://www.theyoungfolks.com/video-games/video-game-reviews/">Video Game Reviews</a></li>
	<li id="menu-item-98542" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98542 menu-item-category-1798"><a href="https://www.theyoungfolks.com/video-games/gaming-news/">Gaming News</a></li>
	<li id="menu-item-98543" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98543 menu-item-category-1799"><a href="https://www.theyoungfolks.com/video-games/video-game-features/">Video Game Features</a></li>
</ul>
</li>
<li id="menu-item-98538" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98538 menu-item-category-259"><a title="Lists" href="https://www.theyoungfolks.com/top-10-2/">Lists</a></li>
<li id="menu-item-98540" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98540 menu-item-category-15"><a href="https://www.theyoungfolks.com/tyf-media/podcast/"><span><i class="fa fa-plus"></i></span>Podcasts</a>
<ul class="sub-menu">
	<li id="menu-item-98508" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98508 menu-item-category-6411"><a href="https://www.theyoungfolks.com/tyf-media/tyf-vlog/">Videos</a></li>
</ul>
</li>
<li id="menu-item-98522" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98522 menu-item-category-1789"><a href="https://www.theyoungfolks.com/giveaways/"><span><i class="fa fa-plus"></i></span>Giveaways</a>
<ul class="sub-menu">
	<li id="menu-item-98523" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98523 menu-item-category-1791"><a href="https://www.theyoungfolks.com/giveaways/book-giveaways/">Book Giveaways</a></li>
	<li id="menu-item-98524" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98524 menu-item-category-1790"><a href="https://www.theyoungfolks.com/giveaways/movie-giveaways/"><span><i class="fa fa-plus"></i></span>Movie Giveaways</a>
	<ul class="sub-menu">
		<li id="menu-item-98526" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98526 menu-item-category-1266"><a href="https://www.theyoungfolks.com/giveaways/screening/">Screenings</a></li>
	</ul>
</li>
	<li id="menu-item-98525" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98525 menu-item-category-1792"><a href="https://www.theyoungfolks.com/giveaways/music-giveaways/">Music Giveaways</a></li>
	<li id="menu-item-98527" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98527 menu-item-category-12263"><a href="https://www.theyoungfolks.com/giveaways/tv-giveaways/">TV Giveaways</a></li>
</ul>
</li>
</ul>															<div class="social-links">
								<a href="https://www.facebook.com/TheYoungFolks" class="facebook icon-1x" target="_blank"><i class="fa fa-facebook"></i></a>
				<a href="https://twitter.com/theyoungfolks" class="twitter icon-1x" target="_blank"><i class="fa fa-twitter"></i></a>
				<a href="https://www.instagram.com/theyoungfolks/" class="instagram icon-1x" target="_blank"><i class="fa fa-instagram"></i></a>
							<a href="https://soundcloud.com/tyfofficial" class="soundcloud icon-1x" target="_blank"><i class="fa fa-soundcloud"></i></a>
				<a href="https://www.youtube.com/c/theyoungfolks" class="youtube icon-1x" target="_blank"><i class="fa fa-youtube"></i></a>
			<a href="https://play.spotify.com/user/tyfofficial" class="spotify icon-1x" target="_blank"><i class="fa fa-spotify"></i></a>
					<a href="https://feeds.feedburner.com/TheYoungFolks" class="rss icon-1x" target="_blank"><i class="fa fa-rss"></i></a>
							</div>
					<div class="menu-footer">
											</div>
				</div>
			</div>
		</nav>
		<!-- End Mobile Menu -->
	
	<!-- Start Content Container -->
	<section id="content-container">
		<!-- Start Content Click Capture -->
		<div class="click-capture"></div>
		<!-- End Content Click Capture -->
		<!-- Start Fixed Header -->
<div class="subheader fixed show-for-large light">
			<div class="row full-width-row">
			<div class="medium-8 columns logo">
				<div>
										<a href="https://www.theyoungfolks.com/" class="logolink">
						<img src="/wp-content/uploads/2017/02/2017-logo-21.png" class="logoimg" alt="The Young Folks"/>
					</a>
					<span class="page-title" id="page-title">Hip Hop Roundup: Chris Crack, Jiles, RMC Mike and more</span>
				</div>
			</div>
			<div class="medium-4 columns">
				 		<aside class="share-article-vertical hide-on-print ">
		<h6>0<span>Shares</span></h6>

				<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F145845%2Fhip-hop-roundup-chris-crack-jiles-rmc-mike-and-more%2F" class="facebook social"><i class="fa fa-facebook"></i><span>0</span></a>
						<a href="https://twitter.com/intent/tweet?text=Hip+Hop+Roundup%3A+Chris+Crack%2C+Jiles%2C+RMC+Mike+and+more&url=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F145845%2Fhip-hop-roundup-chris-crack-jiles-rmc-mike-and-more%2F&via=theyoungfolks" class="twitter social "><i class="fa fa-twitter"></i><span>0</span></a>
								<a href="http://pinterest.com/pin/create/link/?url=https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/&media=https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1.jpg&description=Hip+Hop+Roundup%3A+Chris+Crack%2C+Jiles%2C+RMC+Mike+and+more" class="pinterest social" nopin="nopin" data-pin-no-hover="true"><i class="fa fa-pinterest"></i><span>0</span></a>
						<a href="https://www.linkedin.com/cws/share?url=https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/" class="linkedin social"><i class="fa fa-linkedin"></i><span>0</span></a>
						<a href="whatsapp://send?text=Hip+Hop+Roundup%3A+Chris+Crack%2C+Jiles%2C+RMC+Mike+and+more" class="whatsapp social" data-href="https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/" data-action="share/whatsapp/share"><i class="fa fa-whatsapp"></i><span><i class="fa fa-whatsapp"></i></span></a>
			</aside>
				</div>
							<span class="progress"></span>
					</div>
		
	</div>
<!-- End Fixed Header -->
<!-- Start Sub Header -->
<div class="subheader show-for-large light ">
	<div class="row full-width-row">
		<div class="small-12 medium-6 large-7 columns">
			<nav class="subheader-menu">
				<ul id="menu-home" class="sf-menu"><li id="menu-item-12558" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-12558"><a href="https://www.theyoungfolks.com/">Home</a></li>
<li id="menu-item-135846" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135846"><a href="https://www.theyoungfolks.com/about-2/">About The Young Folks</a></li>
<li id="menu-item-12561" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12561"><a href="https://www.theyoungfolks.com/review-policy/">Review &#038; Promotion Policy</a></li>
<li id="menu-item-63212" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63212"><a href="https://www.theyoungfolks.com/review-policy/general-comment-policy/">TYF Comment Policy</a></li>
<li id="menu-item-12562" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12562"><a href="https://www.theyoungfolks.com/write/">Join the TYF Team!</a></li>
</ul>			</nav>
		</div>
		<div class="small-12 medium-6 large-5 columns text-right">
			<ul class="sf-menu right-menu">
					<li class="menu-item-has-children">
		<a href="#">Follow Us</a>
		<ul class="sub-menu">
						<li><a href="https://www.facebook.com/TheYoungFolks" class="facebook icon-1x" target="_blank"><i class="fa fa-facebook"></i> Facebook</a></li>
												<li><a href="https://twitter.com/theyoungfolks" class="twitter icon-1x" target="_blank"><i class="fa fa-twitter"></i> Twitter</a></li>
												<li><a href="https://www.instagram.com/theyoungfolks/" class="instagram icon-1x" target="_blank"><i class="fa fa-instagram"></i> Instagram</a></li>
																					<li><a href="https://soundcloud.com/tyfofficial" class="soundcloud icon-1x" target="_blank"><i class="fa fa-soundcloud"></i> Soundcloud</a></li>
												<li><a href="https://www.youtube.com/c/theyoungfolks" class="youtube icon-1x" target="_blank"><i class="fa fa-youtube"></i> Youtube</a></li>
									<li><a href="https://play.spotify.com/user/tyfofficial" class="spotify icon-1x" target="_blank"><i class="fa fa-spotify"></i> Spotify</a></li>
															<li><a href="https://feeds.feedburner.com/TheYoungFolks" class="rss icon-1x" target="_blank"><i class="fa fa-rss"></i> RSS</a></li>
									<li><a href="https://www.twitch.tv/tyfofficial" class="twitch icon-1x" target="_blank"><i class="fa fa-twitch"></i> Twitch.tv</a></li>
					</ul>
	</li>
									<li>	<div class="quick_search">
		<a href="#" class="quick_toggle"></a>
		<svg version="1.1" class="quick_search_icon" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="20px" height="20px" viewBox="0 -1 20 18" xml:space="preserve">
			<path d="M18.96,16.896l-4.973-4.926c1.02-1.255,1.633-2.846,1.633-4.578c0-4.035-3.312-7.317-7.385-7.317S0.849,3.358,0.849,7.393
				c0,4.033,3.313,7.316,7.386,7.316c1.66,0,3.188-0.552,4.422-1.471l4.998,4.95c0.181,0.179,0.416,0.268,0.652,0.268
				c0.235,0,0.472-0.089,0.652-0.268C19.32,17.832,19.32,17.253,18.96,16.896z M2.693,7.393c0-3.027,2.485-5.489,5.542-5.489
				c3.054,0,5.541,2.462,5.541,5.489c0,3.026-2.486,5.489-5.541,5.489C5.179,12.882,2.693,10.419,2.693,7.393z"/>
		</svg>
		<!-- Start SearchForm -->
<form method="get" class="searchform" role="search" action="https://www.theyoungfolks.com/">
    <fieldset>
    	<input name="s" type="text" placeholder="Search" class="s">
    	<input type="submit" value="Search">
    </fieldset>
</form>
<!-- End SearchForm -->	</div>
	
</li>			</ul>
		</div>
	</div>
</div>
<!-- End Sub Header -->
<!-- Start Header -->
<header class="header style3  light" role="banner">
	<div class="row">
		<div class="small-2 columns text-left mobile-icon-holder">
			<a href="#" data-target="open-menu" class="mobile-toggle"><i class="fa fa-bars"></i></a>
		</div>
		<div class="small-8 large-12 columns logo">
			<div id="menu_width">
								<a href="https://www.theyoungfolks.com/" class="logolink">
					<img src="/wp-content/uploads/2017/02/2017-logo-21.png" class="logoimg" alt="The Young Folks"/>
				</a>
				<nav class="menu-holder">
										  <ul id="menu-main-nav-categories" class="sf-menu style3"><li id="menu-item-12523" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12523 menu-item-category-3"><a title="Movies" href="https://www.theyoungfolks.com/film/">Movies</a>


<ul class="sub-menu ">
	<li id="menu-item-12536" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12536 menu-item-category-1780"><a href="https://www.theyoungfolks.com/film/movie-reviews/">Movie Reviews</a></li>
	<li id="menu-item-12535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12535 menu-item-category-1782"><a href="https://www.theyoungfolks.com/film/movie-news/">Movie News</a></li>
	<li id="menu-item-12534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12534 menu-item-category-1783"><a title="Movie Features" href="https://www.theyoungfolks.com/film/movie-features/">Movie Features</a></li>
	<li id="menu-item-12537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12537 menu-item-category-1450"><a href="https://www.theyoungfolks.com/film/the-film-canon/">The Film Canon</a>
	<ul class="sub-menu ">
		<li id="menu-item-12807" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12807"><a title="TFC Index" href="https://www.theyoungfolks.com/the-film-canon/">TFC Index</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-12522" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12522 menu-item-category-6"><a href="https://www.theyoungfolks.com/books/">Books</a>


<ul class="sub-menu ">
	<li id="menu-item-12532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12532 menu-item-category-1781"><a href="https://www.theyoungfolks.com/books/book-reviews/">Book Reviews</a>
	<ul class="sub-menu ">
		<li id="menu-item-12899" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12899 menu-item-category-1925"><a href="https://www.theyoungfolks.com/books/book-reviews/audiobook-reviews/">Audiobook Reviews</a></li>
	</ul>
</li>
	<li id="menu-item-12530" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12530 menu-item-category-1785"><a href="https://www.theyoungfolks.com/books/book-features/">Book Features</a></li>
	<li id="menu-item-12531" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12531 menu-item-category-1784"><a href="https://www.theyoungfolks.com/books/book-news/">Book News</a></li>
	<li id="menu-item-54742" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54742 menu-item-category-14026"><a href="https://www.theyoungfolks.com/books/comics/">Comics &#038; Graphic Novels</a></li>
</ul>
</li>
<li id="menu-item-12525" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-12525 menu-item-category-4"><a href="https://www.theyoungfolks.com/music/">Music</a>


<ul class="sub-menu ">
	<li id="menu-item-12545" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12545 menu-item-category-1786"><a href="https://www.theyoungfolks.com/music/music-reviews/">Music Reviews</a></li>
	<li id="menu-item-12542" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12542 menu-item-category-5"><a href="https://www.theyoungfolks.com/music/concerts/">Concert Reviews</a></li>
	<li id="menu-item-12544" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12544 menu-item-category-1787"><a href="https://www.theyoungfolks.com/music/music-news/">Music News</a></li>
	<li id="menu-item-12543" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12543 menu-item-category-1788"><a href="https://www.theyoungfolks.com/music/music-features/">Music Features</a></li>
	<li id="menu-item-43919" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-43919 menu-item-category-11890"><a href="https://www.theyoungfolks.com/music/from-the-record-crate/">From the Record Crate</a>
	<ul class="sub-menu ">
		<li id="menu-item-43920" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43920"><a title="FtRC Index" href="https://www.theyoungfolks.com/from-the-record-crate/">FtRC Index</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-12526" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12526 menu-item-category-7"><a href="https://www.theyoungfolks.com/television/">Television</a>


<ul class="sub-menu ">
	<li id="menu-item-12548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12548 menu-item-category-1793"><a href="https://www.theyoungfolks.com/television/tv-reviews/">TV Reviews</a></li>
	<li id="menu-item-12547" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12547 menu-item-category-1794"><a href="https://www.theyoungfolks.com/television/tv-news-television/">TV News</a></li>
	<li id="menu-item-12546" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12546 menu-item-category-1795"><a href="https://www.theyoungfolks.com/television/tv-features/">TV Features</a></li>
</ul>
</li>
<li id="menu-item-12529" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12529 menu-item-category-13"><a href="https://www.theyoungfolks.com/video-games/">Video Games</a>


<ul class="sub-menu ">
	<li id="menu-item-12554" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12554 menu-item-category-1797"><a href="https://www.theyoungfolks.com/video-games/video-game-reviews/">Video Game Reviews</a></li>
	<li id="menu-item-12552" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12552 menu-item-category-1798"><a href="https://www.theyoungfolks.com/video-games/gaming-news/">Gaming News</a></li>
	<li id="menu-item-12553" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12553 menu-item-category-1799"><a href="https://www.theyoungfolks.com/video-games/video-game-features/">Video Game Features</a></li>
</ul>
</li>
<li id="menu-item-12527" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12527 menu-item-category-259"><a title="Lists" href="https://www.theyoungfolks.com/top-10-2/">Lists</a></li>
<li id="menu-item-83832" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-83832"><a href="https://www.theyoungfolks.com/tyf-podcasts-video-series/">Podcasts &#038; More</a>


<ul class="sub-menu ">
	<li id="menu-item-12551" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12551 menu-item-category-15"><a href="https://www.theyoungfolks.com/tyf-media/podcast/">Podcasts</a></li>
	<li id="menu-item-24973" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24973 menu-item-category-6411"><a href="https://www.theyoungfolks.com/tyf-media/tyf-vlog/">Videos</a></li>
	<li id="menu-item-12549" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12549 menu-item-category-1796"><a href="https://www.theyoungfolks.com/tyf-column/editorials/">Editorials</a>
	<ul class="sub-menu ">
		<li id="menu-item-12550" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12550 menu-item-category-975"><a href="https://www.theyoungfolks.com/tyf-column/latinx-spotlight/">Latinx Spotlight</a></li>
	</ul>
</li>
</ul>
</li>
</ul>																			</nav>
			</div>
		</div>
		<div class="small-2 columns text-right mobile-share-holder">
			<div>
				<div class="quick_search">
		<a href="#" class="quick_toggle"></a>
		<svg version="1.1" class="quick_search_icon" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="20px" height="20px" viewBox="0 -1 20 18" xml:space="preserve">
			<path d="M18.96,16.896l-4.973-4.926c1.02-1.255,1.633-2.846,1.633-4.578c0-4.035-3.312-7.317-7.385-7.317S0.849,3.358,0.849,7.393
				c0,4.033,3.313,7.316,7.386,7.316c1.66,0,3.188-0.552,4.422-1.471l4.998,4.95c0.181,0.179,0.416,0.268,0.652,0.268
				c0.235,0,0.472-0.089,0.652-0.268C19.32,17.832,19.32,17.253,18.96,16.896z M2.693,7.393c0-3.027,2.485-5.489,5.542-5.489
				c3.054,0,5.541,2.462,5.541,5.489c0,3.026-2.486,5.489-5.541,5.489C5.179,12.882,2.693,10.419,2.693,7.393z"/>
		</svg>
		<!-- Start SearchForm -->
<form method="get" class="searchform" role="search" action="https://www.theyoungfolks.com/">
    <fieldset>
    	<input name="s" type="text" placeholder="Search" class="s">
    	<input type="submit" value="Search">
    </fieldset>
</form>
<!-- End SearchForm -->	</div>
	
			</div>
		</div>
	</div>
</header>
<!-- End Header -->		
		<div role="main" class=""><div id="infinite-article" data-infinite="on" class="on">
			<div class="row post-detail-row top-padding">
	<div class="small-12 medium-8 columns">

	  <article itemscope itemtype="http://schema.org/Article" class="post blog-post post-145845 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-features tag-bby-goyard tag-big-super tag-chris-crack tag-comptonass-tg tag-hip-hop-roundup tag-jiles tag-lil-yachty tag-louie-ray tag-nef-the-pharaoh tag-rmc-mike tag-teeezy tag-yn-jay" id="post-145845" role="article" data-id="145845" data-url="https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/">
	  	<header class="post-title entry-header">
	  		<a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a>	  		<h1 class="entry-title" itemprop="name headline">Hip Hop Roundup: Chris Crack, Jiles, RMC Mike and more</h1>	  			<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time" datetime="2020-08-07T07:15:00-04:00" itemprop="datePublished" content="2020-08-07T07:15:00-04:00">August 7, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-08-06T19:11:38-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1.jpg">
		  <meta itemprop="width" content="225">
		  <meta itemprop="height" content="225">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/">
							</aside>
		  	</header>
	  		  	<figure class="post-gallery">
	  		<img width="225" height="225" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1.jpg" class="attachment-goodlife-post-style1 size-goodlife-post-style1 wp-post-image" alt="" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1.jpg 225w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1-150x150.jpg 150w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1-24x24.jpg 24w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1-48x48.jpg 48w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1-96x96.jpg 96w" sizes="(max-width: 225px) 100vw, 225px" />	  			  	</figure>
	  		  	<div class="share-container">
		  	 		<aside class="share-article-vertical hide-on-print fixed-me show-for-medium">
		<h6>0<span>Shares</span></h6>

				<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F145845%2Fhip-hop-roundup-chris-crack-jiles-rmc-mike-and-more%2F" class="facebook social"><i class="fa fa-facebook"></i><span>0</span></a>
						<a href="https://twitter.com/intent/tweet?text=Hip+Hop+Roundup%3A+Chris+Crack%2C+Jiles%2C+RMC+Mike+and+more&url=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F145845%2Fhip-hop-roundup-chris-crack-jiles-rmc-mike-and-more%2F&via=theyoungfolks" class="twitter social "><i class="fa fa-twitter"></i><span>0</span></a>
								<a href="http://pinterest.com/pin/create/link/?url=https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/&media=https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1.jpg&description=Hip+Hop+Roundup%3A+Chris+Crack%2C+Jiles%2C+RMC+Mike+and+more" class="pinterest social" nopin="nopin" data-pin-no-hover="true"><i class="fa fa-pinterest"></i><span>0</span></a>
						<a href="https://www.linkedin.com/cws/share?url=https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/" class="linkedin social"><i class="fa fa-linkedin"></i><span>0</span></a>
						<a href="whatsapp://send?text=Hip+Hop+Roundup%3A+Chris+Crack%2C+Jiles%2C+RMC+Mike+and+more" class="whatsapp social" data-href="https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/" data-action="share/whatsapp/share"><i class="fa fa-whatsapp"></i><span><i class="fa fa-whatsapp"></i></span></a>
			</aside>
				  <div class="post-content-container">
					<div class="post-content entry-content cf">
									    	
<h3>Album of the Week: Chris Crack &#8211; <em>Good Cops Don&#8217;t Exist</em></h3>



<figure class="wp-block-embed-spotify aligncenter wp-block-embed is-type-rich is-provider-spotify wp-embed-aspect-9-16 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<iframe title="Spotify Embed: Good Cops Don&#039;t Exist" width="300" height="380" allowtransparency="true" frameborder="0" allow="encrypted-media" src="https://open.spotify.com/embed/album/5p3C59yPTGqDaSscHL83dO?si=R2-jsnYWQhGZuyMj_2VkkQ"></iframe>
</div></figure>



<p>Chicago MC Chris Crack never approaches an album with limited prose. His wisecracking sensibilities (&#8220;Post-Nut Clarity&#8221;) can quickly morph into piercing imagery (&#8220;White Lies Cost Black Lives&#8221;) on the drop of a dime. He neglects any semblance of a traditional album rollout, opting instead for three to four projects a year filled with social commentary, offbeat humor and technical wizardry. Sure, his raps play out in an Earl-like stream-of-consciousness, but unlike Mr. Sweatshirt, Crack shies away from theoretical existentialism. Rather, he walks a fine line between emotionally-driven vignettes and brutally honest pragmatism.</p>



<p>His newest album <em>Good Cops Don&#8217;t Exist</em> continues this streak of conscious wit and metaphorical realism. The production feels organically charismatic,  which bodes well next too Crack&#8217;s animated delivery. Every song sounds poetically caustic and artistically boundless. The cover art and song titles are just as fascinating as Crack&#8217;s lyrical prowess, sometimes even surpassing the latter in blunt intensity. &#8220;Go Where Your Prioritized&#8221; is a powerful combination of titular brilliance, memorable storytelling, and intermittent zaniness with regards to love (&#8220;Never been a kisser/Only roll papers in the swisher/Henny right here but I&#8217;mma miss her, used to take pictures&#8221;). The overarching theme involves surrounding yourself with the right people, but love&#8217;s fleeting temptations can sometimes stand in the way of that.</p>



<p>Not all albums have to contain some type of consistent thread of concept and sound. Oftentimes, the most exciting projects are the unpredictable ones. Crack never ceases to amaze, which is why his transparent self-awareness is so mesmerizing. The obvious soulfulness is apparent throughout every one of his endeavors, but Crack&#8217;s monumental scriptures are what bring these frames to life. His personality is far from monolithic, as evidenced on multiple songs, though never more apparent then on &#8220;I Know a Place.&#8221; Crack flips a juvenile infatuation for a girl (&#8220;She do the D like a running back in a pumpkin patch/them kitties look like saddlebags&#8221;) into a broader message on misogyny (&#8220;God will turn a whole mess into a message/I&#8217;m just saying, let&#8217;s be less sexist&#8221;). It&#8217;s certainly not the most nuanced way of approaching the societal problem, but Crack&#8217;s stark firmness and honesty makes for a genuine sentiment. He&#8217;s a lot like early Danny Brown, but less hedonistic and more revelatory (both styles are great in their own way). </p>



<p>Most music traditionalists would probably prefer a more conventional way of album rollouts, or at the very least, room to breathe before the next release. I totally understand this viewpoint, especially since Lil Uzi has essentially guaranteed a deluxe edition for every subsequent mainstream rap album. However, I do think there&#8217;s something admirable about Crack&#8217;s ceaseless output. The one to two minute songs are less about grandiosity and more about raw emotion. There&#8217;s an obvious thread of timely concepts, but he never feels the need to completely adhere to them. He&#8217;s fine going on tangents about other personal experiences. </p>



<p>With everything that&#8217;s currently going on, I&#8217;m not surprised Crack wants to say as much as possible about whatever the hell comes to his mind. At the end of the day, everyone has some type of chip on their shoulder, or some type of message to get across. It&#8217;s just a matter of how you want to express yourself, and channel that drive. Crack lets it out through wholehearted confessionals and one-of-a-kind storytelling. </p>



<h3>RMC Mike, Lil Yachty, YN Jay, and Louie Ray &#8211; &#8220;Flintana&#8221;</h3>



<figure class="wp-block-embed-youtube aligncenter wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<div class="flex-video widescreen youtube"><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' width='1170' height='659' src='https://www.youtube.com/embed/g4J8_3Omn9o?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent&#038;showinfo=0&#038;rel=0&#038;modestbranding=1' allowfullscreen='true' style='border:0;'></iframe></span></div>
</div></figure>



<p>Have you ever watched a show or a movie on TV that, every once in awhile, would insert little tidbits of information about what went into the  production of said movie or show? It&#8217;s usually featured at the top or bottom of the screen if you haven&#8217;t. Normally, the information ranges from what went on behind-the-scenes, to original script ideas, to something as small as actor idiosyncrasies. </p>



<p>This Flint posse cut (and Lil Yachty) is exactly like any Marvel movie that gave you small information about Robert Downey&#8217;s rigorous training before Iron Man, or how Chris Evans&#8217; ass became &#8220;America&#8217;s Ass&#8221; (okay, I don&#8217;t think TV would offer something like this, but <a href="https://www.theringer.com/movies/2019/4/30/18523227/avengers-endgame-captain-america-butt-investigation">The Ringer</a> did). Trading these fantastical superheroes for real Michigan rappers isn&#8217;t much of a far-fetched substitute. In fact, Michigan may feature a tighter squad of Avengers. Artists like RMC Mike and Rio Da Yung OG have never let differing personalities and internal brotherly conflict tear them apart. If anything, their talents have brought them closer.</p>



<p>Instead of searching for power, Mike, YN Jay, Yachty, and Louie Ray are in pursuit of wildly creative barbs. This song is structurally no different from any Michigan posse cut. On the surface, it&#8217;s just four guys spitting verses in relay-like fashion over a jittery beat. It&#8217;s the little subtitles that really make this particular video stand out. We&#8217;ve heard about Mike&#8217;s drug dealing before, as well as Yachty&#8217;s love of diamond carats. But I&#8217;ve never officially learned about how bright those carats are (I still don&#8217;t get the vernacular, but I&#8217;m interested), or where Louie keeps his weed. I&#8217;m also interested in why YN Jay hilariously couldn&#8217;t remember his lyrics before shooting this video. These tidbits of information offer much-needed clarity. They&#8217;re also why I love Michigan&#8217;s rap scene so much. </p><div class="A6AShBU3" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>



<h3>ComptonAss TG, Nef the Pharaoh and Teeezy &#8211; &#8220;Compton 2 Da Bay&#8221;</h3>



<figure class="wp-block-embed-youtube aligncenter wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<div class="flex-video widescreen youtube"><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' width='1170' height='659' src='https://www.youtube.com/embed/qg9J-z0a-B8?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent&#038;showinfo=0&#038;rel=0&#038;modestbranding=1' allowfullscreen='true' style='border:0;'></iframe></span></div>
</div></figure>



<p>Th eery composure of Nef paired with Compton and Teeezy&#8217;s gruff regional frankness makes for a worthwhile bridge between Compton and the Bay Area. The video&#8217;s color scheme is equal parts grimy and vibrant, as evidenced by the graffiti art plastered on the run-down warehouse. Funny how much you could learn about a specific environment in short three-minute music videos. Nef&#8217;s been virtually unavoidable this year, which is a great thing to witness. He has a knack for combining grittiness with melody, kind of like RBE&#8217;s Yhung T.O.</p>



<h3>Jiles &#8211; &#8220;Stones&#8221; (feat. Big Super)</h3>



<figure class="wp-block-embed-youtube aligncenter wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-4-3 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<div class="flex-video widescreen youtube"><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' width='1170' height='659' src='https://www.youtube.com/embed/EiLkk0CBXXI?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent&#038;showinfo=0&#038;rel=0&#038;modestbranding=1' allowfullscreen='true' style='border:0;'></iframe></span></div>
</div></figure>



<p> Jiles raps with a sneer on his face at all times, and channels his own realities through burly confessionals and creative hooks (&#8220;Ring around the rosie, pocket full of stones&#8221;). His new EP <em>It&#8217;s Not Much, But It&#8217;s Mine</em> finds the Brockton spitter approaching his art without pressure. His writing is meticulous, but functions without regard for outsiders who don&#8217;t give a shit. &#8220;Stones&#8221; sounds urgent yet reflective of Jiles&#8217; personal circumstances. He&#8217;s bound to catch people&#8217;s attention outside of Massachusetts. </p>



<h3>BBY Goyard &#8211; &#8220;I Swear They Hate U&#8221;</h3>



<figure class="wp-block-embed-soundcloud aligncenter wp-block-embed is-type-rich is-provider-soundcloud wp-embed-aspect-4-3 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<iframe title="I swear they hate u (prod. deceased x blvnts x snoozed) by BBY GOYARD" width="1170" height="400" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player/?visual=true&#038;url=https%3A%2F%2Fapi.soundcloud.com%2Ftracks%2F868665253&#038;show_artwork=true&#038;maxwidth=1170&#038;maxheight=1000&#038;dnt=1"></iframe>
</div></figure>



<p>I need a BBY Goyard and 100 gecs collaboration. Then I&#8217;ll be happy. </p>
<div class="IZYXLszN" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Bottom Post Link Ads -->
<ins class="adsbygoogle"
     style="display: block;height: 100px;overflow: hidden;"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="4109762806"
     data-ad-format="link"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-145845" class="share-facebook sd-button share-icon" href="https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-145845" class="share-twitter sd-button share-icon" href="https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div>			    				    	
					</div>
				</div>
			</div>
						<footer class="article-tags entry-footer">
			<div>
		<span class="tags-title">Tags</span> 
		<a href="https://www.theyoungfolks.com/tag/bby-goyard/" title="" class="tag-link">BBY Goyard</a> <a href="https://www.theyoungfolks.com/tag/big-super/" title="" class="tag-link">Big Super</a> <a href="https://www.theyoungfolks.com/tag/chris-crack/" title="" class="tag-link">Chris Crack</a> <a href="https://www.theyoungfolks.com/tag/comptonass-tg/" title="" class="tag-link">ComptonAss TG</a> <a href="https://www.theyoungfolks.com/tag/hip-hop-roundup/" title="" class="tag-link">Hip Hop Roundup</a> <a href="https://www.theyoungfolks.com/tag/jiles/" title="" class="tag-link">Jiles</a> <a href="https://www.theyoungfolks.com/tag/lil-yachty/" title="" class="tag-link">Lil Yachty</a> <a href="https://www.theyoungfolks.com/tag/louie-ray/" title="" class="tag-link">Louie Ray</a> <a href="https://www.theyoungfolks.com/tag/nef-the-pharaoh/" title="" class="tag-link">Nef the Pharaoh</a> <a href="https://www.theyoungfolks.com/tag/rmc-mike/" title="" class="tag-link">RMC Mike</a> <a href="https://www.theyoungfolks.com/tag/teeezy/" title="" class="tag-link">Teeezy</a> <a href="https://www.theyoungfolks.com/tag/yn-jay/" title="" class="tag-link">YN Jay</a>	</div>
</footer>
 
<section class="post-author">
		<img width="106" height="106" src="https://cdn1.theyoungfolks.com/wp-content/uploads/2017/02/19155218/b4c5ab20586ef31507efb1f98297f696.jpg" class="avatar avatar-164 photo" alt="" srcset="https://cdn1.theyoungfolks.com/wp-content/uploads/2017/02/19155218/b4c5ab20586ef31507efb1f98297f696.jpg 106w, https://cdn1.theyoungfolks.com/wp-content/uploads/2017/02/19155218/b4c5ab20586ef31507efb1f98297f696-24x24.jpg 24w, https://cdn1.theyoungfolks.com/wp-content/uploads/2017/02/19155218/b4c5ab20586ef31507efb1f98297f696-48x48.jpg 48w, https://cdn1.theyoungfolks.com/wp-content/uploads/2017/02/19155218/b4c5ab20586ef31507efb1f98297f696-96x96.jpg 96w" sizes="(max-width: 106px) 100vw, 106px" />	<div class="author-content">
		<h5><a href="https://www.theyoungfolks.com/author/rfeyre/">Ryan Feyre</a></h5>
				<p>Ryan Feyre is a writer for The Young Folks.</p>
									</div>
	</section>
 		<aside class="share-article hide-on-print ">
		<div class="row">
			<div class="small-12 medium-5 columns">
				<h6>Share This</h6>
			</div>
			<div class="small-12 medium-7 columns small-only-text-center text-right">
				<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F145845%2Fhip-hop-roundup-chris-crack-jiles-rmc-mike-and-more%2F" class="facebook social"><i class="fa fa-facebook"></i><span>0</span></a>
						<a href="https://twitter.com/intent/tweet?text=Hip+Hop+Roundup%3A+Chris+Crack%2C+Jiles%2C+RMC+Mike+and+more&url=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F145845%2Fhip-hop-roundup-chris-crack-jiles-rmc-mike-and-more%2F&via=theyoungfolks" class="twitter social "><i class="fa fa-twitter"></i><span>0</span></a>
								<a href="http://pinterest.com/pin/create/link/?url=https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/&media=https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1.jpg&description=Hip+Hop+Roundup%3A+Chris+Crack%2C+Jiles%2C+RMC+Mike+and+more" class="pinterest social" nopin="nopin" data-pin-no-hover="true"><i class="fa fa-pinterest"></i><span>0</span></a>
						<a href="https://www.linkedin.com/cws/share?url=https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/" class="linkedin social"><i class="fa fa-linkedin"></i><span>0</span></a>
						<a href="whatsapp://send?text=Hip+Hop+Roundup%3A+Chris+Crack%2C+Jiles%2C+RMC+Mike+and+more" class="whatsapp social" data-href="https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/" data-action="share/whatsapp/share"><i class="fa fa-whatsapp"></i></a>
					</div>
	</aside>
	 
			<div class="row post-navi hide-on-print no-padding">
				<div class="small-12 medium-6 columns">
					<span>Previous Article</span><a href="https://www.theyoungfolks.com/review/145902/she-dies-tomorrow-review-amy-seimetz-unleashes-pure-existential-dread-in-this-infectious-new-horror/" title="She Dies Tomorrow Review: Amy Seimetz Unleashes Pure, Existential Dread in this Infectious New Horror">She Dies Tomorrow Review: Amy Seimetz Unleashes Pure, Existential Dread in this Infectious New Horror</a>				</div>
				<div class="small-12 medium-6 columns">
					<span>Next Article</span><a href="https://www.theyoungfolks.com/music/145982/album-review-the-chicks-gaslighter/" title="Album Review: The Chicks - "Gaslighter"">Album Review: The Chicks - "Gaslighter"</a>				</div>
			</div>
			  </article>

					
<div id="disqus_thread"></div>
			</div>
	<aside class="sidebar small-12 medium-4 columns" role="complementary">
	<div class="sidebar_inner fixed-me">
		<div id="thb_singlead_widget-10" class="widget cf widget_singlead"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div id="thb_latestimages_widget-1" class="widget cf widget_latestimages"><strong>Latest Posts</strong><ul><li itemscope itemtype="http://schema.org/Article" class="post listing post-145982 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-reviews tag-featured tag-gaslighter tag-the-chicks" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/music/145982/album-review-the-chicks-gaslighter/" rel="bookmark" title="Album Review: The Chicks &#8211; &#8220;Gaslighter&#8221;">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/05214824/dixie-chicks-the-chicks-gaslighter-album-over-artwork-change-name-new-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/05214824/dixie-chicks-the-chicks-gaslighter-album-over-artwork-change-name-new-80x75.jpg 80w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/05214824/dixie-chicks-the-chicks-gaslighter-album-over-artwork-change-name-new-24x24.jpg 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-reviews/" class="single_category_title category-link-1786" title="Music Reviews">Music Reviews</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/145982/album-review-the-chicks-gaslighter/" title="Album Review: The Chicks &#8211; &#8220;Gaslighter&#8221;">Album Review: The Chicks &#8211; &#8220;Gaslighter&#8221;</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/brilockhart/" title="Posts by Bri Lockhart" rel="author">Bri Lockhart</a></strong>
		<time class="date published time" datetime="2020-08-07T08:00:00-04:00" itemprop="datePublished" content="2020-08-07T08:00:00-04:00">August 7, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-08-06T21:35:56-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/05214824/dixie-chicks-the-chicks-gaslighter-album-over-artwork-change-name-new.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="1149">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/145982/album-review-the-chicks-gaslighter/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-145845 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-features tag-bby-goyard tag-big-super tag-chris-crack tag-comptonass-tg tag-hip-hop-roundup tag-jiles tag-lil-yachty tag-louie-ray tag-nef-the-pharaoh tag-rmc-mike tag-teeezy tag-yn-jay" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/" rel="bookmark" title="Hip Hop Roundup: Chris Crack, Jiles, RMC Mike and more">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1-80x75.jpg 80w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1-24x24.jpg 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/" title="Hip Hop Roundup: Chris Crack, Jiles, RMC Mike and more">Hip Hop Roundup: Chris Crack, Jiles, RMC Mike and more</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time" datetime="2020-08-07T07:15:00-04:00" itemprop="datePublished" content="2020-08-07T07:15:00-04:00">August 7, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-08-06T19:11:38-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/03143707/Chris-Crack-good-cops-dont-exist-1.jpg">
		  <meta itemprop="width" content="225">
		  <meta itemprop="height" content="225">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-145902 type-post status-publish format-standard has-post-thumbnail hentry category-film category-movie-reviews category-review tag-amy-seimetz tag-horror tag-jane-adams tag-kate-lyn-sheil tag-she-dies-tomorrow tag-vod" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/review/145902/she-dies-tomorrow-review-amy-seimetz-unleashes-pure-existential-dread-in-this-infectious-new-horror/" rel="bookmark" title="She Dies Tomorrow Review: Amy Seimetz Unleashes Pure, Existential Dread in this Infectious New Horror">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/05125541/She-Dies-Tomorrow-2-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="She Dies Tomorrow" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/05125541/She-Dies-Tomorrow-2-80x75.jpg 80w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/05125541/She-Dies-Tomorrow-2-24x24.jpg 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/film/movie-reviews/" class="single_category_title category-link-1780" title="Movie Reviews">Movie Reviews</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/145902/she-dies-tomorrow-review-amy-seimetz-unleashes-pure-existential-dread-in-this-infectious-new-horror/" title="She Dies Tomorrow Review: Amy Seimetz Unleashes Pure, Existential Dread in this Infectious New Horror">She Dies Tomorrow Review: Amy Seimetz Unleashes Pure, Existential Dread in this Infectious New Horror</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/jnegroni/" title="Posts by Jon Negroni" rel="author">Jon Negroni</a></strong>
		<time class="date published time" datetime="2020-08-06T15:58:06-04:00" itemprop="datePublished" content="2020-08-06T15:58:06-04:00">August 6, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-08-06T15:58:08-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/05125541/She-Dies-Tomorrow-2.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="676">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/145902/she-dies-tomorrow-review-amy-seimetz-unleashes-pure-existential-dread-in-this-infectious-new-horror/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-145927 type-post status-publish format-standard has-post-thumbnail hentry category-interviews category-music category-music-features tag-stay-over" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/music/145927/music-interview-stay-over-lets-you-know-youre-not-alone/" rel="bookmark" title="Music Interview: Stay Over  lets you know you&#8217;re not alone">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/05182253/Stay-Over-2-credit-Anthony-Campusano-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/05182253/Stay-Over-2-credit-Anthony-Campusano-80x75.jpg 80w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/05182253/Stay-Over-2-credit-Anthony-Campusano-24x24.jpg 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/145927/music-interview-stay-over-lets-you-know-youre-not-alone/" title="Music Interview: Stay Over  lets you know you&#8217;re not alone">Music Interview: Stay Over  lets you know you&#8217;re not alone</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/abulayo/" title="Posts by Ashley Bulayo" rel="author">Ashley Bulayo</a></strong>
		<time class="date published time" datetime="2020-08-06T10:09:14-04:00" itemprop="datePublished" content="2020-08-06T10:09:14-04:00">August 6, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-08-06T10:09:16-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/05182253/Stay-Over-2-credit-Anthony-Campusano-scaled.jpg">
		  <meta itemprop="width" content="2560">
		  <meta itemprop="height" content="1707">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/145927/music-interview-stay-over-lets-you-know-youre-not-alone/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-145536 type-post status-publish format-standard has-post-thumbnail hentry category-book-reviews category-books category-review tag-kaylynn-flanders tag-shielded tag-ya tag-ya-fantasy" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/review/145536/shielded-kaylynn-flanders/" rel="bookmark" title="Book Review: Shielded by KayLynn Flanders">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/24210847/42281684-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/24210847/42281684-80x75.jpg 80w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/24210847/42281684-24x24.jpg 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/books/book-reviews/" class="single_category_title category-link-1781" title="Book Reviews">Book Reviews</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/145536/shielded-kaylynn-flanders/" title="Book Review: Shielded by KayLynn Flanders">Book Review: Shielded by KayLynn Flanders</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/bphilip/" title="Posts by Isabelle Philip" rel="author">Isabelle Philip</a></strong>
		<time class="date published time" datetime="2020-08-06T08:00:00-04:00" itemprop="datePublished" content="2020-08-06T08:00:00-04:00">August 6, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-08-05T12:50:58-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/24210847/42281684.jpg">
		  <meta itemprop="width" content="1650">
		  <meta itemprop="height" content="2475">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/145536/shielded-kaylynn-flanders/">
							</aside>
				</div>
</li></ul></div><div id="thb_singlead_widget-4" class="widget cf widget_singlead"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div id="thb_topreviews_widget-2" class="widget cf widget_topreviews"><strong>Top Reviews</strong><article itemscope itemtype="http://schema.org/Article" class="post post-overlay photo-listing post-117977 type-post status-publish format-standard has-post-thumbnail hentry category-book-reviews category-books category-featured category-review tag-amie-kaufman tag-featured tag-gemina tag-illuminae tag-jay-kristoff tag-obsidio" role="article" style="background-image: url(https://cdn1.theyoungfolks.com/wp-content/uploads/2018/03/13002734/9781925266726-280x150.jpg);">
	<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/117977/review-obsidio-by-amie-kaufman-and-jay-kristoff/" rel="bookmark" title="Review: OBSIDIO by Amie Kaufman and Jay Kristoff">
					<figure class="circle_rating small">
			<span>10/10</span>
			<svg width="50" height="50" viewBox="0 0 50 50" version="1.1" xmlns="http://www.w3.org/2000/svg">
			  <circle class="circle_base" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="0"></circle>
			 	<circle class="circle_perc" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="144.44" data-dashoffset="0"></circle>
			</svg>
		</figure>
				</a>
		<header class="post-title entry-header">
			<h5 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/117977/review-obsidio-by-amie-kaufman-and-jay-kristoff/" title="Review: OBSIDIO by Amie Kaufman and Jay Kristoff">Review: OBSIDIO by Amie Kaufman and Jay Kristoff</a></h5>				<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/yhspatriot1014/" title="Posts by Lauren Wengrovitz" rel="author">Lauren Wengrovitz</a></strong>
		<time class="date published time" datetime="2018-03-13T08:00:25-04:00" itemprop="datePublished" content="2018-03-13T08:00:25-04:00">March 13, 2018</time>
		<meta itemprop="dateModified" class="date updated" content="2018-03-13T16:02:26-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2018/03/13002734/9781925266726.jpg">
		  <meta itemprop="width" content="1827">
		  <meta itemprop="height" content="2765">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/117977/review-obsidio-by-amie-kaufman-and-jay-kristoff/">
							</aside>
			</header>
	</figure>
</article><ul class="style2">               			<li>
               				<a href="https://www.theyoungfolks.com/review/138678/queen-of-nothing-holly-black/" title="Book Review: The Queen of Nothing by Holly Black">Book Review: The Queen of Nothing by Holly Black <span>10</span></a>
               			</li>
               		               			<li>
               				<a href="https://www.theyoungfolks.com/television/107270/wynonna-earp-2x08-review-no-future-in-the-past/" title="Wynonna Earp 2&#215;08 Review: &#8220;No Future in the Past&#8221;">Wynonna Earp 2&#215;08 Review: &#8220;No Future in the Past&#8221; <span>10</span></a>
               			</li>
               		               			<li>
               				<a href="https://www.theyoungfolks.com/review/123648/review-the-darkest-legacy-by-alexandra-bracken/" title="Review: The Darkest Legacy by Alexandra Bracken">Review: The Darkest Legacy by Alexandra Bracken <span>10</span></a>
               			</li>
               		               			<li>
               				<a href="https://www.theyoungfolks.com/review/126456/burning-movie-review/" title="Burning Movie Review: Lee Chang-dong&#8217;s Newest Masterpiece is Haunting and Magnificent">Burning Movie Review: Lee Chang-dong&#8217;s Newest Masterpiece is Haunting and Magnificent <span>10</span></a>
               			</li>
               		</ul></div><div id="thb_singlead_widget-7" class="widget cf widget_singlead"><iframe src="https://player.twitch.tv/?channel=gamingfrogtv" muted="true" autoplay="true" frameborder="0" allowfullscreen="false" scrolling="no" height="250" width="300"></iframe><a href="//www.twitch.tv/gamingfrogtv?tt_content=text_link&tt_medium=live_embed" target="_blank" style="padding:2px 0px 4px; display:block; width:300px; font-weight:normal; font-size:10px; text-decoration:underline;">Watch live video from GamingFrogTV on www.twitch.tv</a></div><div id="thb_viewedimages_widget-2" class="widget cf widget_viewedimages"><strong>Most Viewed<span class="thb_listing" data-type="views" data-count="10"><a href="#" data-time="7" class="active">WEEK</a><a href="#" data-time="30">MONTH</a><a href="#" data-time="365">ALL</a></span></strong><ul><li itemscope itemtype="http://schema.org/Article" class="post listing post-145759 type-post status-publish format-standard has-post-thumbnail hentry category-review category-television category-tv-reviews tag-bob-morley tag-chuku-modu tag-eliza-taylor tag-tasya-teles tag-the-100 tag-the-cw" role="article">
		<figure class="post-gallery">
					<span class="counts">1</span>
				<a href="https://www.theyoungfolks.com/review/145759/the-100-7x10-review-a-little-sacrifice/" rel="bookmark" title="The 100 7&#215;10 Review: A Little Sacrifice">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/03124209/HUN709B_0237r-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/03124209/HUN709B_0237r-80x75.jpg 80w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/03124209/HUN709B_0237r-24x24.jpg 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/television/tv-reviews/" class="single_category_title category-link-1793" title="TV Reviews">TV Reviews</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/145759/the-100-7x10-review-a-little-sacrifice/" title="The 100 7&#215;10 Review: A Little Sacrifice">The 100 7&#215;10 Review: A Little Sacrifice</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/areimer/" title="Posts by Amanda Reimer" rel="author">Amanda Reimer</a></strong>
		<time class="date published time hide" datetime="2020-08-05T21:01:25-04:00" itemprop="datePublished" content="2020-08-05T21:01:25-04:00">August 5, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-08-05T21:01:26-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/03124209/HUN709B_0237r.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="801">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/145759/the-100-7x10-review-a-little-sacrifice/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-79401 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-music category-music-features tag-christopher-jackson tag-daveed-diggs tag-featured tag-hamilton tag-jonathan-groff tag-leslie-odom-jr tag-lin-manuel-miranda tag-phillipa-soo tag-rankings tag-renee-elise-goldsberry" role="article">
		<figure class="post-gallery">
					<span class="counts">2</span>
				<a href="https://www.theyoungfolks.com/music/79401/every-song-from-the-hamilton-cast-album-ranked/" rel="bookmark" title="Every Song from the &#8216;Hamilton&#8217; Cast Album, Ranked">
			<img width="80" height="42" data-original="https://www.theyoungfolks.com/wp-content/uploads/2016/05/alexander-hamilton.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-original-set="https://www.theyoungfolks.com/wp-content/uploads/2016/05/alexander-hamilton.jpg 540w, https://www.theyoungfolks.com/wp-content/uploads/2016/05/alexander-hamilton-300x157.jpg 300w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/79401/every-song-from-the-hamilton-cast-album-ranked/" title="Every Song from the &#8216;Hamilton&#8217; Cast Album, Ranked">Every Song from the &#8216;Hamilton&#8217; Cast Album, Ranked</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/mrice/" title="Posts by Melody Danielle Rice" rel="author">Melody Danielle Rice</a></strong>
		<time class="date published time hide" datetime="2016-06-14T09:00:47-04:00" itemprop="datePublished" content="2016-06-14T09:00:47-04:00">June 14, 2016</time>
		<meta itemprop="dateModified" class="date updated" content="2017-03-01T12:42:51-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2016/05/alexander-hamilton.jpg">
		  <meta itemprop="width" content="540">
		  <meta itemprop="height" content="283">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/79401/every-song-from-the-hamilton-cast-album-ranked/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-116203 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-special category-television category-top-10-2 category-tv-features tag-best-of tag-double-dare tag-featured tag-figure-it-out tag-finders-keepers tag-game-shows tag-get-the-picture tag-guts tag-legends-of-the-hidden-temple tag-marc-summers tag-nick-arcade tag-nickelodeon tag-slime-time-live tag-top-lists tag-tv tag-what-would-you-do tag-wild-crazy-kids" role="article">
		<figure class="post-gallery">
					<span class="counts">3</span>
				<a href="https://www.theyoungfolks.com/television/116203/the-10-best-nickelodeon-game-shows/" rel="bookmark" title="The 10 Best Nickelodeon Game Shows">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2018/02/02153923/DoubleDare_02b-80x75.jpeg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/top-10-2/" class="single_category_title category-link-259" title="Top Lists">Top Lists</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/television/116203/the-10-best-nickelodeon-game-shows/" title="The 10 Best Nickelodeon Game Shows">The 10 Best Nickelodeon Game Shows</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/tchristian/" title="Posts by Tyler Christian" rel="author">Tyler Christian</a></strong>
		<time class="date published time hide" datetime="2018-02-05T10:00:27-05:00" itemprop="datePublished" content="2018-02-05T10:00:27-05:00">February 5, 2018</time>
		<meta itemprop="dateModified" class="date updated" content="2018-02-05T12:26:40-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2018/02/02153923/DoubleDare_02b.jpeg">
		  <meta itemprop="width" content="1140">
		  <meta itemprop="height" content="873">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/television/116203/the-10-best-nickelodeon-game-shows/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-134278 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-music category-music-features tag-american-pie tag-bic-runga tag-blink-182 tag-dishwalla tag-semisonic tag-shades-apart tag-super-transatlantic tag-the-atomic-fireballs tag-third-eye-blind tag-tonic" role="article">
		<figure class="post-gallery">
					<span class="counts">4</span>
				<a href="https://www.theyoungfolks.com/music/134278/every-song-from-the-american-pie-soundtrack-ranked/" rel="bookmark" title="Every Song from the ‘American Pie’ Soundtrack, Ranked">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2019/07/03160734/American-Pie-Soundtrack-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/134278/every-song-from-the-american-pie-soundtrack-ranked/" title="Every Song from the ‘American Pie’ Soundtrack, Ranked">Every Song from the ‘American Pie’ Soundtrack, Ranked</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/bthompson/" title="Posts by Brian Thompson" rel="author">Brian Thompson</a></strong>
		<time class="date published time hide" datetime="2019-07-09T07:00:01-04:00" itemprop="datePublished" content="2019-07-09T07:00:01-04:00">July 9, 2019</time>
		<meta itemprop="dateModified" class="date updated" content="2019-07-04T18:49:17-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2019/07/03160734/American-Pie-Soundtrack.jpg">
		  <meta itemprop="width" content="340">
		  <meta itemprop="height" content="355">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/134278/every-song-from-the-american-pie-soundtrack-ranked/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-86828 type-post status-publish format-standard has-post-thumbnail hentry category-film category-movie-reviews category-review tag-a-family-affair tag-featured tag-marianna-fassaert tag-tom-fassaert" role="article">
		<figure class="post-gallery">
					<span class="counts">5</span>
				<a href="https://www.theyoungfolks.com/review/86828/movie-review-a-family-affair/" rel="bookmark" title="Movie Review: A Family Affair">
			<img width="80" height="52" data-original="https://www.theyoungfolks.com/wp-content/uploads/2016/09/MV5BNDVmNTczZGQtYjkzNC00OWY2LWE3ODctNzI1OTQ5MTQzZDZhXkEyXkFqcGdeQXVyMjUzOTk4MTg@._V1_SX706_CR00706999_AL_-620x400.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-original-set="https://www.theyoungfolks.com/wp-content/uploads/2016/09/MV5BNDVmNTczZGQtYjkzNC00OWY2LWE3ODctNzI1OTQ5MTQzZDZhXkEyXkFqcGdeQXVyMjUzOTk4MTg@._V1_SX706_CR00706999_AL_-620x400.jpg 620w, https://www.theyoungfolks.com/wp-content/uploads/2016/09/MV5BNDVmNTczZGQtYjkzNC00OWY2LWE3ODctNzI1OTQ5MTQzZDZhXkEyXkFqcGdeQXVyMjUzOTk4MTg@._V1_SX706_CR00706999_AL_-300x194.jpg 300w, https://www.theyoungfolks.com/wp-content/uploads/2016/09/MV5BNDVmNTczZGQtYjkzNC00OWY2LWE3ODctNzI1OTQ5MTQzZDZhXkEyXkFqcGdeQXVyMjUzOTk4MTg@._V1_SX706_CR00706999_AL_-85x54.jpg 85w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/film/" class="single_category_title category-link-3" title="Film">Film</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/86828/movie-review-a-family-affair/" title="Movie Review: A Family Affair">Movie Review: A Family Affair</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/nhood/" title="Posts by Nathanael Hood" rel="author">Nathanael Hood</a></strong>
		<time class="date published time hide" datetime="2016-09-16T22:24:54-04:00" itemprop="datePublished" content="2016-09-16T22:24:54-04:00">September 16, 2016</time>
		<meta itemprop="dateModified" class="date updated" content="2016-09-16T22:24:54-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2016/09/MV5BNDVmNTczZGQtYjkzNC00OWY2LWE3ODctNzI1OTQ5MTQzZDZhXkEyXkFqcGdeQXVyMjUzOTk4MTg@._V1_SX706_CR00706999_AL_.jpg">
		  <meta itemprop="width" content="706">
		  <meta itemprop="height" content="999">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/86828/movie-review-a-family-affair/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-87680 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-music category-music-features category-top-10-2 tag-david-bowie tag-featured tag-nirvana tag-pink-floyd tag-queen tag-rod-stewart tag-the-beatles tag-the-clash tag-the-cure tag-the-rolling-stones tag-u2" role="article">
		<figure class="post-gallery">
					<span class="counts">6</span>
				<a href="https://www.theyoungfolks.com/music/87680/10-classic-rock-songs-you-can-play-on-the-ukulele/" rel="bookmark" title="10 Classic Rock Songs You Can Play on the Ukulele">
			<img width="80" height="52" data-original="https://www.theyoungfolks.com/wp-content/uploads/2016/09/image-3-620x400.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-original-set="https://www.theyoungfolks.com/wp-content/uploads/2016/09/image-3-620x400.jpg 620w, https://www.theyoungfolks.com/wp-content/uploads/2016/09/image-3-300x194.jpg 300w, https://www.theyoungfolks.com/wp-content/uploads/2016/09/image-3-85x54.jpg 85w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/featured/" class="single_category_title category-link-12" title="Featured">Featured</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/87680/10-classic-rock-songs-you-can-play-on-the-ukulele/" title="10 Classic Rock Songs You Can Play on the Ukulele">10 Classic Rock Songs You Can Play on the Ukulele</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/bmenjivar/" title="Posts by Brittany Menjivar" rel="author">Brittany Menjivar</a></strong>
		<time class="date published time hide" datetime="2016-09-27T08:30:36-04:00" itemprop="datePublished" content="2016-09-27T08:30:36-04:00">September 27, 2016</time>
		<meta itemprop="dateModified" class="date updated" content="2016-09-27T01:17:33-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2016/09/image-3.jpg">
		  <meta itemprop="width" content="859">
		  <meta itemprop="height" content="804">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/87680/10-classic-rock-songs-you-can-play-on-the-ukulele/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-32887 type-post status-publish format-standard has-post-thumbnail hentry category-editorials category-featured category-special category-television category-tv-features tag-alan-van-sprang tag-cw tag-featured tag-king-henry tag-reign tag-special tag-television tag-the-cw tag-theory tag-tv tag-tv-shows" role="article">
		<figure class="post-gallery">
					<span class="counts">7</span>
				<a href="https://www.theyoungfolks.com/television/32887/reign-theory-king-henrys-madness/" rel="bookmark" title="&#8216;Reign&#8217; Theory: King Henry&#8217;s Madness">
			<img width="80" height="42" data-original="https://www.theyoungfolks.com/wp-content/uploads/2014/05/reign-620x325.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/featured/" class="single_category_title category-link-12" title="Featured">Featured</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/television/32887/reign-theory-king-henrys-madness/" title="&#8216;Reign&#8217; Theory: King Henry&#8217;s Madness">&#8216;Reign&#8217; Theory: King Henry&#8217;s Madness</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/ivannabarrera/" title="Posts by Ivanna Barrera" rel="author">Ivanna Barrera</a></strong>
		<time class="date published time hide" datetime="2014-05-14T00:15:12-04:00" itemprop="datePublished" content="2014-05-14T00:15:12-04:00">May 14, 2014</time>
		<meta itemprop="dateModified" class="date updated" content="2014-05-14T09:27:17-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2014/05/reign.jpg">
		  <meta itemprop="width" content="699">
		  <meta itemprop="height" content="325">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/television/32887/reign-theory-king-henrys-madness/">
							</aside>
				</div>
</li></ul></div><div id="thb_singlead_widget-5" class="widget cf widget_singlead"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>	</div>
</aside></div>
		<div class="row">
		<div class="small-12 columns">
			<!-- Start Related Posts -->
<aside class="related-posts cf hide-on-print">
	<h4 class="related-title">Related News</h4>
	<div class="row">
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-145698 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-features tag-30deep-grimeyy tag-curreny tag-flo-mili tag-gao-the-arsonist tag-harry-fraud tag-hip-hop-roundup tag-shoreline-mafia tag-thouxanbanfauni tag-wiz-khalifa" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/145698/the-hip-hop-roundup-flo-mili-shoreline-mafia-thouxanbanfauni-and-more/" rel="bookmark" title="The Hip Hop Roundup: Flo Mili, Shoreline Mafia, Thouxanbanfauni and more">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/27185701/flo-mili-new-album-1-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/145698/the-hip-hop-roundup-flo-mili-shoreline-mafia-thouxanbanfauni-and-more/" title="The Hip Hop Roundup: Flo Mili, Shoreline Mafia, Thouxanbanfauni and more">The Hip Hop Roundup: Flo Mili, Shoreline Mafia, Thouxanbanfauni and more</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time hide" datetime="2020-07-31T08:11:00-04:00" itemprop="datePublished" content="2020-07-31T08:11:00-04:00">July 31, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-07-30T23:32:35-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/27185701/flo-mili-new-album-1.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="1200">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/145698/the-hip-hop-roundup-flo-mili-shoreline-mafia-thouxanbanfauni-and-more/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-145376 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-reviews tag-baby-smoove tag-chicken-p tag-dj-lucas tag-freshy-da-general tag-hip-hop-roundup tag-joey-bada tag-nocap tag-rich-the-kid tag-shelf-g tag-sme-taxfree" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/145376/the-hip-hop-roundup-nocap-dj-lucas-baby-smoove-and-more/" rel="bookmark" title="The Hip Hop Roundup: NoCap, DJ Lucas, Baby Smoove and more">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/20204141/steel-human-1-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/145376/the-hip-hop-roundup-nocap-dj-lucas-baby-smoove-and-more/" title="The Hip Hop Roundup: NoCap, DJ Lucas, Baby Smoove and more">The Hip Hop Roundup: NoCap, DJ Lucas, Baby Smoove and more</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time hide" datetime="2020-07-23T10:00:04-04:00" itemprop="datePublished" content="2020-07-23T10:00:04-04:00">July 23, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-07-23T10:00:06-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/20204141/steel-human-1.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="1200">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/145376/the-hip-hop-roundup-nocap-dj-lucas-baby-smoove-and-more/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-145068 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-features tag-ean-wire tag-bmf-gangsta tag-chief-keef tag-hip-hop-roundup tag-ill-addicts tag-koncept-jackon tag-neisha-neshae tag-sada-baby tag-unotheactivist" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/145068/the-hip-hop-roundup-unotheactivist-bmf-gangsta-ean-wire-and-more/" rel="bookmark" title="The Hip Hop Roundup: Unotheactivist, BMF Gangsta, $ean Wire and more">
			<img width="225" height="224" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/13110529/unotheactivtst-8-1.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/13110529/unotheactivtst-8-1.jpg 225w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/13110529/unotheactivtst-8-1-150x150.jpg 150w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/13110529/unotheactivtst-8-1-24x24.jpg 24w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/13110529/unotheactivtst-8-1-48x48.jpg 48w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/13110529/unotheactivtst-8-1-96x96.jpg 96w" sizes="(max-width: 225px) 100vw, 225px" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/145068/the-hip-hop-roundup-unotheactivist-bmf-gangsta-ean-wire-and-more/" title="The Hip Hop Roundup: Unotheactivist, BMF Gangsta, $ean Wire and more">The Hip Hop Roundup: Unotheactivist, BMF Gangsta, $ean Wire and more</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time hide" datetime="2020-07-15T14:20:31-04:00" itemprop="datePublished" content="2020-07-15T14:20:31-04:00">July 15, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-07-16T15:16:33-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/13110529/unotheactivtst-8-1.jpg">
		  <meta itemprop="width" content="225">
		  <meta itemprop="height" content="224">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/145068/the-hip-hop-roundup-unotheactivist-bmf-gangsta-ean-wire-and-more/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-144796 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-features tag-9lokknine tag-bktherula tag-hip-hop-roundup tag-nef-the-pharaoh tag-pop-smoke tag-sahbabii" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/144796/hip-hop-roundup-pop-smoke-bktherula-sahbabii-and-more/" rel="bookmark" title="Hip Hop Roundup: Pop Smoke, BKtheRula, SahBabii and more">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/06182215/pop-smoke-aim-for-the-moon-1-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/144796/hip-hop-roundup-pop-smoke-bktherula-sahbabii-and-more/" title="Hip Hop Roundup: Pop Smoke, BKtheRula, SahBabii and more">Hip Hop Roundup: Pop Smoke, BKtheRula, SahBabii and more</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time hide" datetime="2020-07-09T13:37:17-04:00" itemprop="datePublished" content="2020-07-09T13:37:17-04:00">July 9, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-07-09T13:37:19-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/06182215/pop-smoke-aim-for-the-moon-1.jpg">
		  <meta itemprop="width" content="1000">
		  <meta itemprop="height" content="1000">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/144796/hip-hop-roundup-pop-smoke-bktherula-sahbabii-and-more/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-144558 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-features tag-atl-smook tag-dababy tag-denzel-curry tag-drewsthatdude tag-duwap-kaine tag-guapdad-4000 tag-lil-yachty tag-mavi tag-micah tag-roddy-ricch tag-sada-baby tag-the-hip-hop-roundup" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/144558/the-hip-hop-roundup-drewsthatdude-atl-smook-mavi-and-more/" rel="bookmark" title="The Hip Hop Roundup: DrewsThatDude, ATL Smook, Mavi, and more">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/06/29180241/drewsthatdude-1-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/144558/the-hip-hop-roundup-drewsthatdude-atl-smook-mavi-and-more/" title="The Hip Hop Roundup: DrewsThatDude, ATL Smook, Mavi, and more">The Hip Hop Roundup: DrewsThatDude, ATL Smook, Mavi, and more</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time hide" datetime="2020-07-02T09:00:00-04:00" itemprop="datePublished" content="2020-07-02T09:00:00-04:00">July 2, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-07-03T13:49:17-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/06/29180241/drewsthatdude-1.jpg">
		  <meta itemprop="width" content="1000">
		  <meta itemprop="height" content="1000">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/144558/the-hip-hop-roundup-drewsthatdude-atl-smook-mavi-and-more/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-144386 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-features tag-allstar-jr tag-bfb-da-packman tag-bris tag-cash-kidd tag-gang-starr tag-hip-hop-roundup tag-mac-j tag-mike tag-philthy-rich tag-sada-baby tag-yungmanny" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/144386/the-hip-hop-roundup-yungmanny-bris-all-star-jr-and-more/" rel="bookmark" title="The Hip Hop Roundup: YungManny, Bris, All Star JR, and more">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/06/22182305/Yungmanny-confused-2-570x300.png" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/144386/the-hip-hop-roundup-yungmanny-bris-all-star-jr-and-more/" title="The Hip Hop Roundup: YungManny, Bris, All Star JR, and more">The Hip Hop Roundup: YungManny, Bris, All Star JR, and more</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time hide" datetime="2020-06-24T13:11:41-04:00" itemprop="datePublished" content="2020-06-24T13:11:41-04:00">June 24, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-06-24T13:12:17-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/06/22182305/Yungmanny-confused-2.png">
		  <meta itemprop="width" content="996">
		  <meta itemprop="height" content="1000">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/144386/the-hip-hop-roundup-yungmanny-bris-all-star-jr-and-more/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-144214 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-features tag-black-lives-matter tag-drakeo-the-ruler tag-gangsta-boo tag-hip-hop-roundup tag-joogszn tag-kadeem tag-queen-naija tag-run-the-jewels tag-tee-grizzley tag-teejay6x tag-yg" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/144214/the-hip-hop-roundup-protest-songs-and-police-reform/" rel="bookmark" title="The Hip Hop Roundup: Protest Songs and Police Reform">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/06/15193812/rjt-4-1-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/144214/the-hip-hop-roundup-protest-songs-and-police-reform/" title="The Hip Hop Roundup: Protest Songs and Police Reform">The Hip Hop Roundup: Protest Songs and Police Reform</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time hide" datetime="2020-06-18T08:30:00-04:00" itemprop="datePublished" content="2020-06-18T08:30:00-04:00">June 18, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-06-17T23:08:30-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/06/15193812/rjt-4-1.jpg">
		  <meta itemprop="width" content="1920">
		  <meta itemprop="height" content="1080">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/144214/the-hip-hop-roundup-protest-songs-and-police-reform/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-143825 type-post status-publish format-standard has-post-thumbnail hentry category-editorials category-music category-music-features tag-black-lives-matter tag-dj-screw tag-hip-hop-roundup" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/143825/hip-hop-roundup-remembrance-and-reminder/" rel="bookmark" title="Hip Hop Roundup: A Remembrance and a Reminder">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/06/04213943/say-their-names-570x300.png" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/143825/hip-hop-roundup-remembrance-and-reminder/" title="Hip Hop Roundup: A Remembrance and a Reminder">Hip Hop Roundup: A Remembrance and a Reminder</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time hide" datetime="2020-06-04T21:47:05-04:00" itemprop="datePublished" content="2020-06-04T21:47:05-04:00">June 4, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-06-04T21:47:36-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/06/04213943/say-their-names.png">
		  <meta itemprop="width" content="1600">
		  <meta itemprop="height" content="900">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/143825/hip-hop-roundup-remembrance-and-reminder/">
							</aside>
	</article>    </div>
    </div>
</aside>
<!-- End Related Posts -->		</div>
	</div>
		</div>
		</div><!-- End role["main"] -->
			
						<!-- Start Footer -->
			<footer id="footer" role="contentinfo" class="dark ">
			  	<div class="row">
			  						    <div class="small-12 medium-4 large-4 columns">
				    	<div id="custom-twitter-feeds-widget-2" class="widget cf widget_custom-twitter-feeds-widget"><strong>@TheYoungFolks on Twitter</strong><!-- Custom Twitter Feeds by Smash Balloon --><div id="ctf" class="ctf ctf-type-usertimeline  ctf-styles" style="width: 100%;" data-ctfshortcode="{}" data-ctfneeded="0"><div class="ctf-tweets"><div class="ctf-item ctf-author-theyoungfolks ctf-new ctf-retweet" id="1291218326794928128" style=""><div class="ctf-context"><a href="https://twitter.com/intent/user?screen_name=TheYoungFolks" target="_blank" class="ctf-retweet-icon"><i class="fa fa-retweet" aria-hidden="true"></i><span class="ctf-screenreader">Retweet on Twitter</span></a><a href="https://twitter.com/TheYoungFolks" target="_blank" class="ctf-retweet-text" style="">The Young Folks Retweeted</a></div><div class="ctf-author-box"><div class="ctf-author-box-link" style=""><a href="https://twitter.com/bylineamanda" class="ctf-author-avatar" target="_blank" style=""><img src="https://pbs.twimg.com/profile_images/1290359175927623685/TEi_3QVr_normal.jpg" alt="bylineamanda" width="48" height="48"></a><a href="https://twitter.com/bylineamanda" target="_blank" class="ctf-author-name" style="">amandalorian 🪐</a><a href="https://twitter.com/bylineamanda" class="ctf-author-screenname" target="_blank" style="">@bylineamanda</a><span class="ctf-screename-sep">&middot;</span><div class="ctf-tweet-meta"><a href="https://twitter.com/bylineamanda/status/1291178825037107202" class="ctf-tweet-date" target="_blank" style="">6 Aug</a></div></div> <!-- end .ctf-author-box-link --></div><div class="ctf-tweet-content"><p class="ctf-tweet-text" style="">In this week's #The100, Echo applies to be a part of genocide club and sadly is denied. Check out the <br />
@TheYoungFolks review now!<br />
<br />
https://t.co/ePwdJFoWOB</div><div class="ctf-tweet-actions"><a href="https://twitter.com/intent/tweet?in_reply_to=1291178825037107202&related=bylineamanda" class="ctf-reply" target="_blank" style=""><i class="fa fa-reply"></i><span class="ctf-screenreader">Reply on Twitter 1291178825037107202</span></a><a href="https://twitter.com/intent/retweet?tweet_id=1291178825037107202&related=bylineamanda" class="ctf-retweet" target="_blank" style=""><i class="fa fa-retweet"></i><span class="ctf-screenreader">Retweet on Twitter 1291178825037107202</span><span class="ctf-action-count ctf-retweet-count">13</span></a><a href="https://twitter.com/intent/like?tweet_id=1291178825037107202&related=bylineamanda" class="ctf-like" target="_blank" style=""><i class="fa fa-heart"></i><span class="ctf-screenreader">Like on Twitter 1291178825037107202</span><span class="ctf-action-count ctf-favorite-count">52</span></a><a href="https://twitter.com/bylineamanda/status/1291178825037107202" class="ctf-twitterlink" style="" target="_blank">Twitter <span class="ctf-screenreader">1291178825037107202</span></a></div></div><div class="ctf-item ctf-author-theyoungfolks ctf-new ctf-retweet" id="1291218268628422662" style=""><div class="ctf-context"><a href="https://twitter.com/intent/user?screen_name=TheYoungFolks" target="_blank" class="ctf-retweet-icon"><i class="fa fa-retweet" aria-hidden="true"></i><span class="ctf-screenreader">Retweet on Twitter</span></a><a href="https://twitter.com/TheYoungFolks" target="_blank" class="ctf-retweet-text" style="">The Young Folks Retweeted</a></div><div class="ctf-author-box"><div class="ctf-author-box-link" style=""><a href="https://twitter.com/TinkFoYoself" class="ctf-author-avatar" target="_blank" style=""><img src="https://pbs.twimg.com/profile_images/1285180083569938432/rziTyKYM_normal.jpg" alt="TinkFoYoself" width="48" height="48"></a><a href="https://twitter.com/TinkFoYoself" target="_blank" class="ctf-author-name" style="">🦅Moe Maverick Betta🌺</a><a href="https://twitter.com/TinkFoYoself" class="ctf-author-screenname" target="_blank" style="">@TinkFoYoself</a><span class="ctf-screename-sep">&middot;</span><div class="ctf-tweet-meta"><a href="https://twitter.com/TinkFoYoself/status/1291204014353391616" class="ctf-tweet-date" target="_blank" style="">6 Aug</a></div></div> <!-- end .ctf-author-box-link --></div><div class="ctf-tweet-content"><p class="ctf-tweet-text" style="">The 100 7×10 Review: A Little Sacrifice https://t.co/MrJmVibCPw via @theyoungfolks</div><div class="ctf-tweet-actions"><a href="https://twitter.com/intent/tweet?in_reply_to=1291204014353391616&related=TinkFoYoself" class="ctf-reply" target="_blank" style=""><i class="fa fa-reply"></i><span class="ctf-screenreader">Reply on Twitter 1291204014353391616</span></a><a href="https://twitter.com/intent/retweet?tweet_id=1291204014353391616&related=TinkFoYoself" class="ctf-retweet" target="_blank" style=""><i class="fa fa-retweet"></i><span class="ctf-screenreader">Retweet on Twitter 1291204014353391616</span><span class="ctf-action-count ctf-retweet-count">1</span></a><a href="https://twitter.com/intent/like?tweet_id=1291204014353391616&related=TinkFoYoself" class="ctf-like" target="_blank" style=""><i class="fa fa-heart"></i><span class="ctf-screenreader">Like on Twitter 1291204014353391616</span><span class="ctf-action-count ctf-favorite-count">1</span></a><a href="https://twitter.com/TinkFoYoself/status/1291204014353391616" class="ctf-twitterlink" style="" target="_blank">Twitter <span class="ctf-screenreader">1291204014353391616</span></a></div></div><div class="ctf-item ctf-author-theyoungfolks ctf-new ctf-quoted" id="1291169528618131467" style=""><div class="ctf-author-box"><div class="ctf-author-box-link" style=""><a href="https://twitter.com/TheYoungFolks" class="ctf-author-avatar" target="_blank" style=""><img src="https://pbs.twimg.com/profile_images/1283846040630812673/AAzeKen6_normal.png" alt="TheYoungFolks" width="48" height="48"></a><a href="https://twitter.com/TheYoungFolks" target="_blank" class="ctf-author-name" style="">The Young Folks</a><a href="https://twitter.com/TheYoungFolks" class="ctf-author-screenname" target="_blank" style="">@TheYoungFolks</a><span class="ctf-screename-sep">&middot;</span><div class="ctf-tweet-meta"><a href="https://twitter.com/TheYoungFolks/status/1291169528618131467" class="ctf-tweet-date" target="_blank" style="">6 Aug</a></div></div> <!-- end .ctf-author-box-link --></div><div class="ctf-tweet-content"><p class="ctf-tweet-text" style=""> </p><a href="https://twitter.com/TheYoungFolks/status/1291169528618131467" target="_blank" class="ctf-tweet-text-media-wrap"><i style="padding-right: 5px;" class="fa fa-file-video-o ctf-tweet-text-media" aria-hidden="true"></i></a></div><a href="https://twitter.com/DEADLINE/status/1291159947363966976" class="ctf-quoted-tweet" style="" target="_blank"><span class="ctf-quoted-author-name">Deadline Hollywood</span><span class="ctf-quoted-verified"><i class="fa fa-check-circle" aria-hidden="true"></i></span><span class="ctf-quoted-author-screenname">@DEADLINE</span><p class="ctf-quoted-tweet-text" style="">‘Captain Marvel 2’: ‘Candyman”s Nia DaCosta To Direct Sequel https://t.co/4pt9gBjWyW <span class="ctf-quoted-tweet-text-media-wrap"><i style="padding-right: 5px;" class="fa fa-picture-o ctf-tweet-text-media" aria-hidden="true"></i></span></p></a><div class="ctf-tweet-actions"><a href="https://twitter.com/intent/tweet?in_reply_to=1291169528618131467&related=TheYoungFolks" class="ctf-reply" target="_blank" style=""><i class="fa fa-reply"></i><span class="ctf-screenreader">Reply on Twitter 1291169528618131467</span></a><a href="https://twitter.com/intent/retweet?tweet_id=1291169528618131467&related=TheYoungFolks" class="ctf-retweet" target="_blank" style=""><i class="fa fa-retweet"></i><span class="ctf-screenreader">Retweet on Twitter 1291169528618131467</span><span class="ctf-action-count ctf-retweet-count"></span></a><a href="https://twitter.com/intent/like?tweet_id=1291169528618131467&related=TheYoungFolks" class="ctf-like" target="_blank" style=""><i class="fa fa-heart"></i><span class="ctf-screenreader">Like on Twitter 1291169528618131467</span><span class="ctf-action-count ctf-favorite-count">2</span></a><a href="https://twitter.com/TheYoungFolks/status/1291169528618131467" class="ctf-twitterlink" style="" target="_blank">Twitter <span class="ctf-screenreader">1291169528618131467</span></a></div></div></div></div><script type="text/javascript" src="https://www.theyoungfolks.com/wp-content/plugins/custom-twitter-feeds/js/ctf-scripts.js?ver=1.3"></script></div>				    </div>
				    <div class="small-12 medium-4 large-4 columns">
				    	<div id="thb_categoryslider_widget-2" class="widget cf widget_categoryslider"><strong>Latest Reviews</strong><div class="slick text-center" data-columns="1" data-pagination="false" data-navigation="true" data-autoplay="false" data-speed="500"><article itemscope itemtype="http://schema.org/Article" class="post style1 style1-meta post-145902 type-post status-publish format-standard has-post-thumbnail hentry category-film category-movie-reviews category-review tag-amy-seimetz tag-horror tag-jane-adams tag-kate-lyn-sheil tag-she-dies-tomorrow tag-vod" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/145902/she-dies-tomorrow-review-amy-seimetz-unleashes-pure-existential-dread-in-this-infectious-new-horror/" rel="bookmark" title="She Dies Tomorrow Review: Amy Seimetz Unleashes Pure, Existential Dread in this Infectious New Horror">
			<img width="280" height="150" src="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/05125541/She-Dies-Tomorrow-2-280x150.jpg" class="no-lazy-load wp-post-image" alt="She Dies Tomorrow" />					<figure class="circle_rating small">
			<span>9</span>
			<svg width="50" height="50" viewBox="0 0 50 50" version="1.1" xmlns="http://www.w3.org/2000/svg">
			  <circle class="circle_base" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="0"></circle>
			 	<circle class="circle_perc" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="144.44" data-dashoffset="14.444"></circle>
			</svg>
		</figure>
				</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/film/movie-reviews/" class="single_category_title category-link-1780" title="Movie Reviews">Movie Reviews</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/145902/she-dies-tomorrow-review-amy-seimetz-unleashes-pure-existential-dread-in-this-infectious-new-horror/" title="She Dies Tomorrow Review: Amy Seimetz Unleashes Pure, Existential Dread in this Infectious New Horror">She Dies Tomorrow Review: Amy Seimetz Unleashes Pure, Existential Dread in this Infectious New Horror</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/jnegroni/" title="Posts by Jon Negroni" rel="author">Jon Negroni</a></strong>
		<time class="date published time" datetime="2020-08-06T15:58:06-04:00" itemprop="datePublished" content="2020-08-06T15:58:06-04:00">August 6, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-08-06T15:58:08-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/05125541/She-Dies-Tomorrow-2.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="676">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/145902/she-dies-tomorrow-review-amy-seimetz-unleashes-pure-existential-dread-in-this-infectious-new-horror/">
							</aside>
	</article><article itemscope itemtype="http://schema.org/Article" class="post style1 style1-meta post-145536 type-post status-publish format-standard has-post-thumbnail hentry category-book-reviews category-books category-review tag-kaylynn-flanders tag-shielded tag-ya tag-ya-fantasy" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/145536/shielded-kaylynn-flanders/" rel="bookmark" title="Book Review: Shielded by KayLynn Flanders">
			<img width="280" height="150" src="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/24210847/42281684-280x150.jpg" class="no-lazy-load wp-post-image" alt="" />					<figure class="circle_rating small">
			<span>6</span>
			<svg width="50" height="50" viewBox="0 0 50 50" version="1.1" xmlns="http://www.w3.org/2000/svg">
			  <circle class="circle_base" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="0"></circle>
			 	<circle class="circle_perc" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="144.44" data-dashoffset="57.776"></circle>
			</svg>
		</figure>
				</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/books/book-reviews/" class="single_category_title category-link-1781" title="Book Reviews">Book Reviews</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/145536/shielded-kaylynn-flanders/" title="Book Review: Shielded by KayLynn Flanders">Book Review: Shielded by KayLynn Flanders</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/bphilip/" title="Posts by Isabelle Philip" rel="author">Isabelle Philip</a></strong>
		<time class="date published time" datetime="2020-08-06T08:00:00-04:00" itemprop="datePublished" content="2020-08-06T08:00:00-04:00">August 6, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-08-05T12:50:58-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/24210847/42281684.jpg">
		  <meta itemprop="width" content="1650">
		  <meta itemprop="height" content="2475">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/145536/shielded-kaylynn-flanders/">
							</aside>
	</article><article itemscope itemtype="http://schema.org/Article" class="post style1 style1-meta post-145759 type-post status-publish format-standard has-post-thumbnail hentry category-review category-television category-tv-reviews tag-bob-morley tag-chuku-modu tag-eliza-taylor tag-tasya-teles tag-the-100 tag-the-cw" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/145759/the-100-7x10-review-a-little-sacrifice/" rel="bookmark" title="The 100 7&#215;10 Review: A Little Sacrifice">
			<img width="280" height="150" src="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/03124209/HUN709B_0237r-280x150.jpg" class="no-lazy-load wp-post-image" alt="" />					<figure class="circle_rating small">
			<span>7</span>
			<svg width="50" height="50" viewBox="0 0 50 50" version="1.1" xmlns="http://www.w3.org/2000/svg">
			  <circle class="circle_base" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="0"></circle>
			 	<circle class="circle_perc" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="144.44" data-dashoffset="43.332"></circle>
			</svg>
		</figure>
				</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/television/tv-reviews/" class="single_category_title category-link-1793" title="TV Reviews">TV Reviews</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/145759/the-100-7x10-review-a-little-sacrifice/" title="The 100 7&#215;10 Review: A Little Sacrifice">The 100 7&#215;10 Review: A Little Sacrifice</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/areimer/" title="Posts by Amanda Reimer" rel="author">Amanda Reimer</a></strong>
		<time class="date published time" datetime="2020-08-05T21:01:25-04:00" itemprop="datePublished" content="2020-08-05T21:01:25-04:00">August 5, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-08-05T21:01:26-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/03124209/HUN709B_0237r.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="801">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/145759/the-100-7x10-review-a-little-sacrifice/">
							</aside>
	</article></div></div>				    </div>
				    <div class="small-12 medium-4 large-4 columns">
				        <div id="text-17" class="widget cf widget_text"><strong>@TYFofficial on Spotify</strong>			<div class="textwidget"><p><center><iframe src="//open.spotify.com/embed/user/tyfofficial/playlist/6Vz4AfORooxu2z4fpg9kt3" frameborder="0"></iframe><br />
&nbsp;<br />
&nbsp;<br />
<iframe src="//open.spotify.com/embed/user/tyfofficial/playlist/1QbfPr5WqgAEAfRBRD8WR0" frameborder="0"></iframe> </center></p>
</div>
		</div>				    </div>
				    			    </div>
			</footer>
			<!-- End Footer -->
									<!-- Start Sub Footer -->
			<footer id="subfooter" role="contentinfo" class="dark ">
				<div class="row">
					<div class="small-12 columns">
						<div class="subfooter-menu-holder text-center">
															<a href="https://www.theyoungfolks.com/" class="logolink">
									<img src="/wp-content/uploads/2016/07/cropped-tyf-logo-2016.jpg" class="logoimg" alt="The Young Folks"/>
								</a>
														<div class="subfooter-menu"><ul id="menu-footer-menu" class="footer-menu"><li id="menu-item-24378" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-24378"><a href="https://www.theyoungfolks.com/">Home</a></li>
<li id="menu-item-135847" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135847"><a href="https://www.theyoungfolks.com/about-2/">About The Young Folks</a></li>
<li id="menu-item-24380" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24380"><a href="https://www.theyoungfolks.com/write/">Join the TYF Team!</a></li>
<li id="menu-item-63213" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63213"><a href="https://www.theyoungfolks.com/review-policy/general-comment-policy/">TYF Comment Policy</a></li>
</ul></div>	
							<p>Copyright 2017 The Young Folks. All Rights Reserved </p>
						</div>
					</div>
				</div>
			</footer>
			<!-- End Sub Footer -->
				</section> <!-- End #content-container -->

</div> <!-- End #wrapper -->
	<a href="#" id="scroll_totop"><i class="fa fa-angle-up"></i></a>
	<div style="display:none">
	<div class="grofile-hash-map-b4c5ab20586ef31507efb1f98297f696">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.theyoungfolks.com\/music\/145845\/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more\/":145845};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/music/145845/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://www.theyoungfolks.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.3.10'></script>
<script type='text/javascript' src='https://platform.twitter.com/widgets.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"theyoungfolks"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"145845 https:\/\/www.theyoungfolks.com\/?p=145845","disqusShortname":"theyoungfolks","disqusTitle":"Hip Hop Roundup: Chris Crack, Jiles, RMC Mike and more","disqusUrl":"https:\/\/www.theyoungfolks.com\/music\/145845\/hip-hop-roundup-chris-crack-jiles-rmc-mike-and-more\/","postId":"145845"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=202032'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.8/modules/wpgroho.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/assets/js/vendor.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var themeajax = {"url":"https:\/\/www.theyoungfolks.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/assets/js/app.min.js?ver=2.1.2'></script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.3.4'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.8/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202032.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.8',blog:'77923915',post:'145845',tz:'-4',srv:'www.theyoungfolks.com'} ]);
	_stq.push([ 'clickTrackerInit', '77923915', '145845' ]);
</script>
</body>
</html>