<!doctype html>
<html lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=1">
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<link rel="pingback" href="https://www.theyoungfolks.com/xmlrpc.php">
	<link rel="icon" href="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/16114115/cropped-TYF-Favicon-2020-rounded-32x32.png" sizes="32x32" />
<link rel="icon" href="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/16114115/cropped-TYF-Favicon-2020-rounded-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/16114115/cropped-TYF-Favicon-2020-rounded-180x180.png" />
<meta name="msapplication-TileImage" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/16114115/cropped-TYF-Favicon-2020-rounded-270x270.png" />
		
	<meta http-equiv="x-dns-prefetch-control" content="on">
	<link rel="dns-prefetch" href="//fonts.googleapis.com" />
	<link rel="dns-prefetch" href="//fonts.gstatic.com" />
	<link rel="dns-prefetch" href="//0.gravatar.com/" />
	<link rel="dns-prefetch" href="//2.gravatar.com/" />
	<link rel="dns-prefetch" href="//1.gravatar.com/" />
	<title>Star Trek: Discovery 3x09 review: &quot;Terra Firma, part 1&quot; | The Young Folks</title>

<!-- All In One SEO Pack 3.7.1[1293,1381] -->
<meta name="description"  content="In the special two-parter of the season, &quot;Terra Firma,&quot; Georgiou must relive the fateful day where her Burnham betrayed her." />

<meta name="keywords"  content="star trek discovery terra firma part 1 review,star trek discovery 309,cbs all access,star trek discovery,star trek,star trek discovery season three,sonequa martin-green,doug jones,anthony rapp,mary wiseman,michael burnham,saru,paul stamets,sylvia tilly,star trek discovery 3x09,terra firma,terra firma part 1,star trek discovery terra firma," />

<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.theyoungfolks.com/#organization","url":"https://www.theyoungfolks.com/","name":"The Young Folks","sameAs":["https://www.facebook.com/theyoungfolks/","https://twitter.com/theyoungfolks","https://www.instagram.com/theyoungfolks/"]},{"@type":"WebSite","@id":"https://www.theyoungfolks.com/#website","url":"https://www.theyoungfolks.com/","name":"The Young Folks","publisher":{"@id":"https://www.theyoungfolks.com/#organization"}},{"@type":"WebPage","@id":"https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/#webpage","url":"https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/","inLanguage":"en-US","name":"‘Star Trek: Discovery’ 3×09 review: ‘Terra Firma, Part 1’","isPartOf":{"@id":"https://www.theyoungfolks.com/#website"},"breadcrumb":{"@id":"https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/#breadcrumblist"},"description":"In the special two-parter of the season, &quot;Terra Firma,&quot; Georgiou must relive the fateful day where her Burnham betrayed her.","image":{"@type":"ImageObject","@id":"https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/#primaryimage","url":"https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT.jpg","width":1200,"height":800,"caption":" Michael Gibson/CBS ©2020 CBS Interactive, Inc. All Rights Reserved."},"primaryImageOfPage":{"@id":"https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/#primaryimage"},"datePublished":"2020-12-12T14:47:03-05:00","dateModified":"2020-12-12T14:47:04-05:00"},{"@type":"Article","@id":"https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/#article","isPartOf":{"@id":"https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/#webpage"},"author":{"@id":"https://www.theyoungfolks.com/author/areimer/#author"},"headline":"‘Star Trek: Discovery’ 3×09 review: ‘Terra Firma, Part 1’","datePublished":"2020-12-12T14:47:03-05:00","dateModified":"2020-12-12T14:47:04-05:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/#webpage"},"publisher":{"@id":"https://www.theyoungfolks.com/#organization"},"articleSection":"Review, Television, TV Reviews, Anthony Rapp, CBS All Access, David Ajala, Doug Jones, Mary Wiseman, Michelle Yeoh, Paul Stamets, Sonequa Martin-Green, Star Trek: Discovery, Wilson Cruz","image":{"@type":"ImageObject","@id":"https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/#primaryimage","url":"https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT.jpg","width":1200,"height":800,"caption":" Michael Gibson/CBS ©2020 CBS Interactive, Inc. All Rights Reserved."}},{"@type":"Person","@id":"https://www.theyoungfolks.com/author/areimer/#author","name":"Amanda Reimer","sameAs":["https://twitter.com/bylineamanda"]},{"@type":"BreadcrumbList","@id":"https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/#breadcrumblist","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.theyoungfolks.com/","url":"https://www.theyoungfolks.com/","name":"The Young Folks: Reviews of Films, Music, TV, Books, and Video Games - Written by young people for young people"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/","url":"https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/","name":"‘Star Trek: Discovery’ 3×09 review: ‘Terra Firma, Part 1’"}}]}]}</script>
<link rel="canonical" href="https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Star Trek: Discovery 3x09 review: &quot;Terra Firma, part 1&quot; | The Young Folks" />
<meta property="og:description" content="In the special two-parter of the season, &quot;Terra Firma,&quot; Georgiou must relive the fateful day where her Burnham betrayed her." />
<meta property="og:url" content="https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/" />
<meta property="og:site_name" content="The Young Folks" />
<meta property="og:image" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT.jpg" />
<meta property="fb:admins" content="156189131064135" />
<meta property="fb:app_id" content="449377471938761" />
<meta property="article:published_time" content="2020-12-12T14:47:03Z" />
<meta property="article:modified_time" content="2020-12-12T14:47:04Z" />
<meta property="article:publisher" content="//www.facebook.com/TheYoungFolks" />
<meta property="og:image:secure_url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@TheYoungFolks" />
<meta name="twitter:creator" content="@bylineamanda" />
<meta name="twitter:domain" content="TheYoungFolks.com" />
<meta name="twitter:title" content="Star Trek: Discovery 3x09 review: &quot;Terra Firma, part 1&quot; | The Young Folks" />
<meta name="twitter:description" content="In the special two-parter of the season, &quot;Terra Firma,&quot; Georgiou must relive the fateful day where her Burnham betrayed her." />
<meta name="twitter:image" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT.jpg" />
			<script type="text/javascript" >
				window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
				ga('create', 'UA-12374332-4', 'auto');
				// Plugins
				
				ga('send', 'pageview');
			</script>
			<script async src="https://www.google-analytics.com/analytics.js"></script>
			<!-- All In One SEO Pack -->
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Young Folks &raquo; Feed" href="https://www.theyoungfolks.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Young Folks &raquo; Comments Feed" href="https://www.theyoungfolks.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Young Folks &raquo; ‘Star Trek: Discovery’ 3×09 review: ‘Terra Firma, Part 1’ Comments Feed" href="https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/feed/" />
						<meta property="og:title" content="‘Star Trek: Discovery’ 3×09 review: ‘Terra Firma, Part 1’" />
			<meta property="og:type" content="article" />
			<meta property="og:description" content="Star Trek: Discovery launches into its special two-parter of the season, &#8220;Terra Firma,&#8221; where Georgiou must relive the fateful day where her Burnham betrayed her. Introduced to this day/me" />
			<meta property="og:image" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT.jpg" />
			<meta property="og:url" content="https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/" />
			<!-- This site uses the Google Analytics by ExactMetrics plugin v6.3.3 - Using Analytics tracking - https://www.exactmetrics.com/ -->
<script type="text/javascript" data-cfasync="false">
    (window.gaDevIds=window.gaDevIds||[]).push("dNDMyYj");
	var em_version         = '6.3.3';
	var em_track_user      = true;
	var em_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-12374332-4';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( em_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

window.ga = __gaTracker;		__gaTracker('create', 'UA-12374332-4', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
		__gaTracker( function() { window.ga = __gaTracker; } );
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + em_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
			window.ga = __gaTracker;		})();
		}
</script>
<!-- / Google Analytics by ExactMetrics -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.theyoungfolks.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.theyoungfolks.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.3' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://www.theyoungfolks.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.3.10' type='text/css' media='all' />
<link rel='stylesheet' id='ctf_styles-css'  href='https://www.theyoungfolks.com/wp-content/plugins/custom-twitter-feeds/css/ctf-styles.css?ver=1.3' type='text/css' media='all' />
<link rel='stylesheet' id='math-captcha-frontend-css'  href='https://www.theyoungfolks.com/wp-content/plugins/wp-math-captcha/css/frontend.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='exactmetrics-popular-posts-style-css'  href='https://www.theyoungfolks.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/css/frontend.min.css?ver=6.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='thb-fa-css'  href='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/assets/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thb-app-css'  href='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/assets/css/app.css?ver=2.1.2' type='text/css' media='all' />
<style id='thb-app-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='style-css'  href='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='thb-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Droid+Serif%3A300%2C400%2C500%2C600%2C700%2C900%7CPoppins%3A300%2C400%2C500%2C600%2C700%2C900&#038;subset=latin%2Clatin-ext&#038;ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.theyoungfolks.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.2.1' type='text/css' media='all' />
<script type='text/javascript' id='exactmetrics-frontend-script-js-extra'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/www.theyoungfolks.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend.min.js?ver=6.3.3' id='exactmetrics-frontend-script-js'></script>
<script type='text/javascript' id='jquery-core-js-extra'>
/* <![CDATA[ */
var ctf = {"ajax_url":"https:\/\/www.theyoungfolks.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js' id='html5-shiv-js'></script>
<![endif]-->
<link rel="https://api.w.org/" href="https://www.theyoungfolks.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.theyoungfolks.com/wp-json/wp/v2/posts/149521" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.theyoungfolks.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.theyoungfolks.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='&#8216;Wolfwalkers&#8217; review: A visually stunning tale' href='https://www.theyoungfolks.com/review/149628/wolfwalkers-review-a-visually-stunning-tale/' />
<link rel='next' title='&#8216;Wild Mountain Thyme&#8217; review: Romance is lost amid inconsistent storytelling' href='https://www.theyoungfolks.com/review/149638/wild-mountain-thyme-review-romance-is-lost-amid-inconsistent-storytelling/' />
<meta name="generator" content="WordPress 5.5.3" />
<link rel='shortlink' href='https://wp.me/p5gXzl-CTD' />
<link rel="alternate" type="application/json+oembed" href="https://www.theyoungfolks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.theyoungfolks.com%2Freview%2F149521%2Fstar-trek-discovery-3x09-review-terra-firma-part-1%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.theyoungfolks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.theyoungfolks.com%2Freview%2F149521%2Fstar-trek-discovery-3x09-review-terra-firma-part-1%2F&#038;format=xml" />
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<link rel="icon" href="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/16114115/cropped-TYF-Favicon-2020-rounded-32x32.png" sizes="32x32" />
<link rel="icon" href="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/16114115/cropped-TYF-Favicon-2020-rounded-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/16114115/cropped-TYF-Favicon-2020-rounded-180x180.png" />
<meta name="msapplication-TileImage" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/16114115/cropped-TYF-Favicon-2020-rounded-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			.post.blog-post .post-title {
    margin-bottom: 40px;
}		</style>
		<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>		<meta name="norton-safeweb-site-verification" content="rwr0f6kx274t8xgjjttouapy0u9kpb0pomx7w4ozxn4715jrqzi8dkb6vugohvgwsixwypfm3vwz9ly9lxpj3q9qj4bw56r88xchfe1u8h7bjn63zodcnkdzo47rjg7w" />
</head>
<body class="post-template-default single single-post postid-149521 single-format-standard lazy-load-on thb_ads_header_mobile_off thb-lightbox-off thb-capitalize-off wpb-js-composer js-comp-ver-6.4.1 vc_responsive" data-themeurl="https://www.theyoungfolks.com/wp-content/themes/goodlife-wp">
<div id="wrapper" class="open">
	
	<!-- Start Mobile Menu -->
			<nav id="mobile-menu">
			<div class="custom_scroll" id="menu-scroll">
				<div>
															  <ul id="menu-mobile-menu" class="mobile-menu"><li id="menu-item-146693" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-146693"><a title="About" href="https://www.theyoungfolks.com/about/"><span><i class="fa fa-plus"></i></span>About</a>
<ul class="sub-menu">
	<li id="menu-item-146694" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-146694"><a href="https://www.theyoungfolks.com/about/">About The Young Folks</a></li>
	<li id="menu-item-98506" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-98506"><a href="https://www.theyoungfolks.com/write/">Join the TYF Team!</a></li>
	<li id="menu-item-98507" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-98507"><a href="https://www.theyoungfolks.com/review-policy/general-comment-policy/">General Comment Policy</a></li>
</ul>
</li>
<li id="menu-item-98510" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98510 menu-item-category-6"><a href="https://www.theyoungfolks.com/books/"><span><i class="fa fa-plus"></i></span>Books</a>
<ul class="sub-menu">
	<li id="menu-item-98513" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98513 menu-item-category-1781"><a href="https://www.theyoungfolks.com/books/book-reviews/">Book Reviews</a></li>
	<li id="menu-item-98512" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98512 menu-item-category-1784"><a href="https://www.theyoungfolks.com/books/book-news/">Book News</a></li>
	<li id="menu-item-98511" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98511 menu-item-category-1785"><a href="https://www.theyoungfolks.com/books/book-features/">Book Features</a></li>
	<li id="menu-item-98514" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98514 menu-item-category-14026"><a href="https://www.theyoungfolks.com/books/comics/">Comics &#038; Graphic Novels</a></li>
</ul>
</li>
<li id="menu-item-98515" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98515 menu-item-category-3"><a href="https://www.theyoungfolks.com/film/"><span><i class="fa fa-plus"></i></span>Film</a>
<ul class="sub-menu">
	<li id="menu-item-98519" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98519 menu-item-category-1780"><a href="https://www.theyoungfolks.com/film/movie-reviews/">Movie Reviews</a></li>
	<li id="menu-item-98518" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98518 menu-item-category-1782"><a href="https://www.theyoungfolks.com/film/movie-news/">Movie News</a></li>
	<li id="menu-item-98517" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98517 menu-item-category-1783"><a href="https://www.theyoungfolks.com/film/movie-features/">Movie Features</a></li>
	<li id="menu-item-98521" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98521 menu-item-category-1450"><a href="https://www.theyoungfolks.com/film/the-film-canon/">The Film Canon</a></li>
</ul>
</li>
<li id="menu-item-98528" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98528 menu-item-category-4"><a href="https://www.theyoungfolks.com/music/"><span><i class="fa fa-plus"></i></span>Music</a>
<ul class="sub-menu">
	<li id="menu-item-98533" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98533 menu-item-category-1786"><a href="https://www.theyoungfolks.com/music/music-reviews/"><span><i class="fa fa-plus"></i></span>Music Reviews</a>
	<ul class="sub-menu">
		<li id="menu-item-98529" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98529 menu-item-category-5"><a href="https://www.theyoungfolks.com/music/concerts/">Concert Reviews</a></li>
	</ul>
</li>
	<li id="menu-item-98532" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98532 menu-item-category-1787"><a href="https://www.theyoungfolks.com/music/music-news/">Music News</a></li>
	<li id="menu-item-98531" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98531 menu-item-category-1788"><a href="https://www.theyoungfolks.com/music/music-features/">Music Features</a></li>
	<li id="menu-item-98530" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98530 menu-item-category-11890"><a href="https://www.theyoungfolks.com/music/from-the-record-crate/">From the Record Crate</a></li>
</ul>
</li>
<li id="menu-item-98534" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-98534 menu-item-category-7"><a href="https://www.theyoungfolks.com/television/"><span><i class="fa fa-plus"></i></span>Television</a>
<ul class="sub-menu">
	<li id="menu-item-98537" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-98537 menu-item-category-1793"><a href="https://www.theyoungfolks.com/television/tv-reviews/">TV Reviews</a></li>
	<li id="menu-item-98536" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98536 menu-item-category-1794"><a href="https://www.theyoungfolks.com/television/tv-news-television/">TV News</a></li>
	<li id="menu-item-98535" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98535 menu-item-category-1795"><a href="https://www.theyoungfolks.com/television/tv-features/">TV Features</a></li>
</ul>
</li>
<li id="menu-item-98541" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98541 menu-item-category-13"><a href="https://www.theyoungfolks.com/video-games/"><span><i class="fa fa-plus"></i></span>Video Games</a>
<ul class="sub-menu">
	<li id="menu-item-98544" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98544 menu-item-category-1797"><a href="https://www.theyoungfolks.com/video-games/video-game-reviews/">Video Game Reviews</a></li>
	<li id="menu-item-98542" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98542 menu-item-category-1798"><a href="https://www.theyoungfolks.com/video-games/gaming-news/">Gaming News</a></li>
	<li id="menu-item-98543" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98543 menu-item-category-1799"><a href="https://www.theyoungfolks.com/video-games/video-game-features/">Video Game Features</a></li>
</ul>
</li>
<li id="menu-item-146715" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-146715 menu-item-category-3836"><a href="https://www.theyoungfolks.com/interviews/">Interviews</a></li>
<li id="menu-item-98538" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98538 menu-item-category-259"><a title="Lists" href="https://www.theyoungfolks.com/top-10-2/">Lists</a></li>
<li id="menu-item-98522" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98522 menu-item-category-1789"><a href="https://www.theyoungfolks.com/giveaways/">Giveaways</a></li>
</ul>															<div class="social-links">
								<a href="https://www.facebook.com/TheYoungFolks" class="facebook icon-1x" target="_blank"><i class="fa fa-facebook"></i></a>
				<a href="https://twitter.com/theyoungfolks" class="twitter icon-1x" target="_blank"><i class="fa fa-twitter"></i></a>
				<a href="https://www.instagram.com/theyoungfolks/" class="instagram icon-1x" target="_blank"><i class="fa fa-instagram"></i></a>
							<a href="https://soundcloud.com/tyfofficial" class="soundcloud icon-1x" target="_blank"><i class="fa fa-soundcloud"></i></a>
				<a href="https://www.youtube.com/c/theyoungfolks" class="youtube icon-1x" target="_blank"><i class="fa fa-youtube"></i></a>
			<a href="https://play.spotify.com/user/tyfofficial" class="spotify icon-1x" target="_blank"><i class="fa fa-spotify"></i></a>
					<a href="https://feeds.feedburner.com/TheYoungFolks" class="rss icon-1x" target="_blank"><i class="fa fa-rss"></i></a>
							</div>
					<div class="menu-footer">
											</div>
				</div>
			</div>
		</nav>
		<!-- End Mobile Menu -->
	
	<!-- Start Content Container -->
	<section id="content-container">
		<!-- Start Content Click Capture -->
		<div class="click-capture"></div>
		<!-- End Content Click Capture -->
		<!-- Start Fixed Header -->
<div class="subheader fixed show-for-large light">
			<div class="row full-width-row">
			<div class="medium-8 columns logo">
				<div>
										<a href="https://www.theyoungfolks.com/" class="logolink">
						<img src="/wp-content/uploads/2017/02/2017-logo-21.png" class="logoimg" alt="The Young Folks"/>
					</a>
					<span class="page-title" id="page-title">‘Star Trek: Discovery’ 3×09 review: ‘Terra Firma, Part 1’</span>
				</div>
			</div>
			<div class="medium-4 columns">
				 		<aside class="share-article-vertical hide-on-print ">
		<h6>0<span>Shares</span></h6>

				<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.theyoungfolks.com%2Freview%2F149521%2Fstar-trek-discovery-3x09-review-terra-firma-part-1%2F" class="facebook social"><i class="fa fa-facebook"></i><span>0</span></a>
						<a href="https://twitter.com/intent/tweet?text=%E2%80%98Star+Trek%3A+Discovery%E2%80%99+3%C3%9709+review%3A+%E2%80%98Terra+Firma%2C+Part+1%E2%80%99&url=https%3A%2F%2Fwww.theyoungfolks.com%2Freview%2F149521%2Fstar-trek-discovery-3x09-review-terra-firma-part-1%2F&via=theyoungfolks" class="twitter social "><i class="fa fa-twitter"></i><span>0</span></a>
								<a href="http://pinterest.com/pin/create/link/?url=https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/&media=https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT.jpg&description=%E2%80%98Star+Trek%3A+Discovery%E2%80%99+3%C3%9709+review%3A+%E2%80%98Terra+Firma%2C+Part+1%E2%80%99" class="pinterest social" nopin="nopin" data-pin-no-hover="true"><i class="fa fa-pinterest"></i><span>0</span></a>
						<a href="https://www.linkedin.com/cws/share?url=https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/" class="linkedin social"><i class="fa fa-linkedin"></i><span>0</span></a>
						<a href="whatsapp://send?text=%E2%80%98Star+Trek%3A+Discovery%E2%80%99+3%C3%9709+review%3A+%E2%80%98Terra+Firma%2C+Part+1%E2%80%99" class="whatsapp social" data-href="https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/" data-action="share/whatsapp/share"><i class="fa fa-whatsapp"></i><span><i class="fa fa-whatsapp"></i></span></a>
			</aside>
				</div>
							<span class="progress"></span>
					</div>
		
	</div>
<!-- End Fixed Header -->
<!-- Start Sub Header -->
<div class="subheader show-for-large light ">
	<div class="row full-width-row">
		<div class="small-12 medium-6 large-7 columns">
			<nav class="subheader-menu">
				<ul id="menu-home" class="sf-menu"><li id="menu-item-12558" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-12558"><a href="https://www.theyoungfolks.com/">Home</a></li>
<li id="menu-item-146692" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-146692"><a href="https://www.theyoungfolks.com/about/">About The Young Folks</a></li>
<li id="menu-item-12562" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12562"><a href="https://www.theyoungfolks.com/write/">Write for The Young Folks</a></li>
<li id="menu-item-12561" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12561"><a href="https://www.theyoungfolks.com/review-policy/">Advertising &#038; Promotions</a></li>
<li id="menu-item-63212" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63212"><a href="https://www.theyoungfolks.com/review-policy/general-comment-policy/">TYF Comment Policy</a></li>
</ul>			</nav>
		</div>
		<div class="small-12 medium-6 large-5 columns text-right">
			<ul class="sf-menu right-menu">
					<li class="menu-item-has-children">
		<a href="#">Follow Us</a>
		<ul class="sub-menu">
						<li><a href="https://www.facebook.com/TheYoungFolks" class="facebook icon-1x" target="_blank"><i class="fa fa-facebook"></i> Facebook</a></li>
												<li><a href="https://twitter.com/theyoungfolks" class="twitter icon-1x" target="_blank"><i class="fa fa-twitter"></i> Twitter</a></li>
												<li><a href="https://www.instagram.com/theyoungfolks/" class="instagram icon-1x" target="_blank"><i class="fa fa-instagram"></i> Instagram</a></li>
																					<li><a href="https://soundcloud.com/tyfofficial" class="soundcloud icon-1x" target="_blank"><i class="fa fa-soundcloud"></i> Soundcloud</a></li>
												<li><a href="https://www.youtube.com/c/theyoungfolks" class="youtube icon-1x" target="_blank"><i class="fa fa-youtube"></i> Youtube</a></li>
									<li><a href="https://play.spotify.com/user/tyfofficial" class="spotify icon-1x" target="_blank"><i class="fa fa-spotify"></i> Spotify</a></li>
															<li><a href="https://feeds.feedburner.com/TheYoungFolks" class="rss icon-1x" target="_blank"><i class="fa fa-rss"></i> RSS</a></li>
									<li><a href="https://www.twitch.tv/tyfofficial" class="twitch icon-1x" target="_blank"><i class="fa fa-twitch"></i> Twitch.tv</a></li>
					</ul>
	</li>
									<li>	<div class="quick_search">
		<a href="#" class="quick_toggle"></a>
		<svg version="1.1" class="quick_search_icon" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="20px" height="20px" viewBox="0 -1 20 18" xml:space="preserve">
			<path d="M18.96,16.896l-4.973-4.926c1.02-1.255,1.633-2.846,1.633-4.578c0-4.035-3.312-7.317-7.385-7.317S0.849,3.358,0.849,7.393
				c0,4.033,3.313,7.316,7.386,7.316c1.66,0,3.188-0.552,4.422-1.471l4.998,4.95c0.181,0.179,0.416,0.268,0.652,0.268
				c0.235,0,0.472-0.089,0.652-0.268C19.32,17.832,19.32,17.253,18.96,16.896z M2.693,7.393c0-3.027,2.485-5.489,5.542-5.489
				c3.054,0,5.541,2.462,5.541,5.489c0,3.026-2.486,5.489-5.541,5.489C5.179,12.882,2.693,10.419,2.693,7.393z"/>
		</svg>
		<!-- Start SearchForm -->
<form method="get" class="searchform" role="search" action="https://www.theyoungfolks.com/">
    <fieldset>
    	<input name="s" type="text" placeholder="Search" class="s">
    	<input type="submit" value="Search">
    </fieldset>
</form>
<!-- End SearchForm -->	</div>
	
</li>			</ul>
		</div>
	</div>
</div>
<!-- End Sub Header -->
<!-- Start Header -->
<header class="header style3  light" role="banner">
	<div class="row">
		<div class="small-2 columns text-left mobile-icon-holder">
			<a href="#" data-target="open-menu" class="mobile-toggle"><i class="fa fa-bars"></i></a>
		</div>
		<div class="small-8 large-12 columns logo">
			<div id="menu_width">
								<a href="https://www.theyoungfolks.com/" class="logolink">
					<img src="/wp-content/uploads/2017/02/2017-logo-21.png" class="logoimg" alt="The Young Folks"/>
				</a>
				<nav class="menu-holder">
										  <ul id="menu-main-nav-categories" class="sf-menu style3"><li id="menu-item-12523" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12523 menu-item-category-3"><a title="Movies" href="https://www.theyoungfolks.com/film/">Movies</a>


<ul class="sub-menu ">
	<li id="menu-item-12536" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12536 menu-item-category-1780"><a href="https://www.theyoungfolks.com/film/movie-reviews/">Movie Reviews</a></li>
	<li id="menu-item-12535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12535 menu-item-category-1782"><a href="https://www.theyoungfolks.com/film/movie-news/">Movie News</a></li>
	<li id="menu-item-12534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12534 menu-item-category-1783"><a title="Movie Features" href="https://www.theyoungfolks.com/film/movie-features/">Movie Features</a></li>
	<li id="menu-item-12537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12537 menu-item-category-1450"><a href="https://www.theyoungfolks.com/film/the-film-canon/">The Film Canon</a>
	<ul class="sub-menu ">
		<li id="menu-item-12807" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12807"><a title="TFC Index" href="https://www.theyoungfolks.com/the-film-canon/">TFC Index</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-12522" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12522 menu-item-category-6"><a href="https://www.theyoungfolks.com/books/">Books</a>


<ul class="sub-menu ">
	<li id="menu-item-12532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12532 menu-item-category-1781"><a href="https://www.theyoungfolks.com/books/book-reviews/">Book Reviews</a>
	<ul class="sub-menu ">
		<li id="menu-item-12899" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12899 menu-item-category-1925"><a href="https://www.theyoungfolks.com/books/book-reviews/audiobook-reviews/">Audiobook Reviews</a></li>
	</ul>
</li>
	<li id="menu-item-12530" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12530 menu-item-category-1785"><a href="https://www.theyoungfolks.com/books/book-features/">Book Features</a></li>
	<li id="menu-item-12531" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12531 menu-item-category-1784"><a href="https://www.theyoungfolks.com/books/book-news/">Book News</a></li>
	<li id="menu-item-54742" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54742 menu-item-category-14026"><a href="https://www.theyoungfolks.com/books/comics/">Comics &#038; Graphic Novels</a></li>
</ul>
</li>
<li id="menu-item-12525" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12525 menu-item-category-4"><a href="https://www.theyoungfolks.com/music/">Music</a>


<ul class="sub-menu ">
	<li id="menu-item-12545" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12545 menu-item-category-1786"><a href="https://www.theyoungfolks.com/music/music-reviews/">Music Reviews</a></li>
	<li id="menu-item-12542" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12542 menu-item-category-5"><a href="https://www.theyoungfolks.com/music/concerts/">Concert Reviews</a></li>
	<li id="menu-item-12544" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12544 menu-item-category-1787"><a href="https://www.theyoungfolks.com/music/music-news/">Music News</a></li>
	<li id="menu-item-12543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12543 menu-item-category-1788"><a href="https://www.theyoungfolks.com/music/music-features/">Music Features</a></li>
	<li id="menu-item-43919" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-43919 menu-item-category-11890"><a href="https://www.theyoungfolks.com/music/from-the-record-crate/">From the Record Crate</a>
	<ul class="sub-menu ">
		<li id="menu-item-43920" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43920"><a title="FtRC Index" href="https://www.theyoungfolks.com/from-the-record-crate/">FtRC Index</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-12526" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-12526 menu-item-category-7"><a href="https://www.theyoungfolks.com/television/">Television</a>


<ul class="sub-menu ">
	<li id="menu-item-12548" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12548 menu-item-category-1793"><a href="https://www.theyoungfolks.com/television/tv-reviews/">TV Reviews</a></li>
	<li id="menu-item-12547" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12547 menu-item-category-1794"><a href="https://www.theyoungfolks.com/television/tv-news-television/">TV News</a></li>
	<li id="menu-item-12546" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12546 menu-item-category-1795"><a href="https://www.theyoungfolks.com/television/tv-features/">TV Features</a></li>
</ul>
</li>
<li id="menu-item-12529" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12529 menu-item-category-13"><a href="https://www.theyoungfolks.com/video-games/">Video Games</a>


<ul class="sub-menu ">
	<li id="menu-item-12554" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12554 menu-item-category-1797"><a href="https://www.theyoungfolks.com/video-games/video-game-reviews/">Video Game Reviews</a></li>
	<li id="menu-item-12552" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12552 menu-item-category-1798"><a href="https://www.theyoungfolks.com/video-games/gaming-news/">Gaming News</a></li>
	<li id="menu-item-12553" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12553 menu-item-category-1799"><a href="https://www.theyoungfolks.com/video-games/video-game-features/">Video Game Features</a></li>
</ul>
</li>
<li id="menu-item-146714" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-146714 menu-item-category-3836"><a href="https://www.theyoungfolks.com/interviews/">Interviews</a></li>
<li id="menu-item-12527" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12527 menu-item-category-259"><a title="Lists" href="https://www.theyoungfolks.com/top-10-2/">Lists</a></li>
<li id="menu-item-12549" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12549 menu-item-category-1796"><a href="https://www.theyoungfolks.com/tyf-column/editorials/">More</a>


<ul class="sub-menu ">
	<li id="menu-item-146712" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-146712 menu-item-category-1796"><a href="https://www.theyoungfolks.com/tyf-column/editorials/">Editorials</a></li>
	<li id="menu-item-24973" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24973 menu-item-category-6411"><a href="https://www.theyoungfolks.com/tyf-media/tyf-vlog/">Videos</a></li>
	<li id="menu-item-146713" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-146713 menu-item-category-1789"><a href="https://www.theyoungfolks.com/giveaways/">Giveaways</a></li>
</ul>
</li>
</ul>																			</nav>
			</div>
		</div>
		<div class="small-2 columns text-right mobile-share-holder">
			<div>
				<div class="quick_search">
		<a href="#" class="quick_toggle"></a>
		<svg version="1.1" class="quick_search_icon" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="20px" height="20px" viewBox="0 -1 20 18" xml:space="preserve">
			<path d="M18.96,16.896l-4.973-4.926c1.02-1.255,1.633-2.846,1.633-4.578c0-4.035-3.312-7.317-7.385-7.317S0.849,3.358,0.849,7.393
				c0,4.033,3.313,7.316,7.386,7.316c1.66,0,3.188-0.552,4.422-1.471l4.998,4.95c0.181,0.179,0.416,0.268,0.652,0.268
				c0.235,0,0.472-0.089,0.652-0.268C19.32,17.832,19.32,17.253,18.96,16.896z M2.693,7.393c0-3.027,2.485-5.489,5.542-5.489
				c3.054,0,5.541,2.462,5.541,5.489c0,3.026-2.486,5.489-5.541,5.489C5.179,12.882,2.693,10.419,2.693,7.393z"/>
		</svg>
		<!-- Start SearchForm -->
<form method="get" class="searchform" role="search" action="https://www.theyoungfolks.com/">
    <fieldset>
    	<input name="s" type="text" placeholder="Search" class="s">
    	<input type="submit" value="Search">
    </fieldset>
</form>
<!-- End SearchForm -->	</div>
	
			</div>
		</div>
	</div>
</header>
<!-- End Header -->		
		<div role="main" class=""><div id="infinite-article" data-infinite="on" class="on">
			<div class="row post-detail-row top-padding">
	<div class="small-12 medium-8 columns">

	  <article itemscope itemtype="http://schema.org/Article" class="post blog-post post-149521 type-post status-publish format-standard has-post-thumbnail hentry category-review category-television category-tv-reviews tag-anthony-rapp tag-cbs-all-access tag-david-ajala tag-doug-jones tag-mary-wiseman tag-michelle-yeoh tag-paul-stamets tag-sonequa-martin-green tag-star-trek-discovery tag-wilson-cruz" id="post-149521" role="article" data-id="149521" data-url="https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/">
	  	<header class="post-title entry-header">
	  		<a href="https://www.theyoungfolks.com/television/tv-reviews/" class="single_category_title category-link-1793" title="TV Reviews">TV Reviews</a>	  		<h1 class="entry-title" itemprop="name headline">‘Star Trek: Discovery’ 3×09 review: ‘Terra Firma, Part 1’</h1>	  			<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/areimer/" title="Posts by Amanda Reimer" rel="author">Amanda Reimer</a></strong>
		<time class="date published time" datetime="2020-12-12T09:47:03-05:00" itemprop="datePublished" content="2020-12-12T09:47:03-05:00">December 12, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-12-12T09:47:04-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="800">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/">
							</aside>
		  	</header>
	  		  	<figure class="post-gallery">
	  		<img width="770" height="513" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT-770x513.jpg" class="attachment-goodlife-post-style1 size-goodlife-post-style1 wp-post-image" alt="Star Trek Discovery 309 Terra Firma Saru Tilly" loading="lazy" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT-770x513.jpg 770w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT-768x512.jpg 768w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT.jpg 1200w" sizes="(max-width: 770px) 100vw, 770px" />	  			  			<figcaption class="featured_image_credit"> Michael Gibson/CBS </figcaption>
	  			  	</figure>
	  		  	<div class="share-container">
		  	 		<aside class="share-article-vertical hide-on-print fixed-me show-for-medium">
		<h6>0<span>Shares</span></h6>

				<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.theyoungfolks.com%2Freview%2F149521%2Fstar-trek-discovery-3x09-review-terra-firma-part-1%2F" class="facebook social"><i class="fa fa-facebook"></i><span>0</span></a>
						<a href="https://twitter.com/intent/tweet?text=%E2%80%98Star+Trek%3A+Discovery%E2%80%99+3%C3%9709+review%3A+%E2%80%98Terra+Firma%2C+Part+1%E2%80%99&url=https%3A%2F%2Fwww.theyoungfolks.com%2Freview%2F149521%2Fstar-trek-discovery-3x09-review-terra-firma-part-1%2F&via=theyoungfolks" class="twitter social "><i class="fa fa-twitter"></i><span>0</span></a>
								<a href="http://pinterest.com/pin/create/link/?url=https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/&media=https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT.jpg&description=%E2%80%98Star+Trek%3A+Discovery%E2%80%99+3%C3%9709+review%3A+%E2%80%98Terra+Firma%2C+Part+1%E2%80%99" class="pinterest social" nopin="nopin" data-pin-no-hover="true"><i class="fa fa-pinterest"></i><span>0</span></a>
						<a href="https://www.linkedin.com/cws/share?url=https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/" class="linkedin social"><i class="fa fa-linkedin"></i><span>0</span></a>
						<a href="whatsapp://send?text=%E2%80%98Star+Trek%3A+Discovery%E2%80%99+3%C3%9709+review%3A+%E2%80%98Terra+Firma%2C+Part+1%E2%80%99" class="whatsapp social" data-href="https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/" data-action="share/whatsapp/share"><i class="fa fa-whatsapp"></i><span><i class="fa fa-whatsapp"></i></span></a>
			</aside>
				  <div class="post-content-container">
					<div class="post-content entry-content cf">
									    	
<p><em>Star Trek: Discovery </em>launches into its special two-parter of the season, &#8220;Terra Firma,&#8221; where Georgiou must relive the fateful day where <em>her </em>Burnham betrayed her. Introduced to this day/memory by a mysterious man, or should I say Q, it&#8217;s clear that there should be some story<em> </em>or lesson<em> </em>Georgiou must learn to keep her life. And Kelpiens! </p>



<figure class="wp-block-image size-large"><img src="https://telltaletv.com/wp-content/uploads/2020/12/116949_D_067_RT.jpg" alt=""/><figcaption>Michael Gibson/CBS ©2020 CBS Interactive, Inc. All Rights Reserved.</figcaption></figure>



<p>&#8220;Terra Prima, Part 1&#8221; takes place in two halves, in two different places &#8212; in our universe and in Georgiou&#8217;s. While Saru and the crew make unsurprising findings regarding the ship trapped in The Burn, the most important being who inhabited it, Georgiou is tasked with traveling to a planet in order to have a very slim chance to live. </p>



<p>The Terran half of the episode is by far the most interesting and strongest part. The emotional beats delivered in this half are bolstered by small moments during Georgious&#8217; (albeit small) goodbye tour. Saru has mostly gotten on with Georgiou, and they have a simple goodbye, overshadowed by Tilly&#8217;s emotional hug, which still takes the Terran back as she manages to pat at Tilly&#8217;s shoulders. </p>



<p>These moments play important parts as Georgiou manages to navigate her Terran home-universe, but what of everything else? </p>



<div class="wp-block-image"><figure class="aligncenter size-large"><img src="https://telltaletv.com/wp-content/uploads/2020/12/116949_D_233_RT.jpg" alt=""/><figcaption>Michael Gibson/CBS ©2020 CBS Interactive, Inc. All Rights Reserved.</figcaption></figure></div>



<p>Adira&#8217;s moments seem restricted to Stamets, which is unfortunate. Finding yourself is no easy task, and while they are clearly connected to Stamets, at this point, their only screentime unrelated to plot development is with him. <em>Discovery </em>is on its third season at this point and integrating into a cast as familiar with each other as this one requires more work. </p>



<p>Adira feels like they&#8217;ve been put into a cage, which is doubly concerning considering the important representation they provide for so many fans who are non-binary. <em>Discovery </em>doesn&#8217;t even utilize the fact that Adira comes from a different time. They could put forth very interesting information that could help the mission. Adira has so much potential that just seems wasted and for no discernable reason. With only four episodes left and one of those possibly set in a different reality, there&#8217;s no time left to squander.</p>



<p>On the opposite end of this, <em>Star Trek </em>has done a much better job introducing Book into the cast in its third season. Beyond the seamless way he fits in with Michael (radiant chemistry included), he&#8217;s had interactions with Saru, Georgiou, and Tilly (even if by way of Grudge). Throwing a cat into the mix is a sure way to provoke interest. From Porthos to Spot, a Trek pet is <em>always </em>a good idea. </p>



<p>Adira is a character that <em>Star Trek </em>needs, and Book is a character immediatiely engaging, even if he doesn&#8217;t exactly fill the gap that Adira fills. Hopefully there&#8217;s a way to bring Book&#8217;s elements to Adira &#8212; it&#8217;s what they <em>both </em>deserve. </p><div class="DSP2QHUm" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>



<div class="wp-block-image"><figure class="aligncenter size-large"><img src="https://telltaletv.com/wp-content/uploads/2020/12/116949_D_119_RT.jpg" alt=""/><figcaption>Michael Gibson/CBS ©2020 CBS Interactive, Inc. All Rights Reserved.</figcaption></figure></div>



<p>And then there&#8217;s the decrypted video message. The people who were trapped in The Burn (yet, their ship still has integrity) are&#8230; Kelpiens. </p>



<p>We love Saru. He&#8217;s one of <em>Discovery&#8217;s </em>best characters, and his journey as he confronted fear is a storyline like no other. In season three, he&#8217;s had a much more subtle way to shine. His stories haven&#8217;t been the A-plot or B-plot for the most part, but have been laced in throughout the entire season. </p>



<p>He&#8217;s hit some speed bumps as he&#8217;s learned to navigate his new role, and his relationship with the new Admiral (please don&#8217;t be evil) has opened his eyes and allowed him to <em>learn. </em>These are the stories that make Saru so interesting, and like some of the other characters fans loved on <em>Star Trek </em>&#8212; Spock, Data, etc. &#8212; he&#8217;s so very <em>human. </em></p>



<p>So, is involving the Kelpiens into the lore plot of the season, really what Saru needs? The choice is easy; it isn&#8217;t unexpected. There are still four episodes left in the season, so maybe it will connect to Saru&#8217;s growth in a satisfying way, but my gut feeling says no. </p><div class="VqsZ5Qtk" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>



<p>What&#8217;s becoming more and more interesting in this season of <em>Discovery</em> mostly speaks to Saru, and drove the U.S.S. Discovery to the future in the first place &#8212; The Sphere Data. This AI, which operates a deus ex machina, is beginning to feel like a character on its own and could potentially be what gives Starfleet the upper hand in providing stability to their galaxy. </p>



<div class="wp-block-image"><figure class="aligncenter size-large"><img src="https://telltaletv.com/wp-content/uploads/2020/12/116950_D_008_RT.jpg" alt=""/><figcaption>Michael Gibson/CBS ©2020 CBS Interactive, Inc. All Rights Reserved.</figcaption></figure></div>



<p>And what is &#8220;Terra Prima&#8221; without the Emporer, herself? </p>



<p>This time on <em>Star Trek: The Mirror Episodes, </em>the anomaly that The Sphere Data detected that could save Georgiou seems to be a Q (it&#8217;s very Q-like) and with a hasty goodbye to Michael, she steps through the door and it&#8217;s back to fascism, baby. </p>



<p>Q-arl introduces Georgiou to undo her biggest regret and save the most important person to her in the process. This is a journey of redemption for Georgiou. Through her knowledge of the past, and her newfound relationships with species and individuals from those species, she&#8217;s able to finally unearth the root of the betrayal. </p><div class="ripxEfut" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>



<p>(As an aside: Terran Michael Burnam is &#8230;. wow. Heart. Eyes.) </p>



<p>The problem with the root of this coup is that they&#8217;re kind of right. </p>



<p>Georgiou is certainly not soft when it comes to Starfleet standards, but if the Terrans around her noticed this before she even had the excuse<em> </em>of her time in the other time changing her, then maybe this is who Georgiou really is. Georgiou has some major soul-searching to do, and thankfully it&#8217;s on the Terran side because these costumes, choreography, and direction are <em>fun.</em></p>



<p>Though, Georgiou&#8217;s side journey isn&#8217;t surprising at all, considering that her spin-off is in the works, and she&#8217;s currently stuck in the 32nd century. <em> </em></p>



<figure class="wp-block-image size-large"><img src="https://telltaletv.com/wp-content/uploads/2020/12/116950_D_109_RT.jpg" alt=""/><figcaption>Michael Gibson/CBS ©2020 CBS Interactive, Inc. All Rights Reserved.</figcaption></figure>



<p>&#8220;Terra Prime, Part 1&#8221; leaves the audience waiting in the heat of the moment. Georgiou herself isn&#8217;t quite predictable and she has a lot of space to cover before her own show hits the air (COVID has this completely up in the air). </p>



<p>Here&#8217;s to hoping for a Lorca cameo in part 2! </p>



<p><strong><em>Star Trek: Discovery airs on CBS All Access on Thursdays. </em></strong></p>
<center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Bottom Post Link Ads -->
<ins class="adsbygoogle"
     style="display: block;height: 100px;overflow: hidden;"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="4109762806"
     data-ad-format="link"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>			    				    	
					</div>
				</div>
			</div>
					<aside class="post-review style3" itemscope itemtype="http://schema.org/Review">
			<div class="post-review-content">
				<h6 itemprop="itemReviewed" itemscope itemtype="http://schema.org/Thing"><span itemprop="name">‘Star Trek: Discovery’ 3×09: ‘Terra Firma, Part 1’</span></h6>				<ul>
									
					<li>
						<div class="row">
							<div class="small-12 medium-9 columns">Review Rating</div>
							<div class="small-12 medium-3 columns show-for-medium">8</div>
						</div>
						<div class="progress">
							<span data-width="80"></span>
						</div>
					</li>
					
		
								</ul>
			</div>
			<div class="post-review-content">
				<div class="row">
					<div class="small-12 medium-9 columns">
						<div class="row">
							<div class="small-12  medium-6 columns comment_section">
								<span class="post_comment">The Good</span>
															</div>
							<div class="small-12  medium-6 columns comment_section">
								<span class="post_comment">The Bad</span>
															</div>
						</div>
					</div>
					<div class="small-12  medium-3 columns">
						<figure class="average" itemprop="reviewRating" itemscope itemtype="http://schema.org/Rating"><span itemprop="ratingValue">8</span><span class="hide" itemprop="bestRating">10</span></figure>
					</div>
				</div>
			</div>
		</aside>
					<footer class="article-tags entry-footer">
			<div>
		<span class="tags-title">Tags</span> 
		<a href="https://www.theyoungfolks.com/tag/anthony-rapp/" title="" class="tag-link">Anthony Rapp</a> <a href="https://www.theyoungfolks.com/tag/cbs-all-access/" title="" class="tag-link">CBS All Access</a> <a href="https://www.theyoungfolks.com/tag/david-ajala/" title="" class="tag-link">David Ajala</a> <a href="https://www.theyoungfolks.com/tag/doug-jones/" title="" class="tag-link">Doug Jones</a> <a href="https://www.theyoungfolks.com/tag/mary-wiseman/" title="" class="tag-link">Mary Wiseman</a> <a href="https://www.theyoungfolks.com/tag/michelle-yeoh/" title="" class="tag-link">Michelle Yeoh</a> <a href="https://www.theyoungfolks.com/tag/paul-stamets/" title="" class="tag-link">Paul Stamets</a> <a href="https://www.theyoungfolks.com/tag/sonequa-martin-green/" title="" class="tag-link">Sonequa Martin-Green</a> <a href="https://www.theyoungfolks.com/tag/star-trek-discovery/" title="" class="tag-link">Star Trek: Discovery</a> <a href="https://www.theyoungfolks.com/tag/wilson-cruz/" title="" class="tag-link">Wilson Cruz</a>	</div>
</footer>
 
<section class="post-author">
		<img width="164" height="164" src="https://cdn1.theyoungfolks.com/wp-content/uploads/2017/02/17155045/32267346_10212144131303920_8620273287496204288_o-300x300.jpg" class="avatar avatar-164 photo" alt="" loading="lazy" srcset="https://cdn1.theyoungfolks.com/wp-content/uploads/2017/02/17155045/32267346_10212144131303920_8620273287496204288_o-300x300.jpg 300w, https://cdn1.theyoungfolks.com/wp-content/uploads/2017/02/17155045/32267346_10212144131303920_8620273287496204288_o-150x150.jpg 150w, https://cdn1.theyoungfolks.com/wp-content/uploads/2017/02/17155045/32267346_10212144131303920_8620273287496204288_o-24x24.jpg 24w, https://cdn1.theyoungfolks.com/wp-content/uploads/2017/02/17155045/32267346_10212144131303920_8620273287496204288_o-48x48.jpg 48w, https://cdn1.theyoungfolks.com/wp-content/uploads/2017/02/17155045/32267346_10212144131303920_8620273287496204288_o-96x96.jpg 96w" sizes="(max-width: 164px) 100vw, 164px" />	<div class="author-content">
		<h5><a href="https://www.theyoungfolks.com/author/areimer/">Amanda Reimer</a></h5>
				<p>Amanda is a 25-year-old Texan now residing in Los Angeles. When she's not entrenched in a sci-fi series or a network procedural, she works as a Stage Manager for live theater throughout the city, making low-budget productions come to life. Having experience in multiple entertainment industries, she's always drawn to television, and has an invested interest in fandom and they way fanbases interact with their media and its creators.</p>
							<a href="https://twitter.com/bylineamanda" class="twitter"><i class="fa fa-twitter"></i></a>
							</div>
	</section>
 		<aside class="share-article hide-on-print ">
		<div class="row">
			<div class="small-12 medium-5 columns">
				<h6>Share This</h6>
			</div>
			<div class="small-12 medium-7 columns small-only-text-center text-right">
				<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.theyoungfolks.com%2Freview%2F149521%2Fstar-trek-discovery-3x09-review-terra-firma-part-1%2F" class="facebook social"><i class="fa fa-facebook"></i><span>0</span></a>
						<a href="https://twitter.com/intent/tweet?text=%E2%80%98Star+Trek%3A+Discovery%E2%80%99+3%C3%9709+review%3A+%E2%80%98Terra+Firma%2C+Part+1%E2%80%99&url=https%3A%2F%2Fwww.theyoungfolks.com%2Freview%2F149521%2Fstar-trek-discovery-3x09-review-terra-firma-part-1%2F&via=theyoungfolks" class="twitter social "><i class="fa fa-twitter"></i><span>0</span></a>
								<a href="http://pinterest.com/pin/create/link/?url=https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/&media=https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT.jpg&description=%E2%80%98Star+Trek%3A+Discovery%E2%80%99+3%C3%9709+review%3A+%E2%80%98Terra+Firma%2C+Part+1%E2%80%99" class="pinterest social" nopin="nopin" data-pin-no-hover="true"><i class="fa fa-pinterest"></i><span>0</span></a>
						<a href="https://www.linkedin.com/cws/share?url=https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/" class="linkedin social"><i class="fa fa-linkedin"></i><span>0</span></a>
						<a href="whatsapp://send?text=%E2%80%98Star+Trek%3A+Discovery%E2%80%99+3%C3%9709+review%3A+%E2%80%98Terra+Firma%2C+Part+1%E2%80%99" class="whatsapp social" data-href="https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/" data-action="share/whatsapp/share"><i class="fa fa-whatsapp"></i></a>
					</div>
	</aside>
	 
			<div class="row post-navi hide-on-print no-padding">
				<div class="small-12 medium-6 columns">
					<span>Previous Article</span><a href="https://www.theyoungfolks.com/review/149628/wolfwalkers-review-a-visually-stunning-tale/" title="'Wolfwalkers' review: A visually stunning tale">'Wolfwalkers' review: A visually stunning tale</a>				</div>
				<div class="small-12 medium-6 columns">
					<span>Next Article</span><a href="https://www.theyoungfolks.com/review/149638/wild-mountain-thyme-review-romance-is-lost-amid-inconsistent-storytelling/" title="'Wild Mountain Thyme' review: Romance is lost amid inconsistent storytelling">'Wild Mountain Thyme' review: Romance is lost amid inconsistent storytelling</a>				</div>
			</div>
			  </article>

					
<div id="disqus_thread"></div>
			</div>
	<aside class="sidebar small-12 medium-4 columns" role="complementary">
	<div class="sidebar_inner fixed-me">
		<div id="thb_singlead_widget-10" class="widget cf widget_singlead"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div id="thb_latestimages_widget-1" class="widget cf widget_latestimages"><strong>Latest Posts</strong><ul><li itemscope itemtype="http://schema.org/Article" class="post listing post-149638 type-post status-publish format-standard has-post-thumbnail hentry category-film category-movie-reviews category-review tag-emily-blunt tag-jamie-dornan tag-john-patrick-shanley tag-jon-hamm tag-wild-mountain-thyme" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/review/149638/wild-mountain-thyme-review-romance-is-lost-amid-inconsistent-storytelling/" rel="bookmark" title="&#8216;Wild Mountain Thyme&#8217; review: Romance is lost amid inconsistent storytelling">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/12095233/Wild-M-T-00852-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/12095233/Wild-M-T-00852-80x75.jpg 80w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/12095233/Wild-M-T-00852-24x24.jpg 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/film/movie-reviews/" class="single_category_title category-link-1780" title="Movie Reviews">Movie Reviews</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/149638/wild-mountain-thyme-review-romance-is-lost-amid-inconsistent-storytelling/" title="&#8216;Wild Mountain Thyme&#8217; review: Romance is lost amid inconsistent storytelling">&#8216;Wild Mountain Thyme&#8217; review: Romance is lost amid inconsistent storytelling</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/mabdulbaki/" title="Posts by Mae Abdulbaki" rel="author">Mae Abdulbaki</a></strong>
		<time class="date published time" datetime="2020-12-12T12:55:03-05:00" itemprop="datePublished" content="2020-12-12T12:55:03-05:00">December 12, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-12-12T13:01:43-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/12095233/Wild-M-T-00852-scaled.jpg">
		  <meta itemprop="width" content="2560">
		  <meta itemprop="height" content="1708">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/149638/wild-mountain-thyme-review-romance-is-lost-amid-inconsistent-storytelling/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-149521 type-post status-publish format-standard has-post-thumbnail hentry category-review category-television category-tv-reviews tag-anthony-rapp tag-cbs-all-access tag-david-ajala tag-doug-jones tag-mary-wiseman tag-michelle-yeoh tag-paul-stamets tag-sonequa-martin-green tag-star-trek-discovery tag-wilson-cruz" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/" rel="bookmark" title="‘Star Trek: Discovery’ 3×09 review: ‘Terra Firma, Part 1’">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Star Trek Discovery 309 Terra Firma Saru Tilly" loading="lazy" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT-80x75.jpg 80w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT-24x24.jpg 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/television/tv-reviews/" class="single_category_title category-link-1793" title="TV Reviews">TV Reviews</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/" title="‘Star Trek: Discovery’ 3×09 review: ‘Terra Firma, Part 1’">‘Star Trek: Discovery’ 3×09 review: ‘Terra Firma, Part 1’</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/areimer/" title="Posts by Amanda Reimer" rel="author">Amanda Reimer</a></strong>
		<time class="date published time" datetime="2020-12-12T09:47:03-05:00" itemprop="datePublished" content="2020-12-12T09:47:03-05:00">December 12, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-12-12T09:47:04-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="800">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-149628 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-film category-movie-reviews category-review tag-featured tag-film-2 tag-movies tag-tomm-moore tag-wolfwalkers" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/review/149628/wolfwalkers-review-a-visually-stunning-tale/" rel="bookmark" title="&#8216;Wolfwalkers&#8217; review: A visually stunning tale">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/09/13172454/wolfwalkers-02-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/09/13172454/wolfwalkers-02-80x75.jpg 80w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/09/13172454/wolfwalkers-02-24x24.jpg 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/film/movie-reviews/" class="single_category_title category-link-1780" title="Movie Reviews">Movie Reviews</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/149628/wolfwalkers-review-a-visually-stunning-tale/" title="&#8216;Wolfwalkers&#8217; review: A visually stunning tale">&#8216;Wolfwalkers&#8217; review: A visually stunning tale</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/johnsona/" title="Posts by Allyson Johnson" rel="author">Allyson Johnson</a></strong>
		<time class="date published time" datetime="2020-12-11T12:32:13-05:00" itemprop="datePublished" content="2020-12-11T12:32:13-05:00">December 11, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-12-11T12:38:07-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/09/13172454/wolfwalkers-02.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="600">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/149628/wolfwalkers-review-a-visually-stunning-tale/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-149626 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-film category-movie-reviews tag-a24 tag-featured tag-film-2 tag-minari tag-movie-review tag-steven-yeun" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/film/149626/minari-review-steven-yeun-balances-family-and-the-american-dream-in-a24s-latest-warmest-drama/" rel="bookmark" title="&#8216;Minari&#8217; review: Steven Yeun balances family and the American Dream in A24’s latest, warmest drama">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/01/29182120/49105867006_7ab4cf7699_5k-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/01/29182120/49105867006_7ab4cf7699_5k-80x75.jpg 80w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/01/29182120/49105867006_7ab4cf7699_5k-670x628.jpg 670w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/01/29182120/49105867006_7ab4cf7699_5k-24x24.jpg 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/film/movie-reviews/" class="single_category_title category-link-1780" title="Movie Reviews">Movie Reviews</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/film/149626/minari-review-steven-yeun-balances-family-and-the-american-dream-in-a24s-latest-warmest-drama/" title="&#8216;Minari&#8217; review: Steven Yeun balances family and the American Dream in A24’s latest, warmest drama">&#8216;Minari&#8217; review: Steven Yeun balances family and the American Dream in A24’s latest, warmest drama</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/jnegroni/" title="Posts by Jon Negroni" rel="author">Jon Negroni</a></strong>
		<time class="date published time" datetime="2020-12-11T12:27:43-05:00" itemprop="datePublished" content="2020-12-11T12:27:43-05:00">December 11, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-12-11T12:27:44-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/01/29182120/49105867006_7ab4cf7699_5k.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="628">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/film/149626/minari-review-steven-yeun-balances-family-and-the-american-dream-in-a24s-latest-warmest-drama/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-149592 type-post status-publish format-standard has-post-thumbnail hentry category-interviews category-music category-music-features tag-fenix-flexin tag-shoreline-mafia" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/music/149592/music-interview-its-time-for-fenix-flexin-to-enter-the-spotlight/" rel="bookmark" title="Music Interview: It&#8217;s Time for Fenix Flexin to Enter the Spotlight">
			<img width="80" height="75" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/10165456/Screen-Shot-2020-12-10-at-4.53.45-PM-80x75.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" data-original-set="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/10165456/Screen-Shot-2020-12-10-at-4.53.45-PM-80x75.png 80w, https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/10165456/Screen-Shot-2020-12-10-at-4.53.45-PM-24x24.png 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/interviews/" class="single_category_title category-link-3836" title="Interviews">Interviews</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/149592/music-interview-its-time-for-fenix-flexin-to-enter-the-spotlight/" title="Music Interview: It&#8217;s Time for Fenix Flexin to Enter the Spotlight">Music Interview: It&#8217;s Time for Fenix Flexin to Enter the Spotlight</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time" datetime="2020-12-11T11:43:01-05:00" itemprop="datePublished" content="2020-12-11T11:43:01-05:00">December 11, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-12-11T11:43:03-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/10165456/Screen-Shot-2020-12-10-at-4.53.45-PM.png">
		  <meta itemprop="width" content="531">
		  <meta itemprop="height" content="527">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/149592/music-interview-its-time-for-fenix-flexin-to-enter-the-spotlight/">
							</aside>
				</div>
</li></ul></div><div id="thb_singlead_widget-4" class="widget cf widget_singlead"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div id="thb_topreviews_widget-2" class="widget cf widget_topreviews"><strong>Top Reviews</strong><article itemscope itemtype="http://schema.org/Article" class="post post-overlay photo-listing post-117977 type-post status-publish format-standard has-post-thumbnail hentry category-book-reviews category-books category-featured category-review tag-amie-kaufman tag-featured tag-gemina tag-illuminae tag-jay-kristoff tag-obsidio" role="article" style="background-image: url(https://cdn1.theyoungfolks.com/wp-content/uploads/2018/03/13002734/9781925266726-280x150.jpg);">
	<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/117977/review-obsidio-by-amie-kaufman-and-jay-kristoff/" rel="bookmark" title="Review: OBSIDIO by Amie Kaufman and Jay Kristoff">
					<figure class="circle_rating small">
			<span>10/10</span>
			<svg width="50" height="50" viewBox="0 0 50 50" version="1.1" xmlns="http://www.w3.org/2000/svg">
			  <circle class="circle_base" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="0"></circle>
			 	<circle class="circle_perc" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="144.44" data-dashoffset="0"></circle>
			</svg>
		</figure>
				</a>
		<header class="post-title entry-header">
			<h5 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/117977/review-obsidio-by-amie-kaufman-and-jay-kristoff/" title="Review: OBSIDIO by Amie Kaufman and Jay Kristoff">Review: OBSIDIO by Amie Kaufman and Jay Kristoff</a></h5>				<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/yhspatriot1014/" title="Posts by Lauren Wengrovitz" rel="author">Lauren Wengrovitz</a></strong>
		<time class="date published time" datetime="2018-03-13T08:00:25-04:00" itemprop="datePublished" content="2018-03-13T08:00:25-04:00">March 13, 2018</time>
		<meta itemprop="dateModified" class="date updated" content="2018-03-13T16:02:26-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2018/03/13002734/9781925266726.jpg">
		  <meta itemprop="width" content="1827">
		  <meta itemprop="height" content="2765">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/117977/review-obsidio-by-amie-kaufman-and-jay-kristoff/">
							</aside>
			</header>
	</figure>
</article><ul class="style2">               			<li>
               				<a href="https://www.theyoungfolks.com/review/138678/queen-of-nothing-holly-black/" title="Book Review: The Queen of Nothing by Holly Black">Book Review: The Queen of Nothing by Holly Black <span>10</span></a>
               			</li>
               		               			<li>
               				<a href="https://www.theyoungfolks.com/television/107270/wynonna-earp-2x08-review-no-future-in-the-past/" title="Wynonna Earp 2&#215;08 Review: &#8220;No Future in the Past&#8221;">Wynonna Earp 2&#215;08 Review: &#8220;No Future in the Past&#8221; <span>10</span></a>
               			</li>
               		               			<li>
               				<a href="https://www.theyoungfolks.com/review/123648/review-the-darkest-legacy-by-alexandra-bracken/" title="Review: The Darkest Legacy by Alexandra Bracken">Review: The Darkest Legacy by Alexandra Bracken <span>10</span></a>
               			</li>
               		               			<li>
               				<a href="https://www.theyoungfolks.com/review/126456/burning-movie-review/" title="Burning Movie Review: Lee Chang-dong&#8217;s Newest Masterpiece is Haunting and Magnificent">Burning Movie Review: Lee Chang-dong&#8217;s Newest Masterpiece is Haunting and Magnificent <span>10</span></a>
               			</li>
               		</ul></div><div id="thb_singlead_widget-7" class="widget cf widget_singlead"><iframe src="https://player.twitch.tv/?channel=gamingfrogtv" muted="true" autoplay="true" frameborder="0" allowfullscreen="false" scrolling="no" height="250" width="300"></iframe><a href="//www.twitch.tv/gamingfrogtv?tt_content=text_link&tt_medium=live_embed" target="_blank" style="padding:2px 0px 4px; display:block; width:300px; font-weight:normal; font-size:10px; text-decoration:underline;">Watch live video from GamingFrogTV on www.twitch.tv</a></div><div id="thb_viewedimages_widget-2" class="widget cf widget_viewedimages"><strong>Most Viewed<span class="thb_listing" data-type="views" data-count="10"><a href="#" data-time="7" class="active">WEEK</a><a href="#" data-time="30">MONTH</a><a href="#" data-time="365">ALL</a></span></strong>No Stats to show</div><div id="thb_singlead_widget-5" class="widget cf widget_singlead"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>	</div>
</aside></div>
		<div class="row">
		<div class="small-12 columns">
			<!-- Start Related Posts -->
<aside class="related-posts cf hide-on-print">
	<h4 class="related-title">Related News</h4>
	<div class="row">
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-148675 type-post status-publish format-standard has-post-thumbnail hentry category-review category-television category-tv-reviews tag-anthony-rapp tag-cbs-all-access tag-cleveland-booker tag-david-ajala tag-doug-jones tag-mary-wiseman tag-michael-burnham tag-paul-stamets tag-saru tag-sonequa-martin-green tag-star-trek-discovery tag-sylvia-tilly" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/148675/star-trek-discovery-308-the-sanctuary/" rel="bookmark" title="‘Star Trek: Discovery’ 3×08 review: ‘The Sanctuary’">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/02175410/116944_D_010_RT-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" loading="lazy" />					<figure class="circle_rating small">
			<span>7</span>
			<svg width="50" height="50" viewBox="0 0 50 50" version="1.1" xmlns="http://www.w3.org/2000/svg">
			  <circle class="circle_base" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="0"></circle>
			 	<circle class="circle_perc" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="144.44" data-dashoffset="43.332"></circle>
			</svg>
		</figure>
				</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/television/tv-reviews/" class="single_category_title category-link-1793" title="TV Reviews">TV Reviews</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/148675/star-trek-discovery-308-the-sanctuary/" title="‘Star Trek: Discovery’ 3×08 review: ‘The Sanctuary’">‘Star Trek: Discovery’ 3×08 review: ‘The Sanctuary’</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/areimer/" title="Posts by Amanda Reimer" rel="author">Amanda Reimer</a></strong>
		<time class="date published time hide" datetime="2020-12-04T14:59:10-05:00" itemprop="datePublished" content="2020-12-04T14:59:10-05:00">December 4, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-12-04T14:59:12-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/02175410/116944_D_010_RT.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="800">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/148675/star-trek-discovery-308-the-sanctuary/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-148431 type-post status-publish format-standard has-post-thumbnail hentry category-review category-television category-tv-reviews tag-anthony-rapp tag-cbs-all-access tag-doug-jones tag-hugh-culber tag-mary-wiseman tag-michael-burnham tag-michelle-yeoh tag-paul-stamets tag-philippa-georgiou tag-saru tag-sonequa-martin-green tag-star-trek-discovery tag-sylvia-tilly tag-wilson-cruz" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/148431/star-trek-discovery-3x02-review-far-from-home/" rel="bookmark" title="&#8216;Star Trek: Discovery&#8217; 3&#215;02 review: &#8216;Far From Home&#8217;">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/10/20000236/ST_D14_EP302_0407_RT-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" loading="lazy" />					<figure class="circle_rating small">
			<span>9</span>
			<svg width="50" height="50" viewBox="0 0 50 50" version="1.1" xmlns="http://www.w3.org/2000/svg">
			  <circle class="circle_base" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="0"></circle>
			 	<circle class="circle_perc" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="144.44" data-dashoffset="14.444"></circle>
			</svg>
		</figure>
				</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/television/tv-reviews/" class="single_category_title category-link-1793" title="TV Reviews">TV Reviews</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/148431/star-trek-discovery-3x02-review-far-from-home/" title="&#8216;Star Trek: Discovery&#8217; 3&#215;02 review: &#8216;Far From Home&#8217;">&#8216;Star Trek: Discovery&#8217; 3&#215;02 review: &#8216;Far From Home&#8217;</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/areimer/" title="Posts by Amanda Reimer" rel="author">Amanda Reimer</a></strong>
		<time class="date published time hide" datetime="2020-10-22T09:00:00-04:00" itemprop="datePublished" content="2020-10-22T09:00:00-04:00">October 22, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-10-21T08:56:21-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/10/20000236/ST_D14_EP302_0407_RT.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="802">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/148431/star-trek-discovery-3x02-review-far-from-home/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-148293 type-post status-publish format-standard has-post-thumbnail hentry category-review category-television category-tv-reviews tag-cbs-all-access tag-cleveland-booker tag-david-ajala tag-michael-burnham tag-sonequa-martin-green tag-star-trek tag-star-trek-discovery" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/148293/star-trek-discovery-season-3-premiere-that-hope-is-you-part-1/" rel="bookmark" title="&#8216;Star Trek: Discovery&#8217; season 3 premiere review: &#8216;That Hope is You, Part 1&#8217;">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/10/14152503/115790_0141_RT-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" loading="lazy" />					<figure class="circle_rating small">
			<span>9</span>
			<svg width="50" height="50" viewBox="0 0 50 50" version="1.1" xmlns="http://www.w3.org/2000/svg">
			  <circle class="circle_base" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="0"></circle>
			 	<circle class="circle_perc" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="144.44" data-dashoffset="14.444"></circle>
			</svg>
		</figure>
				</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/television/tv-reviews/" class="single_category_title category-link-1793" title="TV Reviews">TV Reviews</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/148293/star-trek-discovery-season-3-premiere-that-hope-is-you-part-1/" title="&#8216;Star Trek: Discovery&#8217; season 3 premiere review: &#8216;That Hope is You, Part 1&#8217;">&#8216;Star Trek: Discovery&#8217; season 3 premiere review: &#8216;That Hope is You, Part 1&#8217;</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/areimer/" title="Posts by Amanda Reimer" rel="author">Amanda Reimer</a></strong>
		<time class="date published time hide" datetime="2020-10-16T08:46:09-04:00" itemprop="datePublished" content="2020-10-16T08:46:09-04:00">October 16, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-10-16T08:46:10-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/10/14152503/115790_0141_RT.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="802">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/148293/star-trek-discovery-season-3-premiere-that-hope-is-you-part-1/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-145491 type-post status-publish format-standard has-post-thumbnail hentry category-television category-tv-features tag-anthony-rapp tag-brian-michael-smith tag-harry-shum-jr tag-j-august-richards tag-jamie-chung tag-jamie-clayton tag-sdcc-2020 tag-tatiana-maslany tag-wilson-cruz" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/television/145491/comic-con-home-future-lgbtq-tv/" rel="bookmark" title="Comic-Con@Home Panel Discusses the Future of LGBTQ on Television">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/24022614/TYF-1200px-x-675px-1-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" loading="lazy" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/television/tv-features/" class="single_category_title category-link-1795" title="TV Features">TV Features</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/television/145491/comic-con-home-future-lgbtq-tv/" title="Comic-Con@Home Panel Discusses the Future of LGBTQ on Television">Comic-Con@Home Panel Discusses the Future of LGBTQ on Television</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/abulayo/" title="Posts by Ashley Bulayo" rel="author">Ashley Bulayo</a></strong>
		<time class="date published time hide" datetime="2020-07-24T12:03:39-04:00" itemprop="datePublished" content="2020-07-24T12:03:39-04:00">July 24, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-07-24T12:03:40-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/07/24022614/TYF-1200px-x-675px-1.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="675">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/television/145491/comic-con-home-future-lgbtq-tv/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-124035 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-film category-movie-reviews category-review tag-awkwafina tag-constance-wu tag-crazy-rich-asians tag-henry-golding tag-jon-m-chu tag-ken-jeong tag-michelle-yeoh tag-nico-santos" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/124035/crazy-rich-asians-movie-constance-wu/" rel="bookmark" title="Movie Review: Crazy Rich Asians is vibrant, hilarious &#038; absolutely charming">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2018/08/10153950/Crazy-Rich-Asians-Movie-Review-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" loading="lazy" />					<figure class="circle_rating small">
			<span>8</span>
			<svg width="50" height="50" viewBox="0 0 50 50" version="1.1" xmlns="http://www.w3.org/2000/svg">
			  <circle class="circle_base" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="0"></circle>
			 	<circle class="circle_perc" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="144.44" data-dashoffset="28.888"></circle>
			</svg>
		</figure>
				</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/film/movie-reviews/" class="single_category_title category-link-1780" title="Movie Reviews">Movie Reviews</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/124035/crazy-rich-asians-movie-constance-wu/" title="Movie Review: Crazy Rich Asians is vibrant, hilarious &#038; absolutely charming">Movie Review: Crazy Rich Asians is vibrant, hilarious &#038; absolutely charming</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/gabrielleadelle/" title="Posts by Gabrielle Bondi" rel="author">Gabrielle Bondi</a></strong>
		<time class="date published time hide" datetime="2018-08-15T08:00:16-04:00" itemprop="datePublished" content="2018-08-15T08:00:16-04:00">August 15, 2018</time>
		<meta itemprop="dateModified" class="date updated" content="2018-08-15T13:27:31-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2018/08/10153950/Crazy-Rich-Asians-Movie-Review.jpg">
		  <meta itemprop="width" content="2000">
		  <meta itemprop="height" content="1000">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/124035/crazy-rich-asians-movie-constance-wu/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-119686 type-post status-publish format-video has-post-thumbnail hentry category-film category-movie-news category-news tag-awkwafina tag-constance-wu tag-crazy-rich-asians tag-gemma-chan tag-henry-golding tag-jon-m-chu tag-ken-jeong tag-kevin-kwan tag-michelle-yeoh tag-nico-santos tag-warner-bros post_format-post-format-video" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/film/119686/crazy-rich-asians-trailer/" rel="bookmark" title="Watch the first trailer for Crazy Rich Asians">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2018/04/22170710/crazy-rich-asians-constance-wu-570x300.gif" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="crazy rich asians constance wu" loading="lazy" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/film/movie-news/" class="single_category_title category-link-1782" title="Movie News">Movie News</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/film/119686/crazy-rich-asians-trailer/" title="Watch the first trailer for Crazy Rich Asians">Watch the first trailer for Crazy Rich Asians</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/gabrielleadelle/" title="Posts by Gabrielle Bondi" rel="author">Gabrielle Bondi</a></strong>
		<time class="date published time hide" datetime="2018-04-23T10:00:10-04:00" itemprop="datePublished" content="2018-04-23T10:00:10-04:00">April 23, 2018</time>
		<meta itemprop="dateModified" class="date updated" content="2018-04-23T10:00:10-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2018/04/22170710/crazy-rich-asians-constance-wu.gif">
		  <meta itemprop="width" content="1680">
		  <meta itemprop="height" content="1120">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/film/119686/crazy-rich-asians-trailer/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-116377 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-review category-television category-tv-reviews tag-anthony-rapp tag-burnham tag-discovery tag-klingons tag-star-trek tag-the-war-without-the-war-within tag-tv-reviews" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/116377/star-trek-discovery-1x14-review-home-is-where-the-war-is/" rel="bookmark" title="Star Trek: Discovery 1&#215;14 Review: Home Is Where The War Is">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2018/02/05220911/star-trek-1.14-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" loading="lazy" />					<figure class="circle_rating small">
			<span>8</span>
			<svg width="50" height="50" viewBox="0 0 50 50" version="1.1" xmlns="http://www.w3.org/2000/svg">
			  <circle class="circle_base" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="0"></circle>
			 	<circle class="circle_perc" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="144.44" data-dashoffset="28.888"></circle>
			</svg>
		</figure>
				</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/television/tv-reviews/" class="single_category_title category-link-1793" title="TV Reviews">TV Reviews</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/116377/star-trek-discovery-1x14-review-home-is-where-the-war-is/" title="Star Trek: Discovery 1&#215;14 Review: Home Is Where The War Is">Star Trek: Discovery 1&#215;14 Review: Home Is Where The War Is</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/athompson/" title="Posts by Andrea Thompson" rel="author">Andrea Thompson</a></strong>
		<time class="date published time hide" datetime="2018-02-05T22:14:16-05:00" itemprop="datePublished" content="2018-02-05T22:14:16-05:00">February 5, 2018</time>
		<meta itemprop="dateModified" class="date updated" content="2018-02-05T22:14:16-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2018/02/05220911/star-trek-1.14.jpg">
		  <meta itemprop="width" content="1920">
		  <meta itemprop="height" content="1080">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/116377/star-trek-discovery-1x14-review-home-is-where-the-war-is/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-115568 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-review category-television category-tv-reviews tag-anthony-rapp tag-discovery tag-michelle-yeoh tag-scifi tag-star-trek tag-tv-reviews" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/115568/star-trek-discovery-1x12-review-relationships-become-more-twisted-in-vaulting-ambition/" rel="bookmark" title="Star Trek: Discovery 1&#215;12 Review: Relationships Become More Twisted In &#8220;Vaulting Ambition&#8221;">
			<img width="570" height="300" data-original="https://cdn1.theyoungfolks.com/wp-content/uploads/2018/01/22224753/star-trek-1.12.2-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" loading="lazy" />					<figure class="circle_rating small">
			<span>8</span>
			<svg width="50" height="50" viewBox="0 0 50 50" version="1.1" xmlns="http://www.w3.org/2000/svg">
			  <circle class="circle_base" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="0"></circle>
			 	<circle class="circle_perc" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="144.44" data-dashoffset="28.888"></circle>
			</svg>
		</figure>
				</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/review/" class="single_category_title category-link-1" title="Review">Review</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/115568/star-trek-discovery-1x12-review-relationships-become-more-twisted-in-vaulting-ambition/" title="Star Trek: Discovery 1&#215;12 Review: Relationships Become More Twisted In &#8220;Vaulting Ambition&#8221;">Star Trek: Discovery 1&#215;12 Review: Relationships Become More Twisted In &#8220;Vaulting Ambition&#8221;</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/athompson/" title="Posts by Andrea Thompson" rel="author">Andrea Thompson</a></strong>
		<time class="date published time hide" datetime="2018-01-22T22:49:08-05:00" itemprop="datePublished" content="2018-01-22T22:49:08-05:00">January 22, 2018</time>
		<meta itemprop="dateModified" class="date updated" content="2018-01-22T22:53:45-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2018/01/22224753/star-trek-1.12.2.jpg">
		  <meta itemprop="width" content="1600">
		  <meta itemprop="height" content="1067">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/115568/star-trek-discovery-1x12-review-relationships-become-more-twisted-in-vaulting-ambition/">
							</aside>
	</article>    </div>
    </div>
</aside>
<!-- End Related Posts -->		</div>
	</div>
		</div>
		</div><!-- End role["main"] -->
			
						<!-- Start Footer -->
			<footer id="footer" role="contentinfo" class="dark ">
			  	<div class="row">
			  						    <div class="small-12 medium-4 large-4 columns">
				    	<div id="custom-twitter-feeds-widget-2" class="widget cf widget_custom-twitter-feeds-widget"><strong>@TheYoungFolks on Twitter</strong><!-- Custom Twitter Feeds by Smash Balloon --><div id="ctf" class="ctf ctf-type-usertimeline  ctf-styles" style="width: 100%;" data-ctfshortcode="{}" data-ctfneeded="0"><div class="ctf-tweets"><div class="ctf-item ctf-author-theyoungfolks ctf-new" id="1337487842323402756" style=""><div class="ctf-author-box"><div class="ctf-author-box-link" style=""><a href="https://twitter.com/TheYoungFolks" class="ctf-author-avatar" target="_blank" style=""><img src="https://pbs.twimg.com/profile_images/1283846040630812673/AAzeKen6_normal.png" alt="TheYoungFolks" width="48" height="48"></a><a href="https://twitter.com/TheYoungFolks" target="_blank" class="ctf-author-name" style="">The Young Folks</a><a href="https://twitter.com/TheYoungFolks" class="ctf-author-screenname" target="_blank" style="">@TheYoungFolks</a><span class="ctf-screename-sep">&middot;</span><div class="ctf-tweet-meta"><a href="https://twitter.com/TheYoungFolks/status/1337487842323402756" class="ctf-tweet-date" target="_blank" style="">11 Dec</a></div></div> <!-- end .ctf-author-box-link --></div><div class="ctf-tweet-content"><p class="ctf-tweet-text" style="">Set in 17th century Ireland, WOLFWALKERS is a kinetic and evocative in its artistry. 🐺 Movie review by @AllysonAJ: https://t.co/m0YeQog9gm https://t.co/Htb041Lpzg</div><div class="ctf-tweet-actions"><a href="https://twitter.com/intent/tweet?in_reply_to=1337487842323402756&related=TheYoungFolks" class="ctf-reply" target="_blank" style=""><i class="fa fa-reply"></i><span class="ctf-screenreader">Reply on Twitter 1337487842323402756</span></a><a href="https://twitter.com/intent/retweet?tweet_id=1337487842323402756&related=TheYoungFolks" class="ctf-retweet" target="_blank" style=""><i class="fa fa-retweet"></i><span class="ctf-screenreader">Retweet on Twitter 1337487842323402756</span><span class="ctf-action-count ctf-retweet-count">1</span></a><a href="https://twitter.com/intent/like?tweet_id=1337487842323402756&related=TheYoungFolks" class="ctf-like" target="_blank" style=""><i class="fa fa-heart"></i><span class="ctf-screenreader">Like on Twitter 1337487842323402756</span><span class="ctf-action-count ctf-favorite-count">2</span></a><a href="https://twitter.com/TheYoungFolks/status/1337487842323402756" class="ctf-twitterlink" style="" target="_blank">Twitter <span class="ctf-screenreader">1337487842323402756</span></a></div></div><div class="ctf-item ctf-author-theyoungfolks ctf-new" id="1337449810480271360" style=""><div class="ctf-author-box"><div class="ctf-author-box-link" style=""><a href="https://twitter.com/TheYoungFolks" class="ctf-author-avatar" target="_blank" style=""><img src="https://pbs.twimg.com/profile_images/1283846040630812673/AAzeKen6_normal.png" alt="TheYoungFolks" width="48" height="48"></a><a href="https://twitter.com/TheYoungFolks" target="_blank" class="ctf-author-name" style="">The Young Folks</a><a href="https://twitter.com/TheYoungFolks" class="ctf-author-screenname" target="_blank" style="">@TheYoungFolks</a><span class="ctf-screename-sep">&middot;</span><div class="ctf-tweet-meta"><a href="https://twitter.com/TheYoungFolks/status/1337449810480271360" class="ctf-tweet-date" target="_blank" style="">11 Dec</a></div></div> <!-- end .ctf-author-box-link --></div><div class="ctf-tweet-content"><p class="ctf-tweet-text" style="">Starring Steven Yeun, #Minari is one of the most lasting and touching films to come out in 2020. ➡️  Movie review by @JonNegroni:  https://t.co/HpTKAeoSif</div><div class="ctf-tweet-actions"><a href="https://twitter.com/intent/tweet?in_reply_to=1337449810480271360&related=TheYoungFolks" class="ctf-reply" target="_blank" style=""><i class="fa fa-reply"></i><span class="ctf-screenreader">Reply on Twitter 1337449810480271360</span></a><a href="https://twitter.com/intent/retweet?tweet_id=1337449810480271360&related=TheYoungFolks" class="ctf-retweet" target="_blank" style=""><i class="fa fa-retweet"></i><span class="ctf-screenreader">Retweet on Twitter 1337449810480271360</span><span class="ctf-action-count ctf-retweet-count">1</span></a><a href="https://twitter.com/intent/like?tweet_id=1337449810480271360&related=TheYoungFolks" class="ctf-like" target="_blank" style=""><i class="fa fa-heart"></i><span class="ctf-screenreader">Like on Twitter 1337449810480271360</span><span class="ctf-action-count ctf-favorite-count">8</span></a><a href="https://twitter.com/TheYoungFolks/status/1337449810480271360" class="ctf-twitterlink" style="" target="_blank">Twitter <span class="ctf-screenreader">1337449810480271360</span></a></div></div><div class="ctf-item ctf-author-theyoungfolks ctf-new ctf-retweet" id="1337200754197716992" style=""><div class="ctf-context"><a href="https://twitter.com/intent/user?screen_name=TheYoungFolks" target="_blank" class="ctf-retweet-icon"><i class="fa fa-retweet" aria-hidden="true"></i><span class="ctf-screenreader">Retweet on Twitter</span></a><a href="https://twitter.com/TheYoungFolks" target="_blank" class="ctf-retweet-text" style="">The Young Folks Retweeted</a></div><div class="ctf-author-box"><div class="ctf-author-box-link" style=""><a href="https://twitter.com/Disney" class="ctf-author-avatar" target="_blank" style=""><img src="https://pbs.twimg.com/profile_images/1289584734494892032/Z1TjPU-z_normal.jpg" alt="Disney" width="48" height="48"></a><a href="https://twitter.com/Disney" target="_blank" class="ctf-author-name" style="">Disney</a><span class="ctf-verified" ><i class="fa fa-check-circle" aria-hidden="true"></i></span><a href="https://twitter.com/Disney" class="ctf-author-screenname" target="_blank" style="">@Disney</a><span class="ctf-screename-sep">&middot;</span><div class="ctf-tweet-meta"><a href="https://twitter.com/Disney/status/1337200405659480065" class="ctf-tweet-date" target="_blank" style="">11 Dec</a></div></div> <!-- end .ctf-author-box-link --></div><div class="ctf-tweet-content"><p class="ctf-tweet-text" style="">Black Panther 2, opening July 8, 2022, is being written &amp; directed by Ryan Coogler. Honoring Chadwick Boseman’s legacy &amp; portrayal of T’Challa, @MarvelStudios will not recast the character, but will explore the world of Wakanda &amp; the rich characters introduced in the first film.</div><div class="ctf-tweet-actions"><a href="https://twitter.com/intent/tweet?in_reply_to=1337200405659480065&related=Disney" class="ctf-reply" target="_blank" style=""><i class="fa fa-reply"></i><span class="ctf-screenreader">Reply on Twitter 1337200405659480065</span></a><a href="https://twitter.com/intent/retweet?tweet_id=1337200405659480065&related=Disney" class="ctf-retweet" target="_blank" style=""><i class="fa fa-retweet"></i><span class="ctf-screenreader">Retweet on Twitter 1337200405659480065</span><span class="ctf-action-count ctf-retweet-count">14805</span></a><a href="https://twitter.com/intent/like?tweet_id=1337200405659480065&related=Disney" class="ctf-like" target="_blank" style=""><i class="fa fa-heart"></i><span class="ctf-screenreader">Like on Twitter 1337200405659480065</span><span class="ctf-action-count ctf-favorite-count">74444</span></a><a href="https://twitter.com/Disney/status/1337200405659480065" class="ctf-twitterlink" style="" target="_blank">Twitter <span class="ctf-screenreader">1337200405659480065</span></a></div></div></div></div><script type="text/javascript" src="https://www.theyoungfolks.com/wp-content/plugins/custom-twitter-feeds/js/ctf-scripts.js?ver=1.3"></script></div>				    </div>
				    <div class="small-12 medium-4 large-4 columns">
				    	<div id="thb_categoryslider_widget-2" class="widget cf widget_categoryslider"><strong>Latest Reviews</strong><div class="slick text-center" data-columns="1" data-pagination="false" data-navigation="true" data-autoplay="false" data-speed="500"><article itemscope itemtype="http://schema.org/Article" class="post style1 style1-meta post-149638 type-post status-publish format-standard has-post-thumbnail hentry category-film category-movie-reviews category-review tag-emily-blunt tag-jamie-dornan tag-john-patrick-shanley tag-jon-hamm tag-wild-mountain-thyme" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/149638/wild-mountain-thyme-review-romance-is-lost-amid-inconsistent-storytelling/" rel="bookmark" title="&#8216;Wild Mountain Thyme&#8217; review: Romance is lost amid inconsistent storytelling">
			<img width="280" height="150" src="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/12095233/Wild-M-T-00852-280x150.jpg" class="no-lazy-load wp-post-image" alt="" loading="lazy" />					<figure class="circle_rating small">
			<span>4</span>
			<svg width="50" height="50" viewBox="0 0 50 50" version="1.1" xmlns="http://www.w3.org/2000/svg">
			  <circle class="circle_base" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="0"></circle>
			 	<circle class="circle_perc" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="144.44" data-dashoffset="86.664"></circle>
			</svg>
		</figure>
				</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/film/movie-reviews/" class="single_category_title category-link-1780" title="Movie Reviews">Movie Reviews</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/149638/wild-mountain-thyme-review-romance-is-lost-amid-inconsistent-storytelling/" title="&#8216;Wild Mountain Thyme&#8217; review: Romance is lost amid inconsistent storytelling">&#8216;Wild Mountain Thyme&#8217; review: Romance is lost amid inconsistent storytelling</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/mabdulbaki/" title="Posts by Mae Abdulbaki" rel="author">Mae Abdulbaki</a></strong>
		<time class="date published time" datetime="2020-12-12T12:55:03-05:00" itemprop="datePublished" content="2020-12-12T12:55:03-05:00">December 12, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-12-12T13:01:43-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/12095233/Wild-M-T-00852-scaled.jpg">
		  <meta itemprop="width" content="2560">
		  <meta itemprop="height" content="1708">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/149638/wild-mountain-thyme-review-romance-is-lost-amid-inconsistent-storytelling/">
							</aside>
	</article><article itemscope itemtype="http://schema.org/Article" class="post style1 style1-meta post-149521 type-post status-publish format-standard has-post-thumbnail hentry category-review category-television category-tv-reviews tag-anthony-rapp tag-cbs-all-access tag-david-ajala tag-doug-jones tag-mary-wiseman tag-michelle-yeoh tag-paul-stamets tag-sonequa-martin-green tag-star-trek-discovery tag-wilson-cruz" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/" rel="bookmark" title="‘Star Trek: Discovery’ 3×09 review: ‘Terra Firma, Part 1’">
			<img width="280" height="150" src="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT-280x150.jpg" class="no-lazy-load wp-post-image" alt="Star Trek Discovery 309 Terra Firma Saru Tilly" loading="lazy" />					<figure class="circle_rating small">
			<span>8</span>
			<svg width="50" height="50" viewBox="0 0 50 50" version="1.1" xmlns="http://www.w3.org/2000/svg">
			  <circle class="circle_base" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="0"></circle>
			 	<circle class="circle_perc" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="144.44" data-dashoffset="28.888"></circle>
			</svg>
		</figure>
				</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/television/tv-reviews/" class="single_category_title category-link-1793" title="TV Reviews">TV Reviews</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/" title="‘Star Trek: Discovery’ 3×09 review: ‘Terra Firma, Part 1’">‘Star Trek: Discovery’ 3×09 review: ‘Terra Firma, Part 1’</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/areimer/" title="Posts by Amanda Reimer" rel="author">Amanda Reimer</a></strong>
		<time class="date published time" datetime="2020-12-12T09:47:03-05:00" itemprop="datePublished" content="2020-12-12T09:47:03-05:00">December 12, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-12-12T09:47:04-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/08172835/116949_D_016_RT.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="800">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/149521/star-trek-discovery-3x09-review-terra-firma-part-1/">
							</aside>
	</article><article itemscope itemtype="http://schema.org/Article" class="post style1 style1-meta post-149628 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-film category-movie-reviews category-review tag-featured tag-film-2 tag-movies tag-tomm-moore tag-wolfwalkers" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/149628/wolfwalkers-review-a-visually-stunning-tale/" rel="bookmark" title="&#8216;Wolfwalkers&#8217; review: A visually stunning tale">
			<img width="280" height="150" src="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/09/13172454/wolfwalkers-02-280x150.jpg" class="no-lazy-load wp-post-image" alt="" loading="lazy" />					<figure class="circle_rating small">
			<span>8</span>
			<svg width="50" height="50" viewBox="0 0 50 50" version="1.1" xmlns="http://www.w3.org/2000/svg">
			  <circle class="circle_base" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="0"></circle>
			 	<circle class="circle_perc" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="144.44" data-dashoffset="28.888"></circle>
			</svg>
		</figure>
				</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/film/movie-reviews/" class="single_category_title category-link-1780" title="Movie Reviews">Movie Reviews</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/149628/wolfwalkers-review-a-visually-stunning-tale/" title="&#8216;Wolfwalkers&#8217; review: A visually stunning tale">&#8216;Wolfwalkers&#8217; review: A visually stunning tale</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/johnsona/" title="Posts by Allyson Johnson" rel="author">Allyson Johnson</a></strong>
		<time class="date published time" datetime="2020-12-11T12:32:13-05:00" itemprop="datePublished" content="2020-12-11T12:32:13-05:00">December 11, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-12-11T12:38:07-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/09/13172454/wolfwalkers-02.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="600">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/149628/wolfwalkers-review-a-visually-stunning-tale/">
							</aside>
	</article></div></div><div id="thb_categoryslider_widget-3" class="widget cf widget_categoryslider"><strong>Latest Interviews</strong><div class="slick text-center" data-columns="1" data-pagination="false" data-navigation="true" data-autoplay="false" data-speed="500"><article itemscope itemtype="http://schema.org/Article" class="post style1 style1-meta post-149592 type-post status-publish format-standard has-post-thumbnail hentry category-interviews category-music category-music-features tag-fenix-flexin tag-shoreline-mafia" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/149592/music-interview-its-time-for-fenix-flexin-to-enter-the-spotlight/" rel="bookmark" title="Music Interview: It&#8217;s Time for Fenix Flexin to Enter the Spotlight">
			<img width="280" height="150" src="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/10165456/Screen-Shot-2020-12-10-at-4.53.45-PM-280x150.png" class="no-lazy-load wp-post-image" alt="" loading="lazy" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/interviews/" class="single_category_title category-link-3836" title="Interviews">Interviews</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/149592/music-interview-its-time-for-fenix-flexin-to-enter-the-spotlight/" title="Music Interview: It&#8217;s Time for Fenix Flexin to Enter the Spotlight">Music Interview: It&#8217;s Time for Fenix Flexin to Enter the Spotlight</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/rfeyre/" title="Posts by Ryan Feyre" rel="author">Ryan Feyre</a></strong>
		<time class="date published time" datetime="2020-12-11T11:43:01-05:00" itemprop="datePublished" content="2020-12-11T11:43:01-05:00">December 11, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-12-11T11:43:03-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/10165456/Screen-Shot-2020-12-10-at-4.53.45-PM.png">
		  <meta itemprop="width" content="531">
		  <meta itemprop="height" content="527">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/149592/music-interview-its-time-for-fenix-flexin-to-enter-the-spotlight/">
							</aside>
	</article><article itemscope itemtype="http://schema.org/Article" class="post style1 style1-meta post-149604 type-post status-publish format-video has-post-thumbnail hentry category-film category-interviews category-movie-features tag-descendants tag-michael-bay tag-sofia-carson tag-songbird post_format-post-format-video" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/film/149604/interview-sofia-carson-songbird/" rel="bookmark" title="Interview: Sofia Carson discusses her new thriller &#8216;Songbird&#8217;">
			<img width="280" height="150" src="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/10190951/My-Post-2020-12-10T190817.744-280x150.jpg" class="no-lazy-load wp-post-image" alt="Sofia Carson Poster" loading="lazy" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/interviews/" class="single_category_title category-link-3836" title="Interviews">Interviews</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/film/149604/interview-sofia-carson-songbird/" title="Interview: Sofia Carson discusses her new thriller &#8216;Songbird&#8217;">Interview: Sofia Carson discusses her new thriller &#8216;Songbird&#8217;</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/aguivas/" title="Posts by Anthony Guivas" rel="author">Anthony Guivas</a></strong>
		<time class="date published time" datetime="2020-12-10T19:31:45-05:00" itemprop="datePublished" content="2020-12-10T19:31:45-05:00">December 10, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-12-10T19:31:46-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/10190951/My-Post-2020-12-10T190817.744.jpg">
		  <meta itemprop="width" content="2560">
		  <meta itemprop="height" content="1440">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/film/149604/interview-sofia-carson-songbird/">
							</aside>
	</article><article itemscope itemtype="http://schema.org/Article" class="post style1 style1-meta post-149404 type-post status-publish format-standard has-post-thumbnail hentry category-film category-interviews category-movie-features tag-disney-plus tag-godmothered tag-isla-fisher tag-jillian-bell tag-willa-skye" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/film/149404/godmothered-interview-willa-skye/" rel="bookmark" title="&#8216;Godmothered&#8217; interview: Willa Skye talks her new Christmas movie on Disney Plus">
			<img width="280" height="150" src="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/03173428/GMD-04872-280x150.jpg" class="no-lazy-load wp-post-image" alt="" loading="lazy" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/interviews/" class="single_category_title category-link-3836" title="Interviews">Interviews</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/film/149404/godmothered-interview-willa-skye/" title="&#8216;Godmothered&#8217; interview: Willa Skye talks her new Christmas movie on Disney Plus">&#8216;Godmothered&#8217; interview: Willa Skye talks her new Christmas movie on Disney Plus</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/areimer/" title="Posts by Amanda Reimer" rel="author">Amanda Reimer</a></strong>
		<time class="date published time" datetime="2020-12-03T21:52:37-05:00" itemprop="datePublished" content="2020-12-03T21:52:37-05:00">December 3, 2020</time>
		<meta itemprop="dateModified" class="date updated" content="2020-12-03T21:52:38-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/12/03173428/GMD-04872-scaled.jpg">
		  <meta itemprop="width" content="2560">
		  <meta itemprop="height" content="1707">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/film/149404/godmothered-interview-willa-skye/">
							</aside>
	</article></div></div>				    </div>
				    <div class="small-12 medium-4 large-4 columns">
				        <div id="wpcom_instagram_widget-3" class="widget cf widget_wpcom_instagram_widget"><strong>@TheYoungFolks on Instagram</strong><div class="wpcom-instagram-images wpcom-instagram-columns-2">
<a href="https://www.instagram.com/p/CH8dLtQg1C3/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent-iad3-1.cdninstagram.com/v/t51.29350-15/127060574_705417927058599_3477197793054865594_n.jpg?_nc_cat=111&#038;ccb=2&#038;_nc_sid=8ae9d6&#038;_nc_ohc=swph1j_76X8AX8ByDfq&#038;_nc_ht=scontent-iad3-1.cdninstagram.com&#038;oh=dee987e8330925c5418b4c032d6aeb38&#038;oe=5FFA7749)"><span class="screen-reader-text"></span></div></a>
<a href="https://www.instagram.com/p/CHBHVxoAThP/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent-iad3-1.cdninstagram.com/v/t51.29350-15/123284891_110565207518773_3437977670551153614_n.jpg?_nc_cat=100&#038;ccb=2&#038;_nc_sid=8ae9d6&#038;_nc_ohc=3OBaBcw5UtkAX9bsZ1I&#038;_nc_ht=scontent-iad3-1.cdninstagram.com&#038;oh=9f42178e4d036e305364f4e9a288002f&#038;oe=5FFC2AA7)"><span class="screen-reader-text"></span></div></a>
<a href="https://www.instagram.com/p/CHAsVm9AoiD/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent-iad3-1.cdninstagram.com/v/t51.29350-15/123017249_778169262744925_604053719103908939_n.jpg?_nc_cat=104&#038;ccb=2&#038;_nc_sid=8ae9d6&#038;_nc_ohc=ucalqlP7S68AX-V5Opf&#038;_nc_ht=scontent-iad3-1.cdninstagram.com&#038;oh=93a847c358da3ea09ee1348df0afcc57&#038;oe=5FFA729B)"><span class="screen-reader-text"></span></div></a>
<a href="https://www.instagram.com/p/CG-3ZH6gkuY/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent-iad3-1.cdninstagram.com/v/t51.29350-15/122748001_202872777853895_335197292786169558_n.jpg?_nc_cat=108&#038;ccb=2&#038;_nc_sid=8ae9d6&#038;_nc_ohc=lHckBHNZPVQAX_qqL0n&#038;_nc_ht=scontent-iad3-1.cdninstagram.com&#038;oh=17ce3eb08e12e2b76e3027e69e5ec4c4&#038;oe=5FFB90A7)"><span class="screen-reader-text"></span></div></a>
<a href="https://www.instagram.com/p/CG-hWTrgVsZ/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent-iad3-1.cdninstagram.com/v/t51.29350-15/123072903_961563147667333_8317343165945099190_n.jpg?_nc_cat=102&#038;ccb=2&#038;_nc_sid=8ae9d6&#038;_nc_ohc=7TAqS8E6SDkAX9DDgw2&#038;_nc_ht=scontent-iad3-1.cdninstagram.com&#038;oh=c47e4d4fd454d99821aa3baf5bbd4e25&#038;oe=5FFC0DD6)"><span class="screen-reader-text"></span></div></a>
<a href="https://www.instagram.com/p/CGlV_TZjwHC/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent-iad3-1.cdninstagram.com/v/t51.29350-15/122246421_386105362752463_3005633682188338619_n.jpg?_nc_cat=105&#038;ccb=2&#038;_nc_sid=8ae9d6&#038;_nc_ohc=jUPDL145PpEAX8WDnP2&#038;_nc_ht=scontent-iad3-1.cdninstagram.com&#038;oh=c806a860f46a2d91d2c79385b6a1c2a3&#038;oe=5FFB43C1)"><span class="screen-reader-text"></span></div></a>
</div>
</div>				    </div>
				    			    </div>
			</footer>
			<!-- End Footer -->
									<!-- Start Sub Footer -->
			<footer id="subfooter" role="contentinfo" class="dark ">
				<div class="row">
					<div class="small-12 columns">
						<div class="subfooter-menu-holder text-center">
															<a href="https://www.theyoungfolks.com/" class="logolink">
									<img src="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/25135816/TYF-Logo-2020-updated-new.png" class="logoimg" alt="The Young Folks"/>
								</a>
														<div class="subfooter-menu"><ul id="menu-footer-menu" class="footer-menu"><li id="menu-item-24378" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-24378"><a href="https://www.theyoungfolks.com/">Home</a></li>
<li id="menu-item-146691" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-146691"><a href="https://www.theyoungfolks.com/about/">About</a></li>
<li id="menu-item-24380" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24380"><a href="https://www.theyoungfolks.com/write/">Write</a></li>
</ul></div>	
							<p>Copyright 2020 The Young Folks. All Rights Reserved </p>
						</div>
					</div>
				</div>
			</footer>
			<!-- End Sub Footer -->
				</section> <!-- End #content-container -->

</div> <!-- End #wrapper -->
	<a href="#" id="scroll_totop"><i class="fa fa-angle-up"></i></a>
	<div style="display:none">
	<div class="grofile-hash-map-393259cc1b09a01010ed30063acce76d">
	</div>
	</div>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.3.10' id='mpp_gutenberg_tabs-js'></script>
<script type='text/javascript' src='https://platform.twitter.com/widgets.js?ver=1.3' id='ctf_twitter_intents-js'></script>
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"theyoungfolks"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"149521 https:\/\/www.theyoungfolks.com\/?p=149521","disqusShortname":"theyoungfolks","disqusTitle":"\u2018Star Trek: Discovery\u2019 3\u00d709 review: \u2018Terra Firma, Part 1\u2019","disqusUrl":"https:\/\/www.theyoungfolks.com\/review\/149521\/star-trek-discovery-3x09-review-terra-firma-part-1\/","postId":"149521"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17' id='disqus_embed-js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=202050' id='grofiles-cards-js'></script>
<script type='text/javascript' id='wpgroho-js-extra'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=9.2.1' id='wpgroho-js'></script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-includes/js/comment-reply.min.js?ver=5.5.3' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/assets/js/vendor.min.js' id='thb-vendor-js'></script>
<script type='text/javascript' id='thb-app-js-extra'>
/* <![CDATA[ */
var themeajax = {"url":"https:\/\/www.theyoungfolks.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/assets/js/app.min.js?ver=2.1.2' id='thb-app-js'></script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.3.4' id='page-links-to-js'></script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-includes/js/wp-embed.min.js?ver=5.5.3' id='wp-embed-js'></script>
</body>
</html>