<!doctype html>
<html lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=1">
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<link rel="pingback" href="https://www.theyoungfolks.com/xmlrpc.php">
	<link rel="icon" href="https://www.theyoungfolks.com/wp-content/uploads/2020/07/cropped-TYF-Favicon-2020-rounded-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.theyoungfolks.com/wp-content/uploads/2020/07/cropped-TYF-Favicon-2020-rounded-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.theyoungfolks.com/wp-content/uploads/2020/07/cropped-TYF-Favicon-2020-rounded-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.theyoungfolks.com/wp-content/uploads/2020/07/cropped-TYF-Favicon-2020-rounded-270x270.png" />
		
	<meta http-equiv="x-dns-prefetch-control" content="on">
	<link rel="dns-prefetch" href="//fonts.googleapis.com" />
	<link rel="dns-prefetch" href="//fonts.gstatic.com" />
	<link rel="dns-prefetch" href="//0.gravatar.com/" />
	<link rel="dns-prefetch" href="//2.gravatar.com/" />
	<link rel="dns-prefetch" href="//1.gravatar.com/" />
	<title>Album Review: Wolf Alice - “Blue Weekend” | The Young Folks</title>
<meta name='robots' content='max-image-preview:large' />

		<!-- All in One SEO Pro 4.0.14 -->
		<meta name="description" content="Blue Weekend is a rollercoaster of emotions, pulling the listener through a history of relationships of every kind."/>
		<meta name="google-site-verification" content="q9jghf6ac2Do5My578tzPgrXe6Jq-piVkt0dUFt5kfk" />
		<link rel="canonical" href="https://www.theyoungfolks.com/music/161720/album-review-wolf-alice-blue-weekend/" />
		<meta property="og:site_name" content="The Young Folks | Entertainment &amp; Pop Culture Criticism" />
		<meta property="og:type" content="article" />
		<meta property="og:title" content="Album Review: Wolf Alice - “Blue Weekend” | The Young Folks" />
		<meta property="og:description" content="Blue Weekend is a rollercoaster of emotions, pulling the listener through a history of relationships of every kind." />
		<meta property="og:url" content="https://www.theyoungfolks.com/music/161720/album-review-wolf-alice-blue-weekend/" />
		<meta property="fb:app_id" content="449377471938761" />
		<meta property="fb:admins" content="156189131064135" />
		<meta property="og:image" content="https://www.theyoungfolks.com/wp-content/uploads/2021/12/61TQ8uEUo6L._SL1500_.jpg" />
		<meta property="og:image:secure_url" content="https://www.theyoungfolks.com/wp-content/uploads/2021/12/61TQ8uEUo6L._SL1500_.jpg" />
		<meta property="og:image:width" content="1500" />
		<meta property="og:image:height" content="1500" />
		<meta property="article:published_time" content="2022-01-01T14:27:00Z" />
		<meta property="article:modified_time" content="2022-01-01T02:28:50Z" />
		<meta property="article:publisher" content="https://www.facebook.com/theyoungfolks/" />
		<meta property="twitter:card" content="summary_large_image" />
		<meta property="twitter:site" content="@theyoungfolks" />
		<meta property="twitter:domain" content="www.theyoungfolks.com" />
		<meta property="twitter:title" content="Album Review: Wolf Alice - “Blue Weekend” | The Young Folks" />
		<meta property="twitter:description" content="Blue Weekend is a rollercoaster of emotions, pulling the listener through a history of relationships of every kind." />
		<meta property="twitter:creator" content="@bri_lockhart" />
		<meta property="twitter:image" content="https://www.theyoungfolks.com/wp-content/uploads/2021/12/61TQ8uEUo6L._SL1500_.jpg" />
		<script type="application/ld+json" class="aioseo-schema">
			{"@context":"https:\/\/schema.org","@graph":[{"@type":"WebSite","@id":"https:\/\/www.theyoungfolks.com\/#website","url":"https:\/\/www.theyoungfolks.com\/","name":"The Young Folks","description":"Entertainment & Pop Culture Criticism","publisher":{"@id":"https:\/\/www.theyoungfolks.com\/#organization"},"potentialAction":{"@type":"SearchAction","target":"https:\/\/www.theyoungfolks.com\/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"Organization","@id":"https:\/\/www.theyoungfolks.com\/#organization","name":"The Young Folks","url":"https:\/\/www.theyoungfolks.com\/","logo":{"@type":"ImageObject","@id":"https:\/\/www.theyoungfolks.com\/#organizationLogo"},"image":{"@id":"https:\/\/www.theyoungfolks.com\/#organizationLogo"},"sameAs":["https:\/\/www.facebook.com\/theyoungfolks\/","https:\/\/twitter.com\/theyoungfolks","https:\/\/www.instagram.com\/theyoungfolks\/","https:\/\/www.youtube.com\/c\/TheYoungFolks","https:\/\/www.linkedin.com\/company\/theyoungfolks"]},{"@type":"BreadcrumbList","@id":"https:\/\/www.theyoungfolks.com\/music\/161720\/album-review-wolf-alice-blue-weekend\/#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"https:\/\/www.theyoungfolks.com\/#listItem","position":"1","item":{"@id":"https:\/\/www.theyoungfolks.com\/#item","name":"Home","description":"The Young Folks' mission is to provide youthful and fresh perspectives on every aspect of pop culture, including movies, music, books, TV and games.","url":"https:\/\/www.theyoungfolks.com\/"},"nextItem":"https:\/\/www.theyoungfolks.com\/music\/#listItem"},{"@type":"ListItem","@id":"https:\/\/www.theyoungfolks.com\/music\/#listItem","position":"2","item":{"@id":"https:\/\/www.theyoungfolks.com\/music\/#item","name":"Music","description":"Blue Weekend is a rollercoaster of emotions, pulling the listener through a history of relationships of every kind.","url":"https:\/\/www.theyoungfolks.com\/music\/"},"nextItem":"https:\/\/www.theyoungfolks.com\/music\/161720\/album-review-wolf-alice-blue-weekend\/#listItem","previousItem":"https:\/\/www.theyoungfolks.com\/#listItem"},{"@type":"ListItem","@id":"https:\/\/www.theyoungfolks.com\/music\/161720\/album-review-wolf-alice-blue-weekend\/#listItem","position":"3","item":{"@id":"https:\/\/www.theyoungfolks.com\/music\/161720\/album-review-wolf-alice-blue-weekend\/#item","name":"Album Review: Wolf Alice - \u201cBlue Weekend\u201d","description":"Blue Weekend is a rollercoaster of emotions, pulling the listener through a history of relationships of every kind.","url":"https:\/\/www.theyoungfolks.com\/music\/161720\/album-review-wolf-alice-blue-weekend\/"},"previousItem":"https:\/\/www.theyoungfolks.com\/music\/#listItem"}]},{"@type":"Person","@id":"https:\/\/www.theyoungfolks.com\/author\/brilockhart\/#author","url":"https:\/\/www.theyoungfolks.com\/author\/brilockhart\/","name":"Bri Lockhart","sameAs":["https:\/\/www.facebook.com\/theyoungfolks\/","bri_lockhart","https:\/\/www.instagram.com\/theyoungfolks\/","https:\/\/www.youtube.com\/c\/TheYoungFolks","https:\/\/www.linkedin.com\/company\/theyoungfolks"]}]}
		</script>
		<script type="text/javascript" >
			window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
			ga('create', "UA-12374332-4", 'auto');
			ga('send', 'pageview');
		</script>
		<script async src="https://www.google-analytics.com/analytics.js"></script>
		<!-- All in One SEO Pro -->

<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Young Folks &raquo; Feed" href="https://www.theyoungfolks.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Young Folks &raquo; Comments Feed" href="https://www.theyoungfolks.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Young Folks &raquo; Album Review: Wolf Alice &#8211; “Blue Weekend” Comments Feed" href="https://www.theyoungfolks.com/music/161720/album-review-wolf-alice-blue-weekend/feed/" />
						<meta property="og:title" content="Album Review: Wolf Alice &#8211; “Blue Weekend”" />
			<meta property="og:type" content="article" />
			<meta property="og:description" content="Over the course of their eleven years, London-born alt rock band Wolf Alice has proven that they’re a band to watch. Their 2015 debut album, My Love Is Cool, wa" />
			<meta property="og:image" content="https://www.theyoungfolks.com/wp-content/uploads/2021/12/61TQ8uEUo6L._SL1500_.jpg" />
			<meta property="og:url" content="https://www.theyoungfolks.com/music/161720/album-review-wolf-alice-blue-weekend/" />
					<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.theyoungfolks.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.theyoungfolks.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://www.theyoungfolks.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://www.theyoungfolks.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://www.theyoungfolks.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='ctf_styles-css'  href='https://www.theyoungfolks.com/wp-content/plugins/custom-twitter-feeds/css/ctf-styles.min.css?ver=1.7' type='text/css' media='all' />
<link rel='stylesheet' id='modern_footnotes-css'  href='https://www.theyoungfolks.com/wp-content/plugins/modern-footnotes/styles.min.css?ver=1.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='math-captcha-frontend-css'  href='https://www.theyoungfolks.com/wp-content/plugins/wp-math-captcha/css/frontend.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='thb-fa-css'  href='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/assets/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thb-app-css'  href='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/assets/css/app.css?ver=2.1.2' type='text/css' media='all' />
<style id='thb-app-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='style-css'  href='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='thb-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Droid+Serif%3A300%2C400%2C500%2C600%2C700%2C900%7CPoppins%3A300%2C400%2C500%2C600%2C700%2C900&#038;subset=latin%2Clatin-ext&#038;ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.theyoungfolks.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.4' type='text/css' media='all' />
<script type='text/javascript' id='jquery-core-js-extra'>
/* <![CDATA[ */
var ctf = {"ajax_url":"https:\/\/www.theyoungfolks.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js' id='html5-shiv-js'></script>
<![endif]-->
<link rel="https://api.w.org/" href="https://www.theyoungfolks.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.theyoungfolks.com/wp-json/wp/v2/posts/161720" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.theyoungfolks.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.theyoungfolks.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.2" />
<link rel='shortlink' href='https://wp.me/p5gXzl-G4o' />
<link rel="alternate" type="application/json+oembed" href="https://www.theyoungfolks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F161720%2Falbum-review-wolf-alice-blue-weekend%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.theyoungfolks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F161720%2Falbum-review-wolf-alice-blue-weekend%2F&#038;format=xml" />
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<link rel="icon" href="https://www.theyoungfolks.com/wp-content/uploads/2020/07/cropped-TYF-Favicon-2020-rounded-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.theyoungfolks.com/wp-content/uploads/2020/07/cropped-TYF-Favicon-2020-rounded-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.theyoungfolks.com/wp-content/uploads/2020/07/cropped-TYF-Favicon-2020-rounded-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.theyoungfolks.com/wp-content/uploads/2020/07/cropped-TYF-Favicon-2020-rounded-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			.post.blog-post .post-title {
    margin-bottom: 40px;
}		</style>
		<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>		<meta name="norton-safeweb-site-verification" content="rwr0f6kx274t8xgjjttouapy0u9kpb0pomx7w4ozxn4715jrqzi8dkb6vugohvgwsixwypfm3vwz9ly9lxpj3q9qj4bw56r88xchfe1u8h7bjn63zodcnkdzo47rjg7w" />
</head>
<body class="post-template-default single single-post postid-161720 single-format-standard lazy-load-on thb_ads_header_mobile_off thb-lightbox-off thb-capitalize-off wpb-js-composer js-comp-ver-6.4.1 vc_responsive" data-themeurl="https://www.theyoungfolks.com/wp-content/themes/goodlife-wp">
<div id="wrapper" class="open">
	
	<!-- Start Mobile Menu -->
			<nav id="mobile-menu">
			<div class="custom_scroll" id="menu-scroll">
				<div>
															  <ul id="menu-mobile-menu" class="mobile-menu"><li id="menu-item-146693" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-146693"><a title="About" href="https://www.theyoungfolks.com/about/"><span><i class="fa fa-plus"></i></span>About</a>
<ul class="sub-menu">
	<li id="menu-item-146694" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-146694"><a href="https://www.theyoungfolks.com/about/">About The Young Folks</a></li>
	<li id="menu-item-98506" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-98506"><a href="https://www.theyoungfolks.com/write/">Join the TYF Team!</a></li>
	<li id="menu-item-98507" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-98507"><a href="https://www.theyoungfolks.com/review-policy/general-comment-policy/">General Comment Policy</a></li>
</ul>
</li>
<li id="menu-item-98510" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98510 menu-item-category-6"><a href="https://www.theyoungfolks.com/books/"><span><i class="fa fa-plus"></i></span>Books</a>
<ul class="sub-menu">
	<li id="menu-item-98513" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98513 menu-item-category-1781"><a href="https://www.theyoungfolks.com/books/book-reviews/">Book Reviews</a></li>
	<li id="menu-item-98512" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98512 menu-item-category-1784"><a href="https://www.theyoungfolks.com/books/book-news/">Book News</a></li>
	<li id="menu-item-98511" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98511 menu-item-category-1785"><a href="https://www.theyoungfolks.com/books/book-features/">Book Features</a></li>
	<li id="menu-item-98514" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98514 menu-item-category-14026"><a href="https://www.theyoungfolks.com/books/comics/">Comics &#038; Graphic Novels</a></li>
</ul>
</li>
<li id="menu-item-98515" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98515 menu-item-category-3"><a href="https://www.theyoungfolks.com/film/"><span><i class="fa fa-plus"></i></span>Film</a>
<ul class="sub-menu">
	<li id="menu-item-98519" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98519 menu-item-category-1780"><a href="https://www.theyoungfolks.com/film/movie-reviews/">Movie Reviews</a></li>
	<li id="menu-item-98518" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98518 menu-item-category-1782"><a href="https://www.theyoungfolks.com/film/movie-news/">Movie News</a></li>
	<li id="menu-item-98517" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98517 menu-item-category-1783"><a href="https://www.theyoungfolks.com/film/movie-features/">Movie Features</a></li>
	<li id="menu-item-98521" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98521 menu-item-category-1450"><a href="https://www.theyoungfolks.com/film/the-film-canon/">The Film Canon</a></li>
</ul>
</li>
<li id="menu-item-98528" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-98528 menu-item-category-4"><a href="https://www.theyoungfolks.com/music/"><span><i class="fa fa-plus"></i></span>Music</a>
<ul class="sub-menu">
	<li id="menu-item-98533" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-98533 menu-item-category-1786"><a href="https://www.theyoungfolks.com/music/music-reviews/"><span><i class="fa fa-plus"></i></span>Music Reviews</a>
	<ul class="sub-menu">
		<li id="menu-item-98529" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98529 menu-item-category-5"><a href="https://www.theyoungfolks.com/music/concerts/">Concert Reviews</a></li>
	</ul>
</li>
	<li id="menu-item-98532" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98532 menu-item-category-1787"><a href="https://www.theyoungfolks.com/music/music-news/">Music News</a></li>
	<li id="menu-item-98531" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98531 menu-item-category-1788"><a href="https://www.theyoungfolks.com/music/music-features/">Music Features</a></li>
	<li id="menu-item-98530" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98530 menu-item-category-11890"><a href="https://www.theyoungfolks.com/music/from-the-record-crate/">From the Record Crate</a></li>
</ul>
</li>
<li id="menu-item-98534" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98534 menu-item-category-7"><a href="https://www.theyoungfolks.com/television/"><span><i class="fa fa-plus"></i></span>Television</a>
<ul class="sub-menu">
	<li id="menu-item-98537" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98537 menu-item-category-1793"><a href="https://www.theyoungfolks.com/television/tv-reviews/">TV Reviews</a></li>
	<li id="menu-item-98536" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98536 menu-item-category-1794"><a href="https://www.theyoungfolks.com/television/tv-news-television/">TV News</a></li>
	<li id="menu-item-98535" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98535 menu-item-category-1795"><a href="https://www.theyoungfolks.com/television/tv-features/">TV Features</a></li>
</ul>
</li>
<li id="menu-item-98541" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-98541 menu-item-category-13"><a href="https://www.theyoungfolks.com/video-games/"><span><i class="fa fa-plus"></i></span>Video Games</a>
<ul class="sub-menu">
	<li id="menu-item-98544" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98544 menu-item-category-1797"><a href="https://www.theyoungfolks.com/video-games/video-game-reviews/">Video Game Reviews</a></li>
	<li id="menu-item-98542" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98542 menu-item-category-1798"><a href="https://www.theyoungfolks.com/video-games/gaming-news/">Gaming News</a></li>
	<li id="menu-item-98543" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98543 menu-item-category-1799"><a href="https://www.theyoungfolks.com/video-games/video-game-features/">Video Game Features</a></li>
</ul>
</li>
<li id="menu-item-146715" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-146715 menu-item-category-3836"><a href="https://www.theyoungfolks.com/interviews/">Interviews</a></li>
<li id="menu-item-98538" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98538 menu-item-category-259"><a title="Lists" href="https://www.theyoungfolks.com/top-10-2/">Lists</a></li>
<li id="menu-item-98522" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98522 menu-item-category-1789"><a href="https://www.theyoungfolks.com/giveaways/">Giveaways</a></li>
</ul>															<div class="social-links">
										<a href="https://twitter.com/theyoungfolks" class="twitter icon-1x" target="_blank"><i class="fa fa-twitter"></i></a>
				<a href="https://www.instagram.com/theyoungfolks/" class="instagram icon-1x" target="_blank"><i class="fa fa-instagram"></i></a>
									<a href="https://www.youtube.com/c/theyoungfolks" class="youtube icon-1x" target="_blank"><i class="fa fa-youtube"></i></a>
			<a href="https://play.spotify.com/user/tyfofficial" class="spotify icon-1x" target="_blank"><i class="fa fa-spotify"></i></a>
					<a href="https://feeds.feedburner.com/TheYoungFolks" class="rss icon-1x" target="_blank"><i class="fa fa-rss"></i></a>
							</div>
					<div class="menu-footer">
											</div>
				</div>
			</div>
		</nav>
		<!-- End Mobile Menu -->
	
	<!-- Start Content Container -->
	<section id="content-container">
		<!-- Start Content Click Capture -->
		<div class="click-capture"></div>
		<!-- End Content Click Capture -->
		<!-- Start Fixed Header -->
<div class="subheader fixed show-for-large light">
			<div class="row full-width-row">
			<div class="medium-8 columns logo">
				<div>
										<a href="https://www.theyoungfolks.com/" class="logolink">
						<img src="/wp-content/uploads/2017/02/2017-logo-21.png" class="logoimg" alt="The Young Folks"/>
					</a>
					<span class="page-title" id="page-title">Album Review: Wolf Alice &#8211; “Blue Weekend”</span>
				</div>
			</div>
			<div class="medium-4 columns">
				 		<aside class="share-article-vertical hide-on-print ">
		<h6>0<span>Shares</span></h6>

				<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F161720%2Falbum-review-wolf-alice-blue-weekend%2F" class="facebook social"><i class="fa fa-facebook"></i><span>0</span></a>
						<a href="https://twitter.com/intent/tweet?text=Album+Review%3A+Wolf+Alice+%E2%80%93+%E2%80%9CBlue+Weekend%E2%80%9D&url=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F161720%2Falbum-review-wolf-alice-blue-weekend%2F&via=theyoungfolks" class="twitter social "><i class="fa fa-twitter"></i><span>0</span></a>
										<a href="https://www.linkedin.com/cws/share?url=https://www.theyoungfolks.com/music/161720/album-review-wolf-alice-blue-weekend/" class="linkedin social"><i class="fa fa-linkedin"></i><span>0</span></a>
						<a href="whatsapp://send?text=Album+Review%3A+Wolf+Alice+%E2%80%93+%E2%80%9CBlue+Weekend%E2%80%9D" class="whatsapp social" data-href="https://www.theyoungfolks.com/music/161720/album-review-wolf-alice-blue-weekend/" data-action="share/whatsapp/share"><i class="fa fa-whatsapp"></i><span><i class="fa fa-whatsapp"></i></span></a>
			</aside>
				</div>
							<span class="progress"></span>
					</div>
		
	</div>
<!-- End Fixed Header -->
<!-- Start Sub Header -->
<div class="subheader show-for-large light ">
	<div class="row full-width-row">
		<div class="small-12 medium-6 large-7 columns">
			<nav class="subheader-menu">
				<ul id="menu-home" class="sf-menu"><li id="menu-item-12558" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-12558"><a href="https://www.theyoungfolks.com/">Home</a></li>
<li id="menu-item-146692" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-146692"><a href="https://www.theyoungfolks.com/about/">About The Young Folks</a></li>
<li id="menu-item-12562" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12562"><a href="https://www.theyoungfolks.com/write/">Write for The Young Folks</a></li>
<li id="menu-item-12561" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12561"><a href="https://www.theyoungfolks.com/review-policy/">Advertising &#038; Promotions</a></li>
<li id="menu-item-63212" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63212"><a href="https://www.theyoungfolks.com/review-policy/general-comment-policy/">TYF Comment Policy</a></li>
</ul>			</nav>
		</div>
		<div class="small-12 medium-6 large-5 columns text-right">
			<ul class="sf-menu right-menu">
					<li class="menu-item-has-children">
		<a href="#">Follow Us</a>
		<ul class="sub-menu">
												<li><a href="https://twitter.com/theyoungfolks" class="twitter icon-1x" target="_blank"><i class="fa fa-twitter"></i> Twitter</a></li>
												<li><a href="https://www.instagram.com/theyoungfolks/" class="instagram icon-1x" target="_blank"><i class="fa fa-instagram"></i> Instagram</a></li>
																											<li><a href="https://www.youtube.com/c/theyoungfolks" class="youtube icon-1x" target="_blank"><i class="fa fa-youtube"></i> Youtube</a></li>
									<li><a href="https://play.spotify.com/user/tyfofficial" class="spotify icon-1x" target="_blank"><i class="fa fa-spotify"></i> Spotify</a></li>
															<li><a href="https://feeds.feedburner.com/TheYoungFolks" class="rss icon-1x" target="_blank"><i class="fa fa-rss"></i> RSS</a></li>
									<li><a href="https://www.twitch.tv/the_young_folks" class="twitch icon-1x" target="_blank"><i class="fa fa-twitch"></i> Twitch.tv</a></li>
					</ul>
	</li>
									<li>	<div class="quick_search">
		<a href="#" class="quick_toggle"></a>
		<svg version="1.1" class="quick_search_icon" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="20px" height="20px" viewBox="0 -1 20 18" xml:space="preserve">
			<path d="M18.96,16.896l-4.973-4.926c1.02-1.255,1.633-2.846,1.633-4.578c0-4.035-3.312-7.317-7.385-7.317S0.849,3.358,0.849,7.393
				c0,4.033,3.313,7.316,7.386,7.316c1.66,0,3.188-0.552,4.422-1.471l4.998,4.95c0.181,0.179,0.416,0.268,0.652,0.268
				c0.235,0,0.472-0.089,0.652-0.268C19.32,17.832,19.32,17.253,18.96,16.896z M2.693,7.393c0-3.027,2.485-5.489,5.542-5.489
				c3.054,0,5.541,2.462,5.541,5.489c0,3.026-2.486,5.489-5.541,5.489C5.179,12.882,2.693,10.419,2.693,7.393z"/>
		</svg>
		<!-- Start SearchForm -->
<form method="get" class="searchform" role="search" action="https://www.theyoungfolks.com/">
    <fieldset>
    	<input name="s" type="text" placeholder="Search" class="s">
    	<input type="submit" value="Search">
    </fieldset>
</form>
<!-- End SearchForm -->	</div>
	
</li>			</ul>
		</div>
	</div>
</div>
<!-- End Sub Header -->
<!-- Start Header -->
<header class="header style3  light" role="banner">
	<div class="row">
		<div class="small-2 columns text-left mobile-icon-holder">
			<a href="#" data-target="open-menu" class="mobile-toggle"><i class="fa fa-bars"></i></a>
		</div>
		<div class="small-8 large-12 columns logo">
			<div id="menu_width">
								<a href="https://www.theyoungfolks.com/" class="logolink">
					<img src="/wp-content/uploads/2017/02/2017-logo-21.png" class="logoimg" alt="The Young Folks"/>
				</a>
				<nav class="menu-holder">
										  <ul id="menu-main-nav-categories" class="sf-menu style3"><li id="menu-item-12523" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12523 menu-item-category-3"><a title="Movies" href="https://www.theyoungfolks.com/film/">Movies</a>


<ul class="sub-menu ">
	<li id="menu-item-12536" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12536 menu-item-category-1780"><a href="https://www.theyoungfolks.com/film/movie-reviews/">Movie Reviews</a></li>
	<li id="menu-item-12535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12535 menu-item-category-1782"><a href="https://www.theyoungfolks.com/film/movie-news/">Movie News</a></li>
	<li id="menu-item-12534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12534 menu-item-category-1783"><a title="Movie Features" href="https://www.theyoungfolks.com/film/movie-features/">Movie Features</a></li>
	<li id="menu-item-12537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12537 menu-item-category-1450"><a href="https://www.theyoungfolks.com/film/the-film-canon/">The Film Canon</a>
	<ul class="sub-menu ">
		<li id="menu-item-12807" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12807"><a title="TFC Index" href="https://www.theyoungfolks.com/the-film-canon/">TFC Index</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-12522" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12522 menu-item-category-6"><a href="https://www.theyoungfolks.com/books/">Books</a>


<ul class="sub-menu ">
	<li id="menu-item-12532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12532 menu-item-category-1781"><a href="https://www.theyoungfolks.com/books/book-reviews/">Book Reviews</a>
	<ul class="sub-menu ">
		<li id="menu-item-12899" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12899 menu-item-category-1925"><a href="https://www.theyoungfolks.com/books/book-reviews/audiobook-reviews/">Audiobook Reviews</a></li>
	</ul>
</li>
	<li id="menu-item-12530" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12530 menu-item-category-1785"><a href="https://www.theyoungfolks.com/books/book-features/">Book Features</a></li>
	<li id="menu-item-12531" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12531 menu-item-category-1784"><a href="https://www.theyoungfolks.com/books/book-news/">Book News</a></li>
	<li id="menu-item-54742" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54742 menu-item-category-14026"><a href="https://www.theyoungfolks.com/books/comics/">Comics &#038; Graphic Novels</a></li>
</ul>
</li>
<li id="menu-item-12525" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-12525 menu-item-category-4"><a href="https://www.theyoungfolks.com/music/">Music</a>


<ul class="sub-menu ">
	<li id="menu-item-12545" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12545 menu-item-category-1786"><a href="https://www.theyoungfolks.com/music/music-reviews/">Music Reviews</a></li>
	<li id="menu-item-12542" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12542 menu-item-category-5"><a href="https://www.theyoungfolks.com/music/concerts/">Concert Reviews</a></li>
	<li id="menu-item-12544" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12544 menu-item-category-1787"><a href="https://www.theyoungfolks.com/music/music-news/">Music News</a></li>
	<li id="menu-item-12543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12543 menu-item-category-1788"><a href="https://www.theyoungfolks.com/music/music-features/">Music Features</a></li>
	<li id="menu-item-43919" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-43919 menu-item-category-11890"><a href="https://www.theyoungfolks.com/music/from-the-record-crate/">From the Record Crate</a>
	<ul class="sub-menu ">
		<li id="menu-item-43920" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43920"><a title="FtRC Index" href="https://www.theyoungfolks.com/from-the-record-crate/">FtRC Index</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-12526" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12526 menu-item-category-7"><a href="https://www.theyoungfolks.com/television/">Television</a>


<ul class="sub-menu ">
	<li id="menu-item-12548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12548 menu-item-category-1793"><a href="https://www.theyoungfolks.com/television/tv-reviews/">TV Reviews</a></li>
	<li id="menu-item-12547" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12547 menu-item-category-1794"><a href="https://www.theyoungfolks.com/television/tv-news-television/">TV News</a></li>
	<li id="menu-item-12546" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12546 menu-item-category-1795"><a href="https://www.theyoungfolks.com/television/tv-features/">TV Features</a></li>
</ul>
</li>
<li id="menu-item-12529" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12529 menu-item-category-13"><a href="https://www.theyoungfolks.com/video-games/">Video Games</a>


<ul class="sub-menu ">
	<li id="menu-item-12554" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12554 menu-item-category-1797"><a href="https://www.theyoungfolks.com/video-games/video-game-reviews/">Video Game Reviews</a></li>
	<li id="menu-item-12552" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12552 menu-item-category-1798"><a href="https://www.theyoungfolks.com/video-games/gaming-news/">Gaming News</a></li>
	<li id="menu-item-12553" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12553 menu-item-category-1799"><a href="https://www.theyoungfolks.com/video-games/video-game-features/">Video Game Features</a></li>
</ul>
</li>
<li id="menu-item-146714" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-146714 menu-item-category-3836"><a href="https://www.theyoungfolks.com/interviews/">Interviews</a></li>
<li id="menu-item-12527" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12527 menu-item-category-259"><a title="Lists" href="https://www.theyoungfolks.com/top-10-2/">Lists</a></li>
<li id="menu-item-12549" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12549 menu-item-category-1796"><a href="https://www.theyoungfolks.com/tyf-column/editorials/">More</a>


<ul class="sub-menu ">
	<li id="menu-item-146712" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-146712 menu-item-category-1796"><a href="https://www.theyoungfolks.com/tyf-column/editorials/">Editorials</a></li>
	<li id="menu-item-24973" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24973 menu-item-category-6411"><a href="https://www.theyoungfolks.com/tyf-media/tyf-vlog/">Videos</a></li>
	<li id="menu-item-146713" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-146713 menu-item-category-1789"><a href="https://www.theyoungfolks.com/giveaways/">Giveaways</a></li>
</ul>
</li>
</ul>																			</nav>
			</div>
		</div>
		<div class="small-2 columns text-right mobile-share-holder">
			<div>
				<div class="quick_search">
		<a href="#" class="quick_toggle"></a>
		<svg version="1.1" class="quick_search_icon" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="20px" height="20px" viewBox="0 -1 20 18" xml:space="preserve">
			<path d="M18.96,16.896l-4.973-4.926c1.02-1.255,1.633-2.846,1.633-4.578c0-4.035-3.312-7.317-7.385-7.317S0.849,3.358,0.849,7.393
				c0,4.033,3.313,7.316,7.386,7.316c1.66,0,3.188-0.552,4.422-1.471l4.998,4.95c0.181,0.179,0.416,0.268,0.652,0.268
				c0.235,0,0.472-0.089,0.652-0.268C19.32,17.832,19.32,17.253,18.96,16.896z M2.693,7.393c0-3.027,2.485-5.489,5.542-5.489
				c3.054,0,5.541,2.462,5.541,5.489c0,3.026-2.486,5.489-5.541,5.489C5.179,12.882,2.693,10.419,2.693,7.393z"/>
		</svg>
		<!-- Start SearchForm -->
<form method="get" class="searchform" role="search" action="https://www.theyoungfolks.com/">
    <fieldset>
    	<input name="s" type="text" placeholder="Search" class="s">
    	<input type="submit" value="Search">
    </fieldset>
</form>
<!-- End SearchForm -->	</div>
	
			</div>
		</div>
	</div>
</header>
<!-- End Header -->		
		<div role="main" class=""><div id="infinite-article" data-infinite="on" class="on">
			<div class="row post-detail-row top-padding">
	<div class="small-12 medium-8 columns">

	  <article itemscope itemtype="http://schema.org/Article" class="post blog-post post-161720 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-reviews tag-blue-weekend tag-wolf-alice" id="post-161720" role="article" data-id="161720" data-url="https://www.theyoungfolks.com/music/161720/album-review-wolf-alice-blue-weekend/">
	  	<header class="post-title entry-header">
	  		<a href="https://www.theyoungfolks.com/music/music-reviews/" class="single_category_title category-link-1786" title="Music Reviews">Music Reviews</a>	  		<h1 class="entry-title" itemprop="name headline">Album Review: Wolf Alice &#8211; “Blue Weekend”</h1>	  			<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/brilockhart/" title="Posts by Bri Lockhart" rel="author">Bri Lockhart</a></strong>
		<time class="date published time" datetime="2022-01-01T09:27:00-05:00" itemprop="datePublished" content="2022-01-01T09:27:00-05:00">January 1, 2022</time>
		<meta itemprop="dateModified" class="date updated" content="2021-12-31T21:28:50-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2021/12/61TQ8uEUo6L._SL1500_.jpg">
		  <meta itemprop="width" content="1500">
		  <meta itemprop="height" content="1500">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/161720/album-review-wolf-alice-blue-weekend/">
							</aside>
		  	</header>
	  		  	<figure class="post-gallery">
	  		<img width="770" height="770" data-original="https://www.theyoungfolks.com/wp-content/uploads/2021/12/61TQ8uEUo6L._SL1500_-770x770.jpg" class="attachment-goodlife-post-style1 size-goodlife-post-style1 wp-post-image" alt="" loading="lazy" data-original-set="https://www.theyoungfolks.com/wp-content/uploads/2021/12/61TQ8uEUo6L._SL1500_-770x770.jpg 770w, https://www.theyoungfolks.com/wp-content/uploads/2021/12/61TQ8uEUo6L._SL1500_-900x900.jpg 900w, https://www.theyoungfolks.com/wp-content/uploads/2021/12/61TQ8uEUo6L._SL1500_-150x150.jpg 150w, https://www.theyoungfolks.com/wp-content/uploads/2021/12/61TQ8uEUo6L._SL1500_-768x768.jpg 768w, https://www.theyoungfolks.com/wp-content/uploads/2021/12/61TQ8uEUo6L._SL1500_-24x24.jpg 24w, https://www.theyoungfolks.com/wp-content/uploads/2021/12/61TQ8uEUo6L._SL1500_-48x48.jpg 48w, https://www.theyoungfolks.com/wp-content/uploads/2021/12/61TQ8uEUo6L._SL1500_-96x96.jpg 96w, https://www.theyoungfolks.com/wp-content/uploads/2021/12/61TQ8uEUo6L._SL1500_-300x300.jpg 300w, https://www.theyoungfolks.com/wp-content/uploads/2021/12/61TQ8uEUo6L._SL1500_.jpg 1500w" sizes="(max-width: 770px) 100vw, 770px" />	  			  	</figure>
	  		  	<div class="share-container">
		  	 		<aside class="share-article-vertical hide-on-print fixed-me show-for-medium">
		<h6>0<span>Shares</span></h6>

				<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F161720%2Falbum-review-wolf-alice-blue-weekend%2F" class="facebook social"><i class="fa fa-facebook"></i><span>0</span></a>
						<a href="https://twitter.com/intent/tweet?text=Album+Review%3A+Wolf+Alice+%E2%80%93+%E2%80%9CBlue+Weekend%E2%80%9D&url=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F161720%2Falbum-review-wolf-alice-blue-weekend%2F&via=theyoungfolks" class="twitter social "><i class="fa fa-twitter"></i><span>0</span></a>
										<a href="https://www.linkedin.com/cws/share?url=https://www.theyoungfolks.com/music/161720/album-review-wolf-alice-blue-weekend/" class="linkedin social"><i class="fa fa-linkedin"></i><span>0</span></a>
						<a href="whatsapp://send?text=Album+Review%3A+Wolf+Alice+%E2%80%93+%E2%80%9CBlue+Weekend%E2%80%9D" class="whatsapp social" data-href="https://www.theyoungfolks.com/music/161720/album-review-wolf-alice-blue-weekend/" data-action="share/whatsapp/share"><i class="fa fa-whatsapp"></i><span><i class="fa fa-whatsapp"></i></span></a>
			</aside>
				  <div class="post-content-container">
					<div class="post-content entry-content cf">
									    	
<p>Over the course of their eleven years, London-born alt rock band Wolf Alice has proven that they’re a band to watch. Their 2015 debut album, <em>My Love Is Cool</em>, was welcomed by fans and critics who celebrated the band’s potential, drawing comparisons to the 1975, Radiohead, and ABBA. Their sophomore effort, 2017’s <em>Visions of a Life</em>, was met with near universal acclaim, earning the Mercury Prize and NME’s label of “Best band in Britain? 100 percent.” Their third album, 2021’s <em>Blue Weekend</em>, takes what Wolf Alice has built over their past two studio albums and raises the bar further, giving fans even more emotion, more clarity, and more confidence.&nbsp;</p>



<figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<div class="flex-video widescreen youtube"><span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="1170" height="659" src="https://www.youtube.com/embed/0xjD7KbxgGQ?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent&#038;showinfo=0&#038;rel=0&#038;modestbranding=1" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span></div>
</div></figure>



<p>The album is framed by “The Beach” and “The Beach II,” two tracks that share little in common beyond their names. Evoking Shakespeare’s <em>Macbeth</em> with a haunting melody, album opener “The Beach&#8221; slowly crescendos, introducing the breakup theme that loosely runs throughout the album with a strong sense of foreboding. The sweeping, gentle guitar and synth of “The Beach II” serve as the final moment of catharsis for the album, closing with a sense of calm contentment amongst a weirdly fitting cacophony.</p><div class="s39wrcOS" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><center><p style="color:gray; font-size: 10px;">Advertisement</p><a href="https://candlewick.com/r/revolution-yf">
  <img src="https://www.theyoungfolks.com/wp-content/uploads/2021/12/Revolu_YoungFOlks_300x250.gif" alt="Advertisement">
</a></center>
</div>



<p>Within the frame, there’s plenty to be found that shows Wolf Alice’s range, as well as the versatility of lead singer Ellie Rowsell’s vocals. From the softer, pretty performances of the folksy guitar-driven “Safe from Heartbreak (if you never fall in love)” and the Fleetwood Mac-esque sounds of “How Can I Make It Ok?” to the high energy, punk-inspired “Play the Greatest Hits” (a companion to <em>Visions of a Life</em>’s “Yuk Foo”), <em>Blue Weekend</em> offers the listener plenty of dimension. Pitting breakup drama against a commentary on fame, the band’s confidence shines through their lyrics, with examples like “I am what I am and I’m good at it/And if you don’t like me, well that isn’t fucking relevant” in the hard rock-tinged “Smile.” Lead single “The Last Man on Earth” unassumingly delivers a punch with its commentary on the arrogance and passive tendencies of man, moving from a quiet, calm beginning that works its way up to a piano-heavy rock sound.&nbsp;</p>



<figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<div class="flex-video widescreen youtube"><span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="1170" height="659" src="https://www.youtube.com/embed/bhWAx67iGyc?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent&#038;showinfo=0&#038;rel=0&#038;modestbranding=1" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span></div>
</div></figure>



<p><em>Blue Weekend</em> is a rollercoaster of emotions, pulling the listener through a history of relationships of every kind–romantic, to fame, to the rest of the world–taking turns between languishing in and relishing the experiences. There’s plenty of their signature combination of shoegaze, grunge, and indie rock, now combined with touches of pop and classic rock. The turns taken on the album may surprise, but they don’t shock; Wolf Alice has perfectly melded the different styles of music, crafting an album more akin to an evocative, go-with-the-flow collection of short stories rather than a single linear tale.&nbsp;</p>



<p>With every release, Wolf Alice builds up expectations, and every ensuing release–including <em>Blue Weekend</em>–more than meets those expectations, promising more great things to come in the future. <em>Blue Weekend</em> takes what makes Wolf Alice great and sharpens it into a tighter, more focused piece that explores these relationships, evoking the immediacy of emotion and the wisdom of distance depending on the track. This newfound focus and confidence brings Wolf Alice’s music down to Earth without losing that signature edgy shoegaze sound, maturing their sound in the best possible way.&nbsp;</p>
<center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Bottom Post Link Ads -->
<ins class="adsbygoogle"
     style="display: block;height: 100px;overflow: hidden;"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="4109762806"
     data-ad-format="link"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>			    				    	
					</div>
				</div>
			</div>
					<aside class="post-review style3" itemscope itemtype="http://schema.org/Review">
			<div class="post-review-content">
				<h6 itemprop="itemReviewed" itemscope itemtype="http://schema.org/Thing"><span itemprop="name">Wolf Alice - &quot;Blue Weekend&quot;</span></h6>				<ul>
									
					<li>
						<div class="row">
							<div class="small-12 medium-9 columns">Review rating</div>
							<div class="small-12 medium-3 columns show-for-medium">9</div>
						</div>
						<div class="progress">
							<span data-width="90"></span>
						</div>
					</li>
					
		
								</ul>
			</div>
			<div class="post-review-content">
				<div class="row">
					<div class="small-12 medium-9 columns">
						<div class="row">
							<div class="small-12  medium-6 columns comment_section">
								<span class="post_comment">The Good</span>
															</div>
							<div class="small-12  medium-6 columns comment_section">
								<span class="post_comment">The Bad</span>
															</div>
						</div>
					</div>
					<div class="small-12  medium-3 columns">
						<figure class="average" itemprop="reviewRating" itemscope itemtype="http://schema.org/Rating"><span itemprop="ratingValue">9</span><span class="hide" itemprop="bestRating">10</span></figure>
					</div>
				</div>
			</div>
		</aside>
					<footer class="article-tags entry-footer">
			<div>
		<span class="tags-title">Tags</span> 
		<a href="https://www.theyoungfolks.com/tag/blue-weekend/" title="" class="tag-link">blue weekend</a> <a href="https://www.theyoungfolks.com/tag/wolf-alice/" title="" class="tag-link">Wolf Alice</a>	</div>
</footer>
 
<section class="post-author">
		<img width="164" height="146" src="https://www.theyoungfolks.com/wp-content/uploads/2014/10/brianna_lockhart.jpg" class="avatar avatar-164 photo" alt="" loading="lazy" srcset="https://www.theyoungfolks.com/wp-content/uploads/2014/10/brianna_lockhart.jpg 527w, https://www.theyoungfolks.com/wp-content/uploads/2014/10/brianna_lockhart-300x266.jpg 300w" sizes="(max-width: 164px) 100vw, 164px" />	<div class="author-content">
		<h5><a href="https://www.theyoungfolks.com/author/brilockhart/">Bri Lockhart</a></h5>
				<p>Bri is a 25-year-old born and raised in the swamps of Jersey. Just kidding, she lives at least twenty minutes from those swamps. She’s a publishing professional that moonlights as a writer. She enjoys going to concerts (anything from Rooney to Springsteen to NKOTBSB), roadtripping, and complaining that she truly belongs in the 1950’s, the 1920′s, or the 1980′s depending on her mood. She definitely owns more books than she should and reads every chance she gets. If you stop hearing from her, it’s because the book piles have fallen over and smothered her to death in the night. You can contact her at bri@theyoungfolks.com.
Twitter: @bri_lockhart</p>
							<a href="http://bri_lockhart" class="twitter"><i class="fa fa-twitter"></i></a>
							</div>
	</section>
 		<aside class="share-article hide-on-print ">
		<div class="row">
			<div class="small-12 medium-5 columns">
				<h6>Share This</h6>
			</div>
			<div class="small-12 medium-7 columns small-only-text-center text-right">
				<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F161720%2Falbum-review-wolf-alice-blue-weekend%2F" class="facebook social"><i class="fa fa-facebook"></i><span>0</span></a>
						<a href="https://twitter.com/intent/tweet?text=Album+Review%3A+Wolf+Alice+%E2%80%93+%E2%80%9CBlue+Weekend%E2%80%9D&url=https%3A%2F%2Fwww.theyoungfolks.com%2Fmusic%2F161720%2Falbum-review-wolf-alice-blue-weekend%2F&via=theyoungfolks" class="twitter social "><i class="fa fa-twitter"></i><span>0</span></a>
										<a href="https://www.linkedin.com/cws/share?url=https://www.theyoungfolks.com/music/161720/album-review-wolf-alice-blue-weekend/" class="linkedin social"><i class="fa fa-linkedin"></i><span>0</span></a>
						<a href="whatsapp://send?text=Album+Review%3A+Wolf+Alice+%E2%80%93+%E2%80%9CBlue+Weekend%E2%80%9D" class="whatsapp social" data-href="https://www.theyoungfolks.com/music/161720/album-review-wolf-alice-blue-weekend/" data-action="share/whatsapp/share"><i class="fa fa-whatsapp"></i></a>
					</div>
	</aside>
	 
			<div class="row post-navi hide-on-print no-padding">
				<div class="small-12 medium-6 columns">
					<span>Previous Article</span><a href="https://www.theyoungfolks.com/review/161712/encanto-review/" title="‘Encanto’ review: Magic isn’t the true magic of Disney’s family musical comedy">‘Encanto’ review: Magic isn’t the true magic of Disney’s family musical comedy</a>				</div>
				<div class="small-12 medium-6 columns">
					<span>No Newer Articles</span>				</div>
			</div>
			  </article>

					
<div id="disqus_thread"></div>
			</div>
	<aside class="sidebar small-12 medium-4 columns" role="complementary">
	<div class="sidebar_inner fixed-me">
		<div id="thb_singlead_widget-10" class="widget cf widget_singlead"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div id="thb_latestimages_widget-1" class="widget cf widget_latestimages"><strong>Latest Posts</strong><ul><li itemscope itemtype="http://schema.org/Article" class="post listing post-161720 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-reviews tag-blue-weekend tag-wolf-alice" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/music/161720/album-review-wolf-alice-blue-weekend/" rel="bookmark" title="Album Review: Wolf Alice &#8211; “Blue Weekend”">
			<img width="80" height="75" data-original="https://www.theyoungfolks.com/wp-content/uploads/2021/12/61TQ8uEUo6L._SL1500_-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" data-original-set="https://www.theyoungfolks.com/wp-content/uploads/2021/12/61TQ8uEUo6L._SL1500_-80x75.jpg 80w, https://www.theyoungfolks.com/wp-content/uploads/2021/12/61TQ8uEUo6L._SL1500_-24x24.jpg 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-reviews/" class="single_category_title category-link-1786" title="Music Reviews">Music Reviews</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/161720/album-review-wolf-alice-blue-weekend/" title="Album Review: Wolf Alice &#8211; “Blue Weekend”">Album Review: Wolf Alice &#8211; “Blue Weekend”</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/brilockhart/" title="Posts by Bri Lockhart" rel="author">Bri Lockhart</a></strong>
		<time class="date published time" datetime="2022-01-01T09:27:00-05:00" itemprop="datePublished" content="2022-01-01T09:27:00-05:00">January 1, 2022</time>
		<meta itemprop="dateModified" class="date updated" content="2021-12-31T21:28:50-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2021/12/61TQ8uEUo6L._SL1500_.jpg">
		  <meta itemprop="width" content="1500">
		  <meta itemprop="height" content="1500">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/161720/album-review-wolf-alice-blue-weekend/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-161712 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-film category-movie-reviews category-review tag-disney tag-encanto tag-featured tag-film-2 tag-john-leguizamo tag-lin-manuel-miranda tag-movie-review tag-movies tag-review-2 tag-stephanie-beatriz" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/review/161712/encanto-review/" rel="bookmark" title="‘Encanto’ review: Magic isn’t the true magic of Disney’s family musical comedy">
			<img width="80" height="75" data-original="https://www.theyoungfolks.com/wp-content/uploads/2021/12/ENCANTO_ONLINE_USE_fullcomp_115_20_6k_709Film.0021-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="encanto" loading="lazy" data-original-set="https://www.theyoungfolks.com/wp-content/uploads/2021/12/ENCANTO_ONLINE_USE_fullcomp_115_20_6k_709Film.0021-80x75.jpg 80w, https://www.theyoungfolks.com/wp-content/uploads/2021/12/ENCANTO_ONLINE_USE_fullcomp_115_20_6k_709Film.0021-24x24.jpg 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/film/movie-reviews/" class="single_category_title category-link-1780" title="Movie Reviews">Movie Reviews</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/161712/encanto-review/" title="‘Encanto’ review: Magic isn’t the true magic of Disney’s family musical comedy">‘Encanto’ review: Magic isn’t the true magic of Disney’s family musical comedy</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/agonzalez/" title="Posts by Adonis Gonzalez" rel="author">Adonis Gonzalez</a></strong>
		<time class="date published time" datetime="2021-12-31T14:58:46-05:00" itemprop="datePublished" content="2021-12-31T14:58:46-05:00">December 31, 2021</time>
		<meta itemprop="dateModified" class="date updated" content="2021-12-31T14:58:47-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2021/12/ENCANTO_ONLINE_USE_fullcomp_115_20_6k_709Film.0021.jpg">
		  <meta itemprop="width" content="1400">
		  <meta itemprop="height" content="788">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/161712/encanto-review/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-161342 type-post status-publish format-standard has-post-thumbnail hentry category-book-features category-books category-featured tag-30-things-i-love-about-me tag-a-l-graziadei tag-african-town tag-aint-burned-all-bright tag-akshaya-raman tag-ashes-of-gold tag-charles-waters tag-echoes-and-empires tag-emma-lord tag-goliath tag-icebreaker tag-irene-latham tag-j-elle tag-january-new-releases tag-jason-griffin tag-jason-reynolds tag-jennieke-cohen tag-jodi-meadows tag-kathryn-williams tag-kerri-maher tag-lois-ann-yamanaka tag-mimi-matthews tag-morgan-rhodes tag-my-fine-fellow tag-radhika-sanghani tag-snow-angel-sand-angel tag-the-ivory-key tag-the-lock-eater tag-the-nightrender tag-the-paris-bookseller tag-the-siren-of-sussex tag-the-storyteller tag-tochi-onyebuchi tag-when-you-get-the-chance tag-zach-loran-clark" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/books/161342/december-2021-new-book-releases-thrilling-and-riveting-reads-for-winter-2/" rel="bookmark" title="January 2022 New Book Releases: Start the New Year">
			<img width="80" height="75" data-original="https://www.theyoungfolks.com/wp-content/uploads/2021/12/January-new-releases-80x75.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" data-original-set="https://www.theyoungfolks.com/wp-content/uploads/2021/12/January-new-releases-80x75.png 80w, https://www.theyoungfolks.com/wp-content/uploads/2021/12/January-new-releases-24x24.png 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/books/book-features/" class="single_category_title category-link-1785" title="Book Features">Book Features</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/books/161342/december-2021-new-book-releases-thrilling-and-riveting-reads-for-winter-2/" title="January 2022 New Book Releases: Start the New Year">January 2022 New Book Releases: Start the New Year</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/brobinson/" title="Posts by Brianna Robinson" rel="author">Brianna Robinson</a></strong>
		<time class="date published time" datetime="2021-12-31T14:30:56-05:00" itemprop="datePublished" content="2021-12-31T14:30:56-05:00">December 31, 2021</time>
		<meta itemprop="dateModified" class="date updated" content="2021-12-31T14:30:57-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2021/12/January-new-releases.png">
		  <meta itemprop="width" content="1640">
		  <meta itemprop="height" content="924">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/books/161342/december-2021-new-book-releases-thrilling-and-riveting-reads-for-winter-2/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-161611 type-post status-publish format-standard has-post-thumbnail hentry category-best-of-list category-music category-music-features category-review tag-adele tag-arlo-parks tag-best-of-2021 tag-billie-eilish tag-black-country-new-road tag-black-midi tag-brandi-carlile tag-chvrches tag-clairo tag-cleo-sol tag-donny-montell tag-dry-cleaning tag-faye-webster tag-featured tag-floating-points tag-fred-again tag-genesis-owusu tag-girl-in-red tag-halsey tag-hayley-williams tag-janet-batch tag-japanese-breakfast tag-jazmine-sullivan tag-jpegmafia tag-julien-baker tag-kero-kero-bonito tag-laura-mvula tag-lil-nas-x tag-lorde tag-low tag-low-cut-connie tag-lucy-dacus tag-mach-hommy tag-madlib tag-magdalena-bay tag-mdou-moctar tag-olivia-rodrigo tag-parannoul tag-pharoah-sanders tag-pinkpanthress tag-porter-robinson tag-remi-wolf tag-self-esteem tag-serpentwithfeet tag-silk-sonic tag-snail-mail tag-squid tag-st-vincent tag-taylor-swift tag-the-war-on-drugs tag-tinashe tag-tyler-the-creator tag-wolf-alice" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/review/161611/50-best-albums-of-2021/" rel="bookmark" title="The 50 Best Albums of 2021">
			<img width="80" height="75" data-original="https://www.theyoungfolks.com/wp-content/uploads/2021/12/2021albumsgraphic-80x75.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" data-original-set="https://www.theyoungfolks.com/wp-content/uploads/2021/12/2021albumsgraphic-80x75.png 80w, https://www.theyoungfolks.com/wp-content/uploads/2021/12/2021albumsgraphic-24x24.png 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/161611/50-best-albums-of-2021/" title="The 50 Best Albums of 2021">The 50 Best Albums of 2021</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/tyfstaff/" title="Posts by TYF Staff" rel="author">TYF Staff</a></strong>
		<time class="date published time" datetime="2021-12-29T17:00:00-05:00" itemprop="datePublished" content="2021-12-29T17:00:00-05:00">December 29, 2021</time>
		<meta itemprop="dateModified" class="date updated" content="2021-12-29T17:44:41-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2021/12/2021albumsgraphic.png">
		  <meta itemprop="width" content="1640">
		  <meta itemprop="height" content="924">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/161611/50-best-albums-of-2021/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-161599 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-film category-movie-reviews category-review tag-featured tag-film-2 tag-kingsman tag-kingsmen tag-matthew-vaughn tag-movie-review tag-movies tag-ralph-fiennes tag-review-2 tag-rhys-ifans tag-the-kings-man" role="article">
		<figure class="post-gallery">
				<a href="https://www.theyoungfolks.com/review/161599/the-kings-man-review/" rel="bookmark" title="&#8216;The King&#8217;s Man&#8217; review: This unexpected prequel takes a more serious, historical turn for the franchise">
			<img width="80" height="75" data-original="https://www.theyoungfolks.com/wp-content/uploads/2021/12/image-80x75.webp" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="the king&#039;s man" loading="lazy" data-original-set="https://www.theyoungfolks.com/wp-content/uploads/2021/12/image-80x75.webp 80w, https://www.theyoungfolks.com/wp-content/uploads/2021/12/image-24x24.webp 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/film/movie-reviews/" class="single_category_title category-link-1780" title="Movie Reviews">Movie Reviews</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/161599/the-kings-man-review/" title="&#8216;The King&#8217;s Man&#8217; review: This unexpected prequel takes a more serious, historical turn for the franchise">&#8216;The King&#8217;s Man&#8217; review: This unexpected prequel takes a more serious, historical turn for the franchise</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author "><a href="https://www.theyoungfolks.com/author/cwoodroof/" title="Posts by Cory Woodroof" rel="author">Cory Woodroof</a></strong>
		<time class="date published time" datetime="2021-12-29T14:38:32-05:00" itemprop="datePublished" content="2021-12-29T14:38:32-05:00">December 29, 2021</time>
		<meta itemprop="dateModified" class="date updated" content="2021-12-29T14:38:33-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2021/12/image.webp">
		  <meta itemprop="width" content="1280">
		  <meta itemprop="height" content="720">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/161599/the-kings-man-review/">
							</aside>
				</div>
</li></ul></div><div id="thb_singlead_widget-4" class="widget cf widget_singlead"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div id="thb_viewedimages_widget-2" class="widget cf widget_viewedimages"><strong>Most Viewed<span class="thb_listing" data-type="views" data-count="5"><a href="#" data-time="7" class="active">WEEK</a><a href="#" data-time="30">MONTH</a><a href="#" data-time="365">ALL</a></span></strong><ul><li itemscope itemtype="http://schema.org/Article" class="post listing post-161479 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-film category-movie-reviews category-review tag-benedetta tag-charlotte-rampling tag-featured tag-paul-verhoeven tag-virginie-efira" role="article">
		<figure class="post-gallery">
					<span class="counts">1</span>
				<a href="https://www.theyoungfolks.com/review/161479/benedetta-review/" rel="bookmark" title="&#8216;Benedetta&#8217; review: A righteous, erotic exploration of sexuality and conviction">
			<img width="80" height="75" data-original="https://www.theyoungfolks.com/wp-content/uploads/2021/12/p20731810_i_h8_aa-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" data-original-set="https://www.theyoungfolks.com/wp-content/uploads/2021/12/p20731810_i_h8_aa-80x75.jpg 80w, https://www.theyoungfolks.com/wp-content/uploads/2021/12/p20731810_i_h8_aa-24x24.jpg 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/film/movie-reviews/" class="single_category_title category-link-1780" title="Movie Reviews">Movie Reviews</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/161479/benedetta-review/" title="&#8216;Benedetta&#8217; review: A righteous, erotic exploration of sexuality and conviction">&#8216;Benedetta&#8217; review: A righteous, erotic exploration of sexuality and conviction</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/kstoetzel/" title="Posts by Katey Stoetzel" rel="author">Katey Stoetzel</a></strong>
		<time class="date published time hide" datetime="2021-12-24T13:24:48-05:00" itemprop="datePublished" content="2021-12-24T13:24:48-05:00">December 24, 2021</time>
		<meta itemprop="dateModified" class="date updated" content="2021-12-26T12:56:39-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2021/12/p20731810_i_h8_aa-scaled.jpg">
		  <meta itemprop="width" content="2560">
		  <meta itemprop="height" content="1440">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/161479/benedetta-review/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-161521 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-review category-television category-top-10-2 category-tv-features tag-anime tag-best-of-2021 tag-blue-period tag-featured tag-fena-pirate-princess tag-fruits-basket tag-jujutsu-kaisen tag-my-hero-academia tag-top-list tag-tv tag-tv-list tag-yasuke" role="article">
		<figure class="post-gallery">
					<span class="counts">2</span>
				<a href="https://www.theyoungfolks.com/review/161521/the-25-best-anime-of-2021/" rel="bookmark" title="The 25 best anime of 2021">
			<img width="80" height="75" data-original="https://www.theyoungfolks.com/wp-content/uploads/2021/12/268390818_311085460940239_8793759699544860942_n-80x75.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" data-original-set="https://www.theyoungfolks.com/wp-content/uploads/2021/12/268390818_311085460940239_8793759699544860942_n-80x75.png 80w, https://www.theyoungfolks.com/wp-content/uploads/2021/12/268390818_311085460940239_8793759699544860942_n-24x24.png 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/television/tv-features/" class="single_category_title category-link-1795" title="TV Features">TV Features</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/161521/the-25-best-anime-of-2021/" title="The 25 best anime of 2021">The 25 best anime of 2021</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/tyfstaff/" title="Posts by TYF Staff" rel="author">TYF Staff</a></strong>
		<time class="date published time hide" datetime="2021-12-28T16:45:00-05:00" itemprop="datePublished" content="2021-12-28T16:45:00-05:00">December 28, 2021</time>
		<meta itemprop="dateModified" class="date updated" content="2021-12-28T15:54:20-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2021/12/268390818_311085460940239_8793759699544860942_n.png">
		  <meta itemprop="width" content="830">
		  <meta itemprop="height" content="412">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/161521/the-25-best-anime-of-2021/">
							</aside>
				</div>
</li><li itemscope itemtype="http://schema.org/Article" class="post listing post-134278 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-music category-music-features tag-american-pie tag-bic-runga tag-blink-182 tag-dishwalla tag-semisonic tag-shades-apart tag-super-transatlantic tag-the-atomic-fireballs tag-third-eye-blind tag-tonic" role="article">
		<figure class="post-gallery">
					<span class="counts">3</span>
				<a href="https://www.theyoungfolks.com/music/134278/every-song-from-the-american-pie-soundtrack-ranked/" rel="bookmark" title="Every Song from the ‘American Pie’ Soundtrack, Ranked">
			<img width="80" height="75" data-original="https://www.theyoungfolks.com/wp-content/uploads/2019/07/american-pie-soundtrack-1-80x75.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" data-original-set="https://www.theyoungfolks.com/wp-content/uploads/2019/07/american-pie-soundtrack-1-80x75.jpg 80w, https://www.theyoungfolks.com/wp-content/uploads/2019/07/american-pie-soundtrack-1-24x24.jpg 24w" sizes="(max-width: 80px) 100vw, 80px" />		</a>
	</figure>
		<div class="listing-content">
					<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
				<header class="post-title entry-header">
			<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/134278/every-song-from-the-american-pie-soundtrack-ranked/" title="Every Song from the ‘American Pie’ Soundtrack, Ranked">Every Song from the ‘American Pie’ Soundtrack, Ranked</a></h6>		</header>
					<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/bthompson/" title="Posts by Brian Thompson" rel="author">Brian Thompson</a></strong>
		<time class="date published time hide" datetime="2019-07-09T07:00:01-04:00" itemprop="datePublished" content="2019-07-09T07:00:01-04:00">July 9, 2019</time>
		<meta itemprop="dateModified" class="date updated" content="2021-05-30T22:37:26-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2019/07/american-pie-soundtrack-1.jpg">
		  <meta itemprop="width" content="1423">
		  <meta itemprop="height" content="1411">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/134278/every-song-from-the-american-pie-soundtrack-ranked/">
							</aside>
				</div>
</li></ul></div><div id="thb_singlead_widget-7" class="widget cf widget_singlead"><iframe src="https://player.twitch.tv/?channel=gamingfrogtv" muted="true" autoplay="true" frameborder="0" allowfullscreen="false" scrolling="no" height="250" width="300"></iframe><a href="//www.twitch.tv/gamingfrogtv?tt_content=text_link&tt_medium=live_embed" target="_blank" style="padding:2px 0px 4px; display:block; width:300px; font-weight:normal; font-size:10px; text-decoration:underline;">Watch live video from GamingFrogTV on www.twitch.tv</a></div><div id="thb_singlead_widget-5" class="widget cf widget_singlead"><center><p style="color:gray; font-size: 10px;">Advertisement</p></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Content Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4885608075692739"
     data-ad-slot="8539962404"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div id="eu_cookie_law_widget-2" class="widget cf widget_eu_cookie_law_widget">
<div
	class="hide-on-button"
	data-hide-timeout="30"
	data-consent-expiration="180"
	id="eu-cookie-law"
>
	<form method="post">
		<input type="submit" value="Close and accept" class="accept" />
	</form>

	Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br />
To find out more, including how to control cookies, see here:
		<a href="https://www.theyoungfolks.com/review-policy/" rel="">
		Privacy Policy	</a>
</div>
</div>	</div>
</aside></div>
		<div class="row">
		<div class="small-12 columns">
			<!-- Start Related Posts -->
<aside class="related-posts cf hide-on-print">
	<h4 class="related-title">Related News</h4>
	<div class="row">
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-161611 type-post status-publish format-standard has-post-thumbnail hentry category-best-of-list category-music category-music-features category-review tag-adele tag-arlo-parks tag-best-of-2021 tag-billie-eilish tag-black-country-new-road tag-black-midi tag-brandi-carlile tag-chvrches tag-clairo tag-cleo-sol tag-donny-montell tag-dry-cleaning tag-faye-webster tag-featured tag-floating-points tag-fred-again tag-genesis-owusu tag-girl-in-red tag-halsey tag-hayley-williams tag-janet-batch tag-japanese-breakfast tag-jazmine-sullivan tag-jpegmafia tag-julien-baker tag-kero-kero-bonito tag-laura-mvula tag-lil-nas-x tag-lorde tag-low tag-low-cut-connie tag-lucy-dacus tag-mach-hommy tag-madlib tag-magdalena-bay tag-mdou-moctar tag-olivia-rodrigo tag-parannoul tag-pharoah-sanders tag-pinkpanthress tag-porter-robinson tag-remi-wolf tag-self-esteem tag-serpentwithfeet tag-silk-sonic tag-snail-mail tag-squid tag-st-vincent tag-taylor-swift tag-the-war-on-drugs tag-tinashe tag-tyler-the-creator tag-wolf-alice" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/review/161611/50-best-albums-of-2021/" rel="bookmark" title="The 50 Best Albums of 2021">
			<img width="570" height="300" data-original="https://www.theyoungfolks.com/wp-content/uploads/2021/12/2021albumsgraphic-570x300.png" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" loading="lazy" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/review/161611/50-best-albums-of-2021/" title="The 50 Best Albums of 2021">The 50 Best Albums of 2021</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/tyfstaff/" title="Posts by TYF Staff" rel="author">TYF Staff</a></strong>
		<time class="date published time hide" datetime="2021-12-29T17:00:00-05:00" itemprop="datePublished" content="2021-12-29T17:00:00-05:00">December 29, 2021</time>
		<meta itemprop="dateModified" class="date updated" content="2021-12-29T17:44:41-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2021/12/2021albumsgraphic.png">
		  <meta itemprop="width" content="1640">
		  <meta itemprop="height" content="924">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/review/161611/50-best-albums-of-2021/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-154415 type-post status-publish format-standard has-post-thumbnail hentry category-music category-music-features tag-boy tag-dear-seattle tag-elder-statesman tag-gospel-of-the-future tag-memory-driven tag-new-kingdoms tag-retriever tag-wolf-alice" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/154415/good-stuff-from-dear-seattle-retriever-wolf-alice-and-boy/" rel="bookmark" title="Good stuff from Dear Seattle, Retriever, Wolf Alice, and BOY">
			<img width="570" height="300" data-original="https://www.theyoungfolks.com/wp-content/uploads/2021/06/elder-statesman-purple-570x300.png" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" loading="lazy" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-features/" class="single_category_title category-link-1788" title="Music Features">Music Features</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/154415/good-stuff-from-dear-seattle-retriever-wolf-alice-and-boy/" title="Good stuff from Dear Seattle, Retriever, Wolf Alice, and BOY">Good stuff from Dear Seattle, Retriever, Wolf Alice, and BOY</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/rradic/" title="Posts by Randy Radic" rel="author">Randy Radic</a></strong>
		<time class="date published time hide" datetime="2021-06-14T10:01:00-04:00" itemprop="datePublished" content="2021-06-14T10:01:00-04:00">June 14, 2021</time>
		<meta itemprop="dateModified" class="date updated" content="2021-06-17T15:43:30-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2021/06/elder-statesman-purple.png">
		  <meta itemprop="width" content="1600">
		  <meta itemprop="height" content="900">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/154415/good-stuff-from-dear-seattle-retriever-wolf-alice-and-boy/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-114536 type-post status-publish format-standard has-post-thumbnail hentry category-best-of-2017 category-best-of-list category-music category-music-features category-top-10-2 tag-alt-j tag-alvvays tag-beck tag-best-of-2017 tag-big-thief tag-bobs-burgers tag-brockhampton tag-daniel-caesar tag-drake tag-dua-lipa tag-ed-sheeran tag-fever-ray tag-fleet-foxes tag-foster-the-people tag-haim tag-harry-styles tag-japanese-breakfast tag-jason-isbell tag-jay-z tag-jens-lekman tag-julien-baker tag-kelela tag-kendrick-lamar tag-kesha tag-khalid tag-lana-del-rey tag-laura-marling tag-lcd-soundsystem tag-lorde tag-mac-demarco tag-miguel tag-muna tag-paramore tag-phoebe-bridgers tag-phoenix tag-queens-of-stone-age tag-slowdive tag-st-vincent tag-sza tag-taylor-swift tag-the-magnetic-fields tag-the-mountain-goats tag-the-national tag-the-war-on-drugs tag-the-xx tag-thundercat tag-tyler-the-creator tag-vince-staples tag-waxahatchee tag-wolf-alice" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/114536/the-young-folks-top-50-albums-of-2017/" rel="bookmark" title="The Young Folks&#8217; Top 50 Albums of 2017">
			<img width="570" height="300" data-original="https://www.theyoungfolks.com/wp-content/uploads/2017/12/collage17-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" loading="lazy" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/best-of-list/best-of-2017/" class="single_category_title category-link-24933" title="Best of 2017">Best of 2017</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/114536/the-young-folks-top-50-albums-of-2017/" title="The Young Folks&#8217; Top 50 Albums of 2017">The Young Folks&#8217; Top 50 Albums of 2017</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/tyfstaff/" title="Posts by TYF Staff" rel="author">TYF Staff</a></strong>
		<time class="date published time hide" datetime="2017-12-29T16:44:02-05:00" itemprop="datePublished" content="2017-12-29T16:44:02-05:00">December 29, 2017</time>
		<meta itemprop="dateModified" class="date updated" content="2018-01-07T07:02:05-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2017/12/collage17.jpg">
		  <meta itemprop="width" content="1200">
		  <meta itemprop="height" content="1200">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/114536/the-young-folks-top-50-albums-of-2017/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-111321 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-music category-music-reviews tag-featured tag-visions-of-a-life tag-wolf-alice" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/111321/album-review-wolf-alice-visions-of-a-life/" rel="bookmark" title="Album Review: Wolf Alice &#8211; “Visions of a Life”">
			<img width="570" height="300" data-original="https://www.theyoungfolks.com/wp-content/uploads/2017/10/wolf-alice-2-570x300.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" loading="lazy" />					<figure class="circle_rating small">
			<span>8</span>
			<svg width="50" height="50" viewBox="0 0 50 50" version="1.1" xmlns="http://www.w3.org/2000/svg">
			  <circle class="circle_base" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="0"></circle>
			 	<circle class="circle_perc" r="23" cx="25" cy="25" fill="transparent" stroke-dasharray="144.44" stroke-dashoffset="144.44" data-dashoffset="28.888"></circle>
			</svg>
		</figure>
				</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/music/music-reviews/" class="single_category_title category-link-1786" title="Music Reviews">Music Reviews</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/111321/album-review-wolf-alice-visions-of-a-life/" title="Album Review: Wolf Alice &#8211; “Visions of a Life”">Album Review: Wolf Alice &#8211; “Visions of a Life”</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/brilockhart/" title="Posts by Bri Lockhart" rel="author">Bri Lockhart</a></strong>
		<time class="date published time hide" datetime="2017-10-14T09:00:28-04:00" itemprop="datePublished" content="2017-10-14T09:00:28-04:00">October 14, 2017</time>
		<meta itemprop="dateModified" class="date updated" content="2017-10-13T23:33:12-04:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2017/10/wolf-alice-2.jpg">
		  <meta itemprop="width" content="1000">
		  <meta itemprop="height" content="1000">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/111321/album-review-wolf-alice-visions-of-a-life/">
							</aside>
	</article>    </div>
               
    <div class="small-6 medium-6 large-3 columns">
    	<article itemscope itemtype="http://schema.org/Article" class="post style1 solo post-68277 type-post status-publish format-standard has-post-thumbnail hentry category-featured category-music category-music-features tag-alabama-shakes tag-alexandre-desplat tag-amy-poehler tag-amy-winehouse tag-antonio-sanchez tag-asap-rocky tag-ashley-monroe tag-big-sean tag-bjork tag-bob-dylan tag-bruno-mars tag-charlie-puth tag-chris-stapleton tag-common tag-courtney-barnett tag-dangelo tag-death-cab-for-cutie tag-diplo tag-don-henley tag-dr-dre tag-drake tag-ed-sheeran tag-elle-king tag-ellie-goulding tag-featured tag-fetty-wap tag-florence-the-machine tag-foo-fighters tag-ghost tag-glen-hansard tag-grammys tag-grammys-2016 tag-hans-zimmer tag-highly-suspect tag-j-cole tag-james-bay tag-james-taylor tag-jason-isbell tag-jazmine-sullivan tag-joey-rory tag-john-legend tag-kanye-west tag-kasey-musgraves tag-keith-urban tag-kelly-clarkson tag-kendrick-lamar tag-lady-gaga tag-lianne-le-havas tag-little-big-town tag-louis-c-k tag-mark-ronson tag-maroon-5 tag-meghan-trainor tag-merle-haggard tag-miguel tag-muse tag-my-morning-jacket tag-nicki-minaj tag-nina-simone tag-patti-smith tag-roger-waters tag-sam-hunt tag-seth-macfarlane tag-slipknot tag-tame-impala tag-taylor-swift tag-the-dead-weather tag-the-weeknd tag-tori-kelly tag-wilco tag-wiz-khalifa tag-wolf-alice tag-wyatt-cenac" role="article">
		<figure class="post-gallery">
		<a href="https://www.theyoungfolks.com/music/68277/2016-grammy-nominations-our-thoughts-and-predictions/" rel="bookmark" title="2016 Grammy Nominations: Our Thoughts and Predictions">
			<img width="452" height="300" data-original="https://www.theyoungfolks.com/wp-content/uploads/2015/12/58th-Grammy-Logo.jpg" class="attachment-goodlife-latest-short size-goodlife-latest-short wp-post-image" alt="" loading="lazy" data-original-set="https://www.theyoungfolks.com/wp-content/uploads/2015/12/58th-Grammy-Logo.jpg 570w, https://www.theyoungfolks.com/wp-content/uploads/2015/12/58th-Grammy-Logo-300x199.jpg 300w" sizes="(max-width: 452px) 100vw, 452px" />					</a>
	</figure>
		<aside class="post-category"><a href="https://www.theyoungfolks.com/featured/" class="single_category_title category-link-12" title="Featured">Featured</a></aside>
	<header class="post-title entry-header">
		<h6 class="entry-title" itemprop="name headline"><a href="https://www.theyoungfolks.com/music/68277/2016-grammy-nominations-our-thoughts-and-predictions/" title="2016 Grammy Nominations: Our Thoughts and Predictions">2016 Grammy Nominations: Our Thoughts and Predictions</a></h6>	</header>
		<aside class="post-bottom-meta">
		<strong rel="author" itemprop="author" class="author hide"><a href="https://www.theyoungfolks.com/author/rgibbs/" title="Posts by Ryan Gibbs" rel="author">Ryan Gibbs</a></strong>
		<time class="date published time hide" datetime="2015-12-07T23:13:53-05:00" itemprop="datePublished" content="2015-12-07T23:13:53-05:00">December 7, 2015</time>
		<meta itemprop="dateModified" class="date updated" content="2015-12-10T18:59:24-05:00">
		<span class="hide" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<meta itemprop="name" content="The Young Folks">
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="/wp-content/uploads/2017/02/2017-logo-21.png">
			</span>
			<meta itemprop="url" content="https://www.theyoungfolks.com">
		</span>
				<span class="hide" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
		  <meta itemprop="url" content="https://www.theyoungfolks.com/wp-content/uploads/2015/12/58th-Grammy-Logo.jpg">
		  <meta itemprop="width" content="570">
		  <meta itemprop="height" content="378">
		</span>
				<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.theyoungfolks.com/music/68277/2016-grammy-nominations-our-thoughts-and-predictions/">
							</aside>
	</article>    </div>
    </div>
</aside>
<!-- End Related Posts -->		</div>
	</div>
		</div>
		</div><!-- End role["main"] -->
			
									<!-- Start Sub Footer -->
			<footer id="subfooter" role="contentinfo" class="dark ">
				<div class="row">
					<div class="small-12 columns">
						<div class="subfooter-menu-holder text-center">
															<a href="https://www.theyoungfolks.com/" class="logolink">
									<img src="https://cdn1.theyoungfolks.com/wp-content/uploads/2020/08/25135816/TYF-Logo-2020-updated-new.png" class="logoimg" alt="The Young Folks"/>
								</a>
														<div class="subfooter-menu"><ul id="menu-footer-menu" class="footer-menu"><li id="menu-item-24378" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-24378"><a href="https://www.theyoungfolks.com/">Home</a></li>
<li id="menu-item-146691" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-146691"><a href="https://www.theyoungfolks.com/about/">About</a></li>
<li id="menu-item-24380" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24380"><a href="https://www.theyoungfolks.com/write/">Write</a></li>
</ul></div>	
							<p>Copyright 2021 The Young Folks. All Rights Reserved </p>
						</div>
					</div>
				</div>
			</footer>
			<!-- End Sub Footer -->
				</section> <!-- End #content-container -->

</div> <!-- End #wrapper -->
	<a href="#" id="scroll_totop"><i class="fa fa-angle-up"></i></a>
	<div style="display:none">
	<div class="grofile-hash-map-925a2b4d67a0c3b1e77d71b4b2eeee96">
	</div>
	</div>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.4.0' id='mpp_gutenberg_tabs-js'></script>
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"theyoungfolks"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.22' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"161720 https:\/\/www.theyoungfolks.com\/?p=161720","disqusShortname":"theyoungfolks","disqusTitle":"Album Review: Wolf Alice \u2013 \u201cBlue Weekend\u201d","disqusUrl":"https:\/\/www.theyoungfolks.com\/music\/161720\/album-review-wolf-alice-blue-weekend\/","postId":"161720"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.22' id='disqus_embed-js'></script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/modern-footnotes/modern-footnotes.min.js?ver=1.4.4' id='modern_footnotes-js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=202252' id='grofiles-cards-js'></script>
<script type='text/javascript' id='wpgroho-js-extra'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=10.4' id='wpgroho-js'></script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-includes/js/comment-reply.min.js?ver=5.8.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/assets/js/vendor.min.js' id='thb-vendor-js'></script>
<script type='text/javascript' id='thb-app-js-extra'>
/* <![CDATA[ */
var themeajax = {"url":"https:\/\/www.theyoungfolks.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/themes/goodlife-wp/assets/js/app.min.js?ver=2.1.2' id='thb-app-js'></script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/jetpack/_inc/build/widgets/eu-cookie-law/eu-cookie-law.min.js?ver=20180522' id='eu-cookie-law-script-js'></script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.3.6' id='page-links-to-js'></script>
<script type='text/javascript' src='https://www.theyoungfolks.com/wp-includes/js/wp-embed.min.js?ver=5.8.2' id='wp-embed-js'></script>
<script src='https://stats.wp.com/e-202252.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.4',blog:'77923915',post:'161720',tz:'-5',srv:'www.theyoungfolks.com'} ]);
	_stq.push([ 'clickTrackerInit', '77923915', '161720' ]);
</script>
</body>
</html>